aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2014-05-06 14:23:36 -0700
committerSébastien Fabbro <bicatali@gentoo.org>2014-05-06 14:23:36 -0700
commit7e10f0d358e0b96c816318da433eed7a047df678 (patch)
tree155357dc0ad59f43046d58f0cbd87199a4be0a22
parentsci-physics/yoda: Initial import (diff)
downloadsci-7e10f0d358e0b96c816318da433eed7a047df678.tar.gz
sci-7e10f0d358e0b96c816318da433eed7a047df678.tar.bz2
sci-7e10f0d358e0b96c816318da433eed7a047df678.zip
sci-physics/rivet: Added doxygen generated docs
Package-Manager: portage-2.2.8-prefix
-rw-r--r--sci-physics/rivet/ChangeLog9
-rw-r--r--sci-physics/rivet/Manifest1
-rw-r--r--sci-physics/rivet/metadata.xml16
-rw-r--r--sci-physics/rivet/rivet-2.1.1.ebuild62
4 files changed, 88 insertions, 0 deletions
diff --git a/sci-physics/rivet/ChangeLog b/sci-physics/rivet/ChangeLog
new file mode 100644
index 000000000..8bf9dbd14
--- /dev/null
+++ b/sci-physics/rivet/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-physics/rivet
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*rivet-2.1.1 (06 May 2014)
+
+ 06 May 2014; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +rivet-2.1.1.ebuild:
+ sci-physics/rivet: Added doxygen generated docs
diff --git a/sci-physics/rivet/Manifest b/sci-physics/rivet/Manifest
new file mode 100644
index 000000000..98f2834b1
--- /dev/null
+++ b/sci-physics/rivet/Manifest
@@ -0,0 +1 @@
+DIST Rivet-2.1.1.tar.bz2 4084261 SHA256 eefa936de6f6c34a6bab39899841f3189d7621c8ba227032f0f32e6e20dfcf85 SHA512 ee1ed8741b539aa773ba7ef9b704bfe0cc5aa1683ad2f4eac5cffc798ac989f041383e38852afb0353a59bdf887bb24c1491407ad4a5f68700c481b5e8008ebf WHIRLPOOL 1ee7cd016cc6ab3a843edc1655dce4bfc251e96bffdc157bda653204e99e997f6f23427af654bb8914314b82103502674fd89637c2acf72529bf7976fb707aaf
diff --git a/sci-physics/rivet/metadata.xml b/sci-physics/rivet/metadata.xml
new file mode 100644
index 000000000..306be1ac5
--- /dev/null
+++ b/sci-physics/rivet/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription>
+ The Rivet project (Robust Independent Validation of Experiment and
+ Theory) is a toolkit for validation of Monte Carlo event
+ generators. It provides a large (and ever growing) set of
+ experimental analyses useful for MC generator development,
+ validation, and tuning, as well as a convenient infrastructure for
+ adding your own analyses. Rivet is the most widespread way by which
+ analysis code from the LHC and other high-energy collider
+ experiments is preserved for comparison to and development of future
+ theory models.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-physics/rivet/rivet-2.1.1.ebuild b/sci-physics/rivet/rivet-2.1.1.ebuild
new file mode 100644
index 000000000..c7a82bd5c
--- /dev/null
+++ b/sci-physics/rivet/rivet-2.1.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 autotools-utils bash-completion-r1
+
+MYP=Rivet-${PV}
+
+DESCRIPTION="Toolkit for validation of Monte Carlo HEP event generators"
+HOMEPAGE="http://rivet.hepforge.org/"
+
+SRC_URI="http://www.hepforge.org/archive/${PN}/${MYP}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc python static-libs"
+
+RDEPEND="
+ dev-libs/boost:0=
+ sci-libs/gsl:0=
+ sci-physics/fastjet:0=[plugins]
+ sci-physics/hepmc:0=
+ sci-physics/yoda:0=[python]
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex,dot] )
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MYP}"
+
+#PATCHES=( "${FILESDIR}"/${P}-system-yaml-cpp.patch )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable python pyext)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && doxygen Doxyfile
+}
+
+src_install() {
+ autotools-utils_src_install
+ newbashcomp "${ED}"/usr/share/Rivet/rivet-completion rivet
+ use doc && dohtml -r doxy/html/* && dodoc doc/rivet-manual.pdf
+}