aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2023-07-26 20:30:36 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2023-07-27 00:15:07 +0200
commit7f84924d9383774b9cfa01d9f4d5c395b2ee9fa2 (patch)
tree834da7e04e56a321b84d3ccbca0588b8825986f3
parentsci-physics/hepunits: new package, add 2.3.2, 9999 (diff)
downloadsci-7f84924d9383774b9cfa01d9f4d5c395b2ee9fa2.tar.gz
sci-7f84924d9383774b9cfa01d9f4d5c395b2ee9fa2.tar.bz2
sci-7f84924d9383774b9cfa01d9f4d5c395b2ee9fa2.zip
sci-physics/particle: new package, add 0.23.0, 9999
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--sci-physics/particle/Manifest1
-rw-r--r--sci-physics/particle/metadata.xml19
-rw-r--r--sci-physics/particle/particle-0.23.0.ebuild42
-rw-r--r--sci-physics/particle/particle-9999.ebuild42
4 files changed, 104 insertions, 0 deletions
diff --git a/sci-physics/particle/Manifest b/sci-physics/particle/Manifest
new file mode 100644
index 000000000..fbbcdada4
--- /dev/null
+++ b/sci-physics/particle/Manifest
@@ -0,0 +1 @@
+DIST particle-0.23.0.tar.gz 313512 BLAKE2B 33a0dc1cf612af8242b5080d0862f3b1e587254b46fa90f235cd6edba3919594c5077733600dfe88ad0959be889271c301324789abf0511a7fbe588942086877 SHA512 582c42beade0b28f28f3ee9f83f6d8cc75558f8a9aa5fbe3679c7aa68af40bd04f374741211d6f214bb828c24a017a89b541f780739a36d61d85a2fd5e00b530
diff --git a/sci-physics/particle/metadata.xml b/sci-physics/particle/metadata.xml
new file mode 100644
index 000000000..1ec9e9afb
--- /dev/null
+++ b/sci-physics/particle/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <longdescription lang="en">
+ Particle provides a pythonic interface to the Particle Data Group (PDG) particle data tables and particle identification codes, with extended particle information and extra goodies.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">particle</remote-id>
+ <remote-id type="github">scikit-hep/particle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-physics/particle/particle-0.23.0.ebuild b/sci-physics/particle/particle-0.23.0.ebuild
new file mode 100644
index 000000000..c1f823d9d
--- /dev/null
+++ b/sci-physics/particle/particle-0.23.0.ebuild
@@ -0,0 +1,42 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_11 )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1
+
+DESCRIPTION="PDG particle data and identification codes"
+HOMEPAGE="https://github.com/scikit-hep/particle"
+
+LICENSE="BSD"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scikit-hep/particle"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ >=sci-physics/hepunits-2.0.0[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="${RDEPEND}"
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e 's:--benchmark-disable::' pyproject.toml || die
+}
+
+python_test() {
+ epytest --ignore tests/particle/test_performance.py
+}
diff --git a/sci-physics/particle/particle-9999.ebuild b/sci-physics/particle/particle-9999.ebuild
new file mode 100644
index 000000000..c1f823d9d
--- /dev/null
+++ b/sci-physics/particle/particle-9999.ebuild
@@ -0,0 +1,42 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_11 )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1
+
+DESCRIPTION="PDG particle data and identification codes"
+HOMEPAGE="https://github.com/scikit-hep/particle"
+
+LICENSE="BSD"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scikit-hep/particle"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ >=sci-physics/hepunits-2.0.0[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="${RDEPEND}"
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e 's:--benchmark-disable::' pyproject.toml || die
+}
+
+python_test() {
+ epytest --ignore tests/particle/test_performance.py
+}