aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-02-19 12:20:51 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-02-19 12:20:51 +0100
commit85794dc2e25580c628e007d4a528ffc2e24d4239 (patch)
tree0181d321436cc67e3c8774b577c33a01cf29cfe7
parentsci-biology/bowtie: add some compile patches from Debian (diff)
downloadsci-85794dc2.tar.gz
sci-85794dc2.tar.bz2
sci-85794dc2.zip
sci-biology/bowtie: working 1.2.2 snapshot
This ebuild keeps the bundled SeqAn-1.1 sources (a library of headers) and does not insist on system-wide installed SeqAn-1.4 (for which too many patches are needed and I am unable to evaluate/apply them all). Package-Manager: Portage-2.3.61, Repoman-2.3.12 Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
-rw-r--r--sci-biology/bowtie/bowtie-1.2.2_beta20190219.ebuild81
-rw-r--r--sci-biology/bowtie/bowtie-9999.ebuild81
-rw-r--r--sci-biology/bowtie/files/bowtie-1.2.2-fix-isa-return-type.patch22
3 files changed, 184 insertions, 0 deletions
diff --git a/sci-biology/bowtie/bowtie-1.2.2_beta20190219.ebuild b/sci-biology/bowtie/bowtie-1.2.2_beta20190219.ebuild
new file mode 100644
index 000000000..fcf0b4516
--- /dev/null
+++ b/sci-biology/bowtie/bowtie-1.2.2_beta20190219.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs git-r3
+
+DESCRIPTION="Popular short read aligner for Next-generation sequencing data"
+HOMEPAGE="http://bowtie-bio.sourceforge.net/"
+EGIT_REPO_URI="https://github.com/BenLangmead/bowtie.git"
+EGIT_BRANCH="bug_fixes"
+COMMIT="f253e204f5ba4565d14ae1b300ea6cb10dfe4660"
+
+LICENSE="Artistic"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="examples +tbb"
+
+RDEPEND="tbb? ( dev-cpp/tbb )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+# sci-biology/seqan:1.4"
+
+DOCS=( AUTHORS NEWS TUTORIAL doc/README )
+HTML_DOCS=( doc/{manual.html,style.css} )
+
+PATCHES=( "${FILESDIR}/bowtie-1.2.2-fix-isa-return-type.patch" )
+# not needed
+# "${FILESDIR}/${P}-fix-Intel-compilation.patch", obsoleted by https://github.com/BenLangmead/bowtie/commit/d8b661fb36c129cb9899fcd3689b3618036f8c7b
+#
+# still to be considered
+#PATCHES=(
+# "${FILESDIR}/${P}-_ContextLss-1.1-1.4.patch"
+# "${FILESDIR}/${P}-unbundle-seqan.patch"
+# "${FILESDIR}/${P}-fix-setBegin-call.patch"
+# "${FILESDIR}/${P}-seqan-popcount.patch"
+# "${FILESDIR}/${P}-seqan-rename-ChunkPool.patch"
+# "${FILESDIR}/${P}-seqan-rename-fill-to-resize.patch"
+# "${FILESDIR}/${P}-spelling.patch"
+# "${FILESDIR}/${P}-tbb-tinythread-missing.patch"
+#)
+
+src_prepare() {
+ default
+
+ # remove bundled library of headers, use system seqan 1.4
+ # rm -rf SeqAn-1.1/ third_party/ || die
+
+ # innocuous non-security flags, prevent log pollution
+ append-cxxflags \
+ -Wno-unused-local-typedefs \
+ -Wno-unused-but-set-variable \
+ -Wno-unused-variable
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CPP="$(tc-getCXX)" \
+ CFLAGS="" \
+ CXXFLAGS="" \
+ EXTRA_FLAGS="${LDFLAGS}" \
+ RELEASE_FLAGS="${CXXFLAGS}" \
+ WITH_TBB="$(usex tbb 1 0)"
+}
+
+src_install() {
+ dobin ${PN} ${PN}-*
+
+ exeinto /usr/libexec/${PN}
+ doexe scripts/*
+
+ newman MANUAL ${PN}.1
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r genomes indexes
+ fi
+}
diff --git a/sci-biology/bowtie/bowtie-9999.ebuild b/sci-biology/bowtie/bowtie-9999.ebuild
new file mode 100644
index 000000000..d54d0a544
--- /dev/null
+++ b/sci-biology/bowtie/bowtie-9999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs git-r3
+
+DESCRIPTION="Popular short read aligner for Next-generation sequencing data"
+HOMEPAGE="http://bowtie-bio.sourceforge.net/"
+EGIT_REPO_URI="https://github.com/BenLangmead/bowtie.git"
+EGIT_BRANCH="bug_fixes"
+
+LICENSE="Artistic"
+SLOT="1"
+KEYWORDS=""
+
+IUSE="examples +tbb"
+
+RDEPEND="tbb? ( dev-cpp/tbb )"
+DEPEND="${RDEPEND}
+ sci-biology/seqan:1.4
+ app-arch/unzip"
+
+DOCS=( AUTHORS NEWS TUTORIAL doc/README )
+HTML_DOCS=( doc/{manual.html,style.css} )
+
+PATCHES=( "${FILESDIR}/bowtie-9999-fix-isa-return-type.patch" )
+# not needed
+# "${FILESDIR}/${P}-fix-Intel-compilation.patch", obsoleted by https://github.com/BenLangmead/bowtie/commit/d8b661fb36c129cb9899fcd3689b3618036f8c7b
+#PATCHES=(
+# "${FILESDIR}/${P}-_ContextLss-1.1-1.4.patch"
+# "${FILESDIR}/${P}-fix-Intel-compilation.patch"
+# "${FILESDIR}/${P}-unbundle-seqan.patch"
+#)
+# other patches to be still considered
+# "${FILESDIR}/${P}-fix-setBegin-call.patch"
+# "${FILESDIR}/${P}-seqan-popcount.patch"
+# "${FILESDIR}/${P}-seqan-rename-ChunkPool.patch"
+# "${FILESDIR}/${P}-seqan-rename-fill-to-resize.patch"
+# "${FILESDIR}/${P}-spelling.patch"
+# "${FILESDIR}/${P}-tbb-tinythread-missing.patch"
+#)
+
+src_prepare() {
+ default
+
+ # remove bundled libraries, use system seqan 1.4
+ # rm -rf SeqAn-1.1/ third_party/ || die
+
+ # innocuous non-security flags, prevent log pollution
+ append-cxxflags \
+ -Wno-unused-local-typedefs \
+ -Wno-unused-but-set-variable \
+ -Wno-unused-variable
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CPP="$(tc-getCXX)" \
+ CFLAGS="" \
+ CXXFLAGS="" \
+ EXTRA_FLAGS="${LDFLAGS}" \
+ RELEASE_FLAGS="${CXXFLAGS}" \
+ WITH_TBB="$(usex tbb 1 0)"
+}
+
+src_install() {
+ dobin ${PN} ${PN}-*
+
+ exeinto /usr/libexec/${PN}
+ doexe scripts/*
+
+ newman MANUAL ${PN}.1
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r genomes indexes
+ fi
+}
diff --git a/sci-biology/bowtie/files/bowtie-1.2.2-fix-isa-return-type.patch b/sci-biology/bowtie/files/bowtie-1.2.2-fix-isa-return-type.patch
new file mode 100644
index 000000000..de19e42a8
--- /dev/null
+++ b/sci-biology/bowtie/files/bowtie-1.2.2-fix-isa-return-type.patch
@@ -0,0 +1,22 @@
+From 58c6ac97b1938909881877ef83167f5eff0e8ab1 Mon Sep 17 00:00:00 2001
+From: Rone Charles <rone_charles@fastmail.com>
+Date: Tue, 4 Sep 2018 21:06:39 -0400
+Subject: [PATCH] Fix isa return type
+
+---
+ ebwt.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ebwt.h b/ebwt.h
+index fe6300cc..8f886b8d 100644
+--- a/ebwt.h
++++ b/ebwt.h
+@@ -862,7 +862,7 @@ class Ebwt {
+ TIndexOffU* ftab() const { return _ftab; }
+ TIndexOffU* eftab() const { return _eftab; }
+ TIndexOffU* offs() const { return _offs; }
+- uint32_t* isa() const { return _isa; } /* check */
++ TIndexOffU* isa() const { return _isa; } /* check */
+ TIndexOffU* plen() const { return _plen; }
+ TIndexOffU* rstarts() const { return _rstarts; }
+ uint8_t* ebwt() const { return _ebwt; }