aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-28 18:53:32 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-28 18:53:32 +0100
commit87d0a0e19717c1cc7ec12418e9d012db9a97ede9 (patch)
tree230d33e87144ee2e3166ad2d2f5895da2ecae02e
parentdev-python/jupyter_client: Moved to tree; Drop old (diff)
downloadsci-87d0a0e1.tar.gz
sci-87d0a0e1.tar.bz2
sci-87d0a0e1.zip
dev-python/jupyter_console: Moved to tree
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/jupyter_console/ChangeLog4
-rw-r--r--dev-python/jupyter_console/Manifest1
-rw-r--r--dev-python/jupyter_console/jupyter_console-4.0.3.ebuild55
3 files changed, 4 insertions, 56 deletions
diff --git a/dev-python/jupyter_console/ChangeLog b/dev-python/jupyter_console/ChangeLog
index 9ae64c4d2..c3d446958 100644
--- a/dev-python/jupyter_console/ChangeLog
+++ b/dev-python/jupyter_console/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 28 Nov 2015; Marius Brehler <marbre@linux.sungazer.de> -Manifest,
+ -jupyter_console-4.0.3.ebuild:
+ dev-python/jupyter_console: Moved to tree
+
*jupyter_console-4.0.3 (11 Oct 2015)
11 Oct 2015; Sean Vig <sean.v.775@gmail.com> +jupyter_console-4.0.3.ebuild,
diff --git a/dev-python/jupyter_console/Manifest b/dev-python/jupyter_console/Manifest
deleted file mode 100644
index bb6efd81b..000000000
--- a/dev-python/jupyter_console/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST jupyter_console-4.0.3.tar.gz 22090 SHA256 555be6963a8f6431fbe1d424c7ffefee90824758058e4c9a2ab3aa045948eb85 SHA512 da9c311d881bbf61fbcea3c79e4dbdbe00f0f713772d0da4d30e0dec36ff5a6c5cbff3b996770f532c1e9c61ade1b1bf7a6f1ed28188ffd6900f6cc2ce7c0665 WHIRLPOOL 37139a87b182b9100284766ffb6e0b4c4e44b9bc2261a2d466920b0a23cf62d55f6a68cfb77da67a2eb3c316582fa7afaddcce69074b7597122e1c858c9a6c26
diff --git a/dev-python/jupyter_console/jupyter_console-4.0.3.ebuild b/dev-python/jupyter_console/jupyter_console-4.0.3.ebuild
deleted file mode 100644
index 0086a624d..000000000
--- a/dev-python/jupyter_console/jupyter_console-4.0.3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests --with-coverage --cover-package=jupyter_console jupyter_console || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}