aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobbert Harms <robbert@xkls.nl>2015-08-30 09:31:32 +0200
committerRobbert Harms <robbert@xkls.nl>2015-08-30 09:31:32 +0200
commit8b3816cb8ff03dc927608cc5575e4c079eaa3728 (patch)
treeebbec909e801280289d5c8e41e609ad4801e9f3c
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-8b3816cb.tar.gz
sci-8b3816cb.tar.bz2
sci-8b3816cb.zip
Version bump, adds nibabel-2.0.1. Also, version-2.0.1 now has python3_4 as python version dependency.
-rw-r--r--sci-libs/nibabel/Manifest1
-rw-r--r--sci-libs/nibabel/nibabel-2.0.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/nibabel/Manifest b/sci-libs/nibabel/Manifest
index 0c4e51b19..2abe48b49 100644
--- a/sci-libs/nibabel/Manifest
+++ b/sci-libs/nibabel/Manifest
@@ -1 +1,2 @@
DIST nibabel-1.3.0.tar.gz 2184060 SHA256 21488202a655eae76bb0c1170271c894bbf08bfae8246e79c71706233d4964b1 SHA512 6970a1345ce9c4ead484a15696bdcd918a292c354d0d5799359f1260a26e0b49a32507511ad5a9446a50c1d374113863e4d717c9b7bd16feecbe49d4f3da6119 WHIRLPOOL d117160713d9e2557cc957ffecc29a339f6ef14c0e60d962768cd4c8b2bbd4ef6a498b3f96f084256a4638a8264b6c8cd0189979329168d2d47c1ea119581541
+DIST nibabel-2.0.1.tar.gz 3390853 SHA256 29c7c371149079586c0cc6152a8dcfd32d1611d683a33306fa551cab93de23db SHA512 ed7bc0d8e8b4f31ed16215fe768b5c1ed27cd6459248b8600b92455e770fc83fc81361eb9533a15ff334352e72bc0400a924df40853c2fad23940f9d3c230b14 WHIRLPOOL 889972d95c50e5b8c6f7698974d9f2f6887d92cc151640adcd1121e10b1052b752f11b804f1d22bc6894795e2d8e1b4ac695e7e284e9333c31ec7d222d767478
diff --git a/sci-libs/nibabel/nibabel-2.0.1.ebuild b/sci-libs/nibabel/nibabel-2.0.1.ebuild
new file mode 100644
index 000000000..6d2f25d4a
--- /dev/null
+++ b/sci-libs/nibabel/nibabel-2.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Access a cacophony of neuro-imaging file formats"
+HOMEPAGE="http://nipy.org/nibabel/"
+SRC_URI="https://github.com/nipy/nibabel/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="dicom doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dicom? (
+ sci-libs/pydicom[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ )
+ "
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ distutils-r1_install_for_testing
+ cd "${BUILD_DIR}" || die
+ echo "backend: Agg" > matplotlibrc
+ MPLCONFIGDIR=. nosetests || die
+}