aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-30 17:34:00 +0100
committerAisha Tammy <gentoo@aisha.cc>2020-12-31 17:22:01 +0000
commit8c5c910f1881b80699c71e5fa46f90c7bb82ede3 (patch)
tree22f5b6855bf2c0dbad936d67dd88fd2a9b118f95
parentdev-python/sphinxcontrib-napoleon: new dep, copy from ::guru (diff)
downloadsci-8c5c910f.tar.gz
sci-8c5c910f.tar.bz2
sci-8c5c910f.zip
dev-python/snakemake: version bump, EAPI bump, bump py targets
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--dev-python/snakemake/Manifest2
-rw-r--r--dev-python/snakemake/snakemake-5.10.0.ebuild16
-rw-r--r--dev-python/snakemake/snakemake-5.31.1.ebuild56
3 files changed, 57 insertions, 17 deletions
diff --git a/dev-python/snakemake/Manifest b/dev-python/snakemake/Manifest
index 2d0455c44..738852f2f 100644
--- a/dev-python/snakemake/Manifest
+++ b/dev-python/snakemake/Manifest
@@ -1 +1 @@
-DIST snakemake-5.10.0.tar.gz 200876 BLAKE2B 2901af3bf270b18759143d60da618ae09bda2310ec5f25dc30475c0be98131e697326f46178bbb0a91c880074583b518fba673cfd35d8b1daeb218b716f6356a SHA512 101b2ab11d3377a68a3b35dbd3be01ab0d7075c38056f571f8b88fbd0eb49322c078a8f37c7fef84f0deda3491afbfeed602c603ffb518197f5ffdc12b4bd3fe
+DIST snakemake-5.31.1.tar.gz 7009148 BLAKE2B 9d707f027922b10b57336e05dd7e4898e9c60ae192fc13c9765bcebf708058a90e1ee5104c3fd01b4c51982f5f0a3055dee6b6fc4f4d6d71a76d8fae04e02d9a SHA512 57464355be82f353b29b3ec5da5001fa6ba66c45c002a63ad5edb74ca310a5288f93ac6244e9028bab19004d8c32f2e361168d378550d9cafe6ec00411bb0a73
diff --git a/dev-python/snakemake/snakemake-5.10.0.ebuild b/dev-python/snakemake/snakemake-5.10.0.ebuild
deleted file mode 100644
index 03e031837..000000000
--- a/dev-python/snakemake/snakemake-5.10.0.ebuild
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Make-like task language"
-HOMEPAGE="https://snakemake.readthedocs.io"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
diff --git a/dev-python/snakemake/snakemake-5.31.1.ebuild b/dev-python/snakemake/snakemake-5.31.1.ebuild
new file mode 100644
index 000000000..6a358a456
--- /dev/null
+++ b/dev-python/snakemake/snakemake-5.31.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Make-like task language"
+HOMEPAGE="https://snakemake.readthedocs.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# missing test dep google.cloud
+RESTRICT="test"
+
+BDEPEND="test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/google-api-python-client[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ net-libs/google-cloud-cpp
+)"
+
+RDEPEND="
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ratelimit[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/configargparse[${PYTHON_USEDEP}]
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/datrie[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/toposort[${PYTHON_USEDEP}]
+ sci-mathematics/pulp[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-napoleon \
+ dev-python/sphinx-argparse \
+ dev-python/sphinx_rtd_theme \
+ dev-python/docutils \
+ dev-python/recommonmark
+distutils_enable_tests pytest