aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-28 11:45:41 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-28 11:45:41 +0100
commit8ffcba1cb3eeaf2a71050b70113ce4da9df7f286 (patch)
treea779b4be0849b0f6e968a426380d7fa29e32d3f5
parentsci-chemistry/ambertools: Fix for gcc-5 and format-security (diff)
downloadsci-8ffcba1c.tar.gz
sci-8ffcba1c.tar.bz2
sci-8ffcba1c.zip
dev-python/ipyparallel: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/ipyparallel-4.1.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 180034005..707fe9ada 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,2 +1,3 @@
DIST ipyparallel-4.0.0.tar.gz 2270657 SHA256 cf4aae8d5c84becbe5bbda7791017f242efc2e017e9a9d54ac1ee4d73c707618 SHA512 6f2672b1f65a4487e619745c78a88621aa15b2cb08995dfb81584c9c05e96441b6b55e990edd495c6b26d939f9c237efd876e2ff65c1d9ba29fa62559ac9b1e7 WHIRLPOOL 41402dbfc4c1d57ba32433ff15d88d12a1df30c0891aa85d249cc119a8bba4b39415bc1e32215c63d982c18a5d6e6badbcd95654311d254aa3ab5d1b2198a962
DIST ipyparallel-4.0.2.tar.gz 2270476 SHA256 6b9e09ca441a45e055b97cb8e3e1dd30de85b935fae3aa0d97f138352fd3089b SHA512 a2edd8d821a6a902fc07e3f883f9dec99d3b51681e968c81163ae1ef5cf1c0ae9fc564cc0378e10b06da9cb822b58dab6bdba65ce441ce77908bdf3d0c500b16 WHIRLPOOL c7020d40cc708d9e9bc0b741c96cb5c79487ec881fc473bdc4eabd77051821a4ed377c2c24dc8a9e5255de2f4d70bd17f7ea62c5f9aff39340da17620be4741f
+DIST ipyparallel-4.1.0.tar.gz 2271608 SHA256 c943f6b3bbabb9332336d15474969e2a7a73d5b583f9786f7b357c75e4b1709a SHA512 19fff1ea57d9fcaec6525ce6e0c72ab63ab1245e32e485174a0691d2b48d8d2512af4055b77df82c7b30a8c071e1b6c5900d37e992f82f1597492e220e83d36f WHIRLPOOL ead35bc2166af0b221e730550689b09b7bf04148abcd754039f1c511acaa182ba50b593372f3e8bc627ae40a6117f9209cac476c1905bdc780f53de10666ffe1
diff --git a/dev-python/ipyparallel/ipyparallel-4.1.0.ebuild b/dev-python/ipyparallel/ipyparallel-4.1.0.ebuild
new file mode 100644
index 000000000..f95165708
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-4.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="http://ipython.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ !<dev-python/ipython-4.0.0[smp]
+ >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ iptest --coverage xml ipyparallel.tests || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}