aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSystem user; root <root@localhost.localdomain>2022-08-24 21:59:44 -0500
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-31 12:18:25 +0200
commit934c792bfe35860a3675d7f179f14ed7c135eede (patch)
tree4d4aa1a00a7ad99c479b9e5ad1c15324ee9fdffe
parentsci-biology/open-ephys-gui: Add 0.6.1 and update live ebuilds (diff)
downloadsci-934c792b.tar.gz
sci-934c792b.tar.bz2
sci-934c792b.zip
sci-misc: elmer-fem fix rpath and make compatible with qwt-6.2
Co-authored-by: Terry Wrist Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org> Closes: https://github.com/gentoo/sci/pull/1167
-rw-r--r--sci-misc/elmer-fem/elmer-fem-9.0-r2.ebuild (renamed from sci-misc/elmer-fem/elmer-fem-9.0-r1.ebuild)2
-rw-r--r--sci-misc/elmer-fem/files/elmer-fem-9.0-qwt-6.2.patch35
-rw-r--r--sci-misc/elmer-fem/files/elmer-fem-rpath.patch11
3 files changed, 48 insertions, 0 deletions
diff --git a/sci-misc/elmer-fem/elmer-fem-9.0-r1.ebuild b/sci-misc/elmer-fem/elmer-fem-9.0-r2.ebuild
index 6d810ed14..82e1c796f 100644
--- a/sci-misc/elmer-fem/elmer-fem-9.0-r1.ebuild
+++ b/sci-misc/elmer-fem/elmer-fem-9.0-r2.ebuild
@@ -40,6 +40,8 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-DCRComplexSolve-compile-error.patch"
"${FILESDIR}/${PN}-ElmerIce-compile.patch"
+ "${FILESDIR}/${PN}-rpath.patch"
+ "${FILESDIR}/${P}-qwt-6.2.patch"
)
S="${WORKDIR}/elmerfem-release-${PV}"
diff --git a/sci-misc/elmer-fem/files/elmer-fem-9.0-qwt-6.2.patch b/sci-misc/elmer-fem/files/elmer-fem-9.0-qwt-6.2.patch
new file mode 100644
index 000000000..13eaf1c5f
--- /dev/null
+++ b/sci-misc/elmer-fem/files/elmer-fem-9.0-qwt-6.2.patch
@@ -0,0 +1,35 @@
+From 48e9430ccb858ca5bda28b967a0c84b51e2404b2 Mon Sep 17 00:00:00 2001
+From: "E. Albiter" <ealbiter@gmail.com>
+Date: Fri, 15 Oct 2021 13:12:48 -0500
+Subject: [PATCH] Compatibility with Qwt 6.2. Fix for #293
+
+---
+ ElmerGUI/Application/src/convergenceview.h | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/ElmerGUI/Application/src/convergenceview.h b/ElmerGUI/Application/src/convergenceview.h
+index 377b644b99..4259eb730e 100755
+--- a/ElmerGUI/Application/src/convergenceview.h
++++ b/ElmerGUI/Application/src/convergenceview.h
+@@ -51,8 +51,8 @@
+ #include <qwt_plot_curve.h>
+ #include <qwt_plot_grid.h>
+ #include <qwt_legend.h>
+-/*#include <qwt_data.h> <-- deprecated in Qwt6, using qwt_compat.h instead*/
+-#include <qwt_compat.h>
++/*#include <qwt_data.h> <-- deprecated in Qwt6, using qwt_compat.h instead
++#include <qwt_compat.h> <-- Removed in Qwt 6.2 */
+ #include <qwt_text.h>
+ #include <qwt_scale_engine.h>
+
+@@ -76,8 +76,8 @@ class CurveData
+
+ private:
+ int d_count;
+- QwtArray<double> d_x;
+- QwtArray<double> d_y;
++ QVector<double> d_x;
++ QVector<double> d_y;
+ };
+
+ class Curve
diff --git a/sci-misc/elmer-fem/files/elmer-fem-rpath.patch b/sci-misc/elmer-fem/files/elmer-fem-rpath.patch
new file mode 100644
index 000000000..27249fef9
--- /dev/null
+++ b/sci-misc/elmer-fem/files/elmer-fem-rpath.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt.orig 2022-08-24 21:50:59.940905698 -0500
++++ b/CMakeLists.txt 2022-08-24 21:51:08.610804464 -0500
+@@ -479,7 +479,7 @@
+
+ # Set up rpaths to point ELMER_INSTALL_LIB_DIR
+ IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+- SET(ELMERSOLVER_RPATH_STRING "\$ORIGIN/../${ELMER_INSTALL_LIB_DIR}")
++ SET(ELMERSOLVER_RPATH_STRING "${ELMER_INSTALL_LIB_DIR}")
+ SET(ELMERLIB_RPATH_STRING "\$ORIGIN/")
+ ELSEIF(APPLE)
+ SET(ELMERSOLVER_RPATH_STRING "@loader_path/../${ELMER_INSTALL_LIB_DIR}")