aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTina Segessemann <tina.seg@bluewin.ch>2019-01-16 16:03:00 +0000
committerHorea Christian <horea.christ@yandex.com>2019-01-16 19:06:00 +0100
commit944ce87d136aaaf6b656691fc517c412b88dd50c (patch)
treeefb8cca61e685024bbe7d1d81c8b2609fd63e6ef
parentsci-biology/ABI-connectivity-data: (diff)
downloadsci-944ce87d.tar.gz
sci-944ce87d.tar.bz2
sci-944ce87d.zip
sci-biology/ABI-expression-data: new package
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Horea Christian <horea.christ@yandex.com>
-rw-r--r--sci-biology/ABI-expression-data/ABI-expression-data-0.1.ebuild34
-rw-r--r--sci-biology/ABI-expression-data/Manifest1
-rw-r--r--sci-biology/ABI-expression-data/metadata.xml16
3 files changed, 51 insertions, 0 deletions
diff --git a/sci-biology/ABI-expression-data/ABI-expression-data-0.1.ebuild b/sci-biology/ABI-expression-data/ABI-expression-data-0.1.ebuild
new file mode 100644
index 000000000..8fc372e55
--- /dev/null
+++ b/sci-biology/ABI-expression-data/ABI-expression-data-0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit check-reqs
+
+DESCRIPTION="Gene expression data form the Allen Mouse Brain data portal"
+HOMEPAGE="https://github.com/IBT-FMI/ABI-geneexpression-data"
+SRC_URI="
+ http://chymera.eu/distfiles/${P}.tar.xz
+ "
+
+LICENSE="fairuse"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND=""
+
+pkg_pretend() {
+ CHECKREQS_DISK_BUILD="7G"
+ CHECKREQS_DISK_USR="7G"
+ CHECKREQS_DISK_VAR="7G"
+ check-reqs_pkg_pretend
+}
+
+# We disable this phase to not check requirements twice.
+pkg_setup() { :; }
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r *
+}
diff --git a/sci-biology/ABI-expression-data/Manifest b/sci-biology/ABI-expression-data/Manifest
new file mode 100644
index 000000000..78ec76e0c
--- /dev/null
+++ b/sci-biology/ABI-expression-data/Manifest
@@ -0,0 +1 @@
+DIST ABI-expression-data-0.1.tar.xz 4059922432 BLAKE2B 367db2c707c83423c4b0d0755abdb823acc376f75e56be3dd1ff27b7fbed216dd0497874bbd4889c2621b6391e3891bd4c3ce20aaade9f0455bddf462a4f449b SHA512 6d152a5c17389135b6e6f8bce6af59a3adf244c166d87e8ea9bb29300f28e298c95016123dedeb59c262b2edd4fa51041b1d6adedd84c474d770d19f90f6f111
diff --git a/sci-biology/ABI-expression-data/metadata.xml b/sci-biology/ABI-expression-data/metadata.xml
new file mode 100644
index 000000000..3c5138f6b
--- /dev/null
+++ b/sci-biology/ABI-expression-data/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tina.seg@bluewin.ch</email>
+ <name>Tina Segessemann</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ A data library of gene expression maps collected
+ from the Allen Mouse Brain data portal.
+ </longdescription>
+</pkgmetadata>