aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-05-02 18:46:33 -0400
committerHorea Christian <chr@chymera.eu>2023-05-02 18:47:38 -0400
commit95e72af97822eef8d7f6273b1f2751b9f4fbb670 (patch)
tree515afa9efe756fa0470cfff21e83cdfd856be8f0
parentdev-python/tridesclous: update SRC_URI (diff)
downloadsci-95e72af97822eef8d7f6273b1f2751b9f4fbb670.tar.gz
sci-95e72af97822eef8d7f6273b1f2751b9f4fbb670.tar.bz2
sci-95e72af97822eef8d7f6273b1f2751b9f4fbb670.zip
sci-biology/neuroconv: brought back
This reverts commit 3f8ff1293b126e52932e381d68d6451f65f11229. Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--sci-biology/neuroconv/Manifest1
-rw-r--r--sci-biology/neuroconv/metadata.xml21
-rw-r--r--sci-biology/neuroconv/neuroconv-0.2.4.ebuild56
3 files changed, 78 insertions, 0 deletions
diff --git a/sci-biology/neuroconv/Manifest b/sci-biology/neuroconv/Manifest
new file mode 100644
index 000000000..54770b3ae
--- /dev/null
+++ b/sci-biology/neuroconv/Manifest
@@ -0,0 +1 @@
+DIST neuroconv-0.2.4.gh.tar.gz 757136 BLAKE2B a3a21b3a00667bde4461d91ade514891c8710f309413b100e1cccfd2684dfcbf9b21feaf4f58b3c5ff845aa08e69bf47467b411926eeb7d3b2862753302b1d9b SHA512 293038feae2704442b81ba0f012d775ba96d7bdffb6aaacaaebd09ca2f8b39e91ef4ea69c972abf060f0f9ab8cb76fedb77dda67455fa992edd52f0e6e504b0d
diff --git a/sci-biology/neuroconv/metadata.xml b/sci-biology/neuroconv/metadata.xml
new file mode 100644
index 000000000..efd00647e
--- /dev/null
+++ b/sci-biology/neuroconv/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <use>
+ <flag name="ecephys">Extracellular electrophysiology interfaces</flag>
+ <flag name="icephys">Intracellular electrophysiology interfaces</flag>
+ <flag name="ophys">Optical physiology interfaces</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">catalystneuro/roiextractors</remote-id>
+ <remote-id type="pypi">roiextractors</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-biology/neuroconv/neuroconv-0.2.4.ebuild b/sci-biology/neuroconv/neuroconv-0.2.4.ebuild
new file mode 100644
index 000000000..39046a1a5
--- /dev/null
+++ b/sci-biology/neuroconv/neuroconv-0.2.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Create NWB files from proprietary formats."
+HOMEPAGE="https://github.com/catalystneuro/neuroconv"
+SRC_URI="https://github.com/catalystneuro/neuroconv/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ecephys +icephys +ophys"
+
+RDEPEND="
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/hdmf[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/dandi-cli[${PYTHON_USEDEP}]
+ ecephys? (
+ dev-python/spikeinterface[${PYTHON_USEDEP}]
+ )
+ icephys? (
+ dev-python/neo[${PYTHON_USEDEP}]
+ )
+ ophys? (
+ sci-biology/roiextractors[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Additional tests require complex data getting infrastructure, ophys tests still have issues:
+ # https://github.com/catalystneuro/neuroconv/issues/305
+ local my_tests=( "tests/test_minimal" )
+ use ecephys && my_tests+=( "tests/test_ecephys" )
+ #use ophys && my_tests+=( "tests/test_ophys" )
+ epytest ${my_tests[*]// /|}
+}