aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-01 11:38:51 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-01 11:38:51 +0100
commit97692d227a146db8714608d39f07cbdfd57e1b02 (patch)
tree5c3c9db5089362a48f22c5beddc2f676de0b5144
parentsci-biology/cortex_var: fix sed calls (diff)
downloadsci-97692d22.tar.gz
sci-97692d22.tar.bz2
sci-97692d22.zip
sci-biology/cramtools: EAPI bump, fix install, add keywords
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-biology/cramtools/cramtools-3.0.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sci-biology/cramtools/cramtools-3.0.ebuild b/sci-biology/cramtools/cramtools-3.0.ebuild
index f0b8d7ac5..b57f4fb26 100644
--- a/sci-biology/cramtools/cramtools-3.0.ebuild
+++ b/sci-biology/cramtools/cramtools-3.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit java-pkg-2 java-ant-2
@@ -12,8 +12,7 @@ SRC_URI="https://github.com/enasequence/cramtools/archive/v3.0.tar.gz -> ${P}.ta
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
-IUSE=""
+KEYWORDS="~amd64"
DEPEND="
>=virtual/jdk-1.7:*
@@ -29,3 +28,7 @@ RDEPEND="
src_compile(){
ant -f build/build.xml runnable || die
}
+
+src_install() {
+ java-pkg_newjar "${P}.jar" "${PN}.jar"
+}