aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-07-19 16:24:15 +0200
committerHorea Christian <horea.christ@yandex.com>2016-07-19 16:24:15 +0200
commit985547a76c2c2072b0e29ea4651729174794c91f (patch)
tree4605614a9b072971dcc8210ce8ff3e301ffb9b55
parentsci-libs/nipype: taking version number from ebuild filename (diff)
downloadsci-985547a7.tar.gz
sci-985547a7.tar.bz2
sci-985547a7.zip
sci-libs/nipype: corrected PV reference and bumped to newest version
Package-Manager: portage-2.3.0
-rw-r--r--sci-libs/nipype/Manifest1
-rw-r--r--sci-libs/nipype/nipype-0.11.0.ebuild2
-rw-r--r--sci-libs/nipype/nipype-0.12.0.ebuild36
3 files changed, 38 insertions, 1 deletions
diff --git a/sci-libs/nipype/Manifest b/sci-libs/nipype/Manifest
index fbf9682c7..7d2db2dca 100644
--- a/sci-libs/nipype/Manifest
+++ b/sci-libs/nipype/Manifest
@@ -1 +1,2 @@
DIST nipype-0.11.0.tar.gz 2837853 SHA256 b1a69fbda7ce044ec24c2536f5733dfc251d16b4a713cab65f893d7e3357b437 SHA512 2b54cb5e57081b49565644a02d319477ecddb41ce6a6689c7f72f5381850afee2ce18ea4d0097ef0cb150fdff4980e1fc6a9c04d9a37610b65179727e8d8a82f WHIRLPOOL a406e44b13df4a90557f745753c19ee949b3267cf68245fb4ab3d23300e39aa481a36c47b690cf40681a1f1c4ffe772b88f36c71827debc23526604333683539
+DIST nipype-0.12.0.tar.gz 3088339 SHA256 ce4c481c8adbea50647b55f6cd7d902332b6de1ffdab4c185568f0bbe6c8b52a SHA512 cb882fb8d20ae8a12b1f333cb5812a1de608158cee0e75b367d97980c6b55e27e8217dbfbd57f5df7da980dd8ac86692c393553ac66ea0e77f7b9a232b6be728 WHIRLPOOL bc8b64f20b510d6ed1aaa84dfb4eeabe7a0420ccd7dc8075ed075f61126109c045eb79059aebb4a3e1022bd889dd0d95ce7e63045602f60d48ea0ba922054ac8
diff --git a/sci-libs/nipype/nipype-0.11.0.ebuild b/sci-libs/nipype/nipype-0.11.0.ebuild
index ea3f1c16c..7afa84181 100644
--- a/sci-libs/nipype/nipype-0.11.0.ebuild
+++ b/sci-libs/nipype/nipype-0.11.0.ebuild
@@ -13,7 +13,7 @@ inherit distutils-r1
DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
HOMEPAGE="http://nipy.sourceforge.net/nipype/"
-SRC_URI="https://github.com/nipy/nipype/archive/{PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/nipy/nipype/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
diff --git a/sci-libs/nipype/nipype-0.12.0.ebuild b/sci-libs/nipype/nipype-0.12.0.ebuild
new file mode 100644
index 000000000..7afa84181
--- /dev/null
+++ b/sci-libs/nipype/nipype-0.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# pyamg missing py3 support
+# PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
+HOMEPAGE="http://nipy.sourceforge.net/nipype/"
+SRC_URI="https://github.com/nipy/nipype/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pydotplus[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -v || die
+}