aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-07-27 13:24:17 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-07-27 13:24:17 +0200
commit9dd1c2d3bff9da42d205f38c55bdc150ad58da30 (patch)
tree488280190910e1918414b39cc77cb9e1ed27ba83
parentsci-biology/freebayes: adjust to current devel tree (diff)
downloadsci-9dd1c2d3.tar.gz
sci-9dd1c2d3.tar.bz2
sci-9dd1c2d3.zip
sci-libs/clfft: Version bump to 2.12.1
Package-Manager: portage-2.2.28
-rw-r--r--sci-libs/clfft/Manifest1
-rw-r--r--sci-libs/clfft/clfft-2.12.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/clfft/Manifest b/sci-libs/clfft/Manifest
index 38f9d6d0c..9d6f61432 100644
--- a/sci-libs/clfft/Manifest
+++ b/sci-libs/clfft/Manifest
@@ -1 +1,2 @@
DIST clfft-2.12.0.tar.gz 1008780 SHA256 c623a1b00cd8fe31583044dd98f8d0d0d2b3bda41628098ddb3edc8530099600 SHA512 8ee21847f2877989a1b6a62f62807e2cfd6d6845ed36702de775eb9dbccfed898e9969cce7bb93827745b5d65a5d91aaf07c565c92e65b6fefe3028efa9c23c9 WHIRLPOOL d582cb0d1946574eee187d3231ab5078980177af3b6752644e52d85999723dc21b31919916d6506050d9abadc104bec2978ae4759b70c2c3a0ffdd1fefb6396b
+DIST clfft-2.12.1.tar.gz 1009856 SHA256 3d0c6439730b243fb4890504d4aa71bc1f4d7d3f91dc79e257c5460dab40fcc5 SHA512 7eb5f1df45766d7ba80cf266264450e1dd733652a13e3fdb97109b7426515e04a96d887f11295f11fc9fe3fa43157652b65ec59a8c4a74a1dd384c47801b513f WHIRLPOOL 490147f396a8199a8e2ff48b30f6f2339119392133b1819a55b0ca54564746dedb1f6f758d891776f3dcc612162e6c50a96daeaedffda895ef9b19877d8a11e1
diff --git a/sci-libs/clfft/clfft-2.12.1.ebuild b/sci-libs/clfft/clfft-2.12.1.ebuild
new file mode 100644
index 000000000..aff0a7e51
--- /dev/null
+++ b/sci-libs/clfft/clfft-2.12.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_PN="clFFT"
+
+DESCRIPTION="Library containing FFT functions written in OpenCL"
+HOMEPAGE="https://github.com/clMathLibraries/clFFT"
+SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="callback_client +client examples test"
+
+RDEPEND="
+ >=sys-devel/gcc-4.6:*
+ virtual/opencl
+ dev-libs/boost"
+DEPEND="${RDEPEND}"
+# test? (
+# dev-cpp/gtest
+# sci-libs/fftw:3.0
+# )"
+
+# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
+# Therefore src_test() won't execute any test.
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_PN}-${PV}/src"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
+ die "Compilation with gcc older than 4.6 is not supported."
+ fi
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_CALLBACK_CLIENT="$(usex callback_client)"
+ -DBUILD_CLIENT="$(usex client)"
+ -DBUILD_SAMPLE="$(usex examples)"
+ -DBUILD_TEST="$(usex test)"
+ -DBoost_USE_STATIC_LIBS=OFF
+ )
+ cmake-utils_src_configure
+}