aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-01-09 00:18:30 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-01-09 00:18:30 +0100
commita3653f104325e48963deb241fd0a8867e516f76f (patch)
treec7f23700cb252189a48bc9ddebb2435a1c0be836
parentImport Upstream Changes (diff)
downloadsci-a3653f104325e48963deb241fd0a8867e516f76f.tar.gz
sci-a3653f104325e48963deb241fd0a8867e516f76f.tar.bz2
sci-a3653f104325e48963deb241fd0a8867e516f76f.zip
sci-biology/vt: new package, uses static libs
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-biology/vt/metadata.xml12
-rw-r--r--sci-biology/vt/vt-9999.ebuild51
2 files changed, 63 insertions, 0 deletions
diff --git a/sci-biology/vt/metadata.xml b/sci-biology/vt/metadata.xml
new file mode 100644
index 000000000..f68a1b6fa
--- /dev/null
+++ b/sci-biology/vt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/vt/vt-9999.ebuild b/sci-biology/vt/vt-9999.ebuild
new file mode 100644
index 000000000..ca197d3b3
--- /dev/null
+++ b/sci-biology/vt/vt-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="A tool set for short variant discovery in genetic sequence data"
+HOMEPAGE="https://github.com/atks/vt
+ http://genome.sph.umich.edu/wiki/vt"
+EGIT_REPO_URI="https://github.com/atks/vt.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="pdf"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pdf? ( dev-texlive/texlive-latex )"
+# >=sci-libs/htslib-1.3.2
+# dev-cpp/tclap
+# sci-libs/libsvm
+# dev-libs/libpcre
+# https://github.com/atks/Rmath
+
+# The 3rd party stuff is bundled because they have special modifications that
+# I made for vt, so it is probably not a good idea to depend on installed components.
+# For example TCLAP is modified partially, libsvm has some minor input/output format changes,
+# Rmath has the header inclusion to always generate the .a object file
+
+# Compiles statically bundled version of htslib and Rmath, only libpcre2 is dynamically linked
+src_prepare(){
+ sed -e "s/= -O3/= ${CFLAGS}/" -i Makefile || die
+ sed -e 's/^CXX = /CXX ?= /' -i Makefile || die
+ sed -e "s/-g -Wall -O2/${CFLAGS}/" -i lib/htslib/Makefile || die
+ sed -e "s/= gcc/= $(tc-getCC)/" -i lib/htslib/Makefile || die
+ sed -e "s/gcc -g -O3/$(tc-getCC) ${CFLAGS}/" -i lib/pcre2/Makefile || die
+ sed -e "s/-Wall -O3 -fPIC/${CXXFLAGS} -fPIC/" -i lib/libsvm/Makefile || die
+# # TODO zap bundled version of:
+# # lib/htslib (version 1.3)
+# # lib/tclap
+# # lib/Rmath
+# # lib/libsvm
+# # lib/pcre2
+}
+
+src_install(){
+ dobin vt
+}