aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-09-26 06:04:10 -0400
committerHorea Christian <chr@chymera.eu>2020-09-26 06:04:10 -0400
commita4498728340f997a1d328c0b8682d651e8c9cec1 (patch)
tree7c0689d9d9cd854d497d588d6c307a000f48f6e3
parentsci-biology/psychopy: rm old and live versions, PYTHON_COMPAT update (diff)
downloadsci-a4498728.tar.gz
sci-a4498728.tar.bz2
sci-a4498728.zip
sci-biology/nitime: version bump 0.8.1 and PYTHON_COMPAT update
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--sci-biology/nitime/Manifest1
-rw-r--r--sci-biology/nitime/nitime-0.6.ebuild6
-rw-r--r--sci-biology/nitime/nitime-0.8.1.ebuild38
-rw-r--r--sci-biology/nitime/nitime-9999.ebuild6
4 files changed, 45 insertions, 6 deletions
diff --git a/sci-biology/nitime/Manifest b/sci-biology/nitime/Manifest
index cb4790f33..2a8de31aa 100644
--- a/sci-biology/nitime/Manifest
+++ b/sci-biology/nitime/Manifest
@@ -1 +1,2 @@
DIST nitime-0.6.tar.gz 6205960 BLAKE2B 0ba316aea962d40f042586962420d08e3ef3b452f6431f51bd6f58c253e6c33b0af6cb3dc06ca3ba598d9c1c5c4cbc1844d0ccf3684ef2085fdc5747b70a7ff1 SHA512 ab91845ad1a29fbb8bf0a442668fb54976fe21d49ecfa57ec40f1596c10baf8684fd52aa3276a58d59faea4051621327cb50d5da8239ea8605365203cc009ae6
+DIST nitime-0.8.1.tar.gz 6200133 BLAKE2B e0afb126f01aaeb903f54e951554dcd12a2b912cdda9ab69bb9f26fa12f25849511e4a92c8fbeb278346d264559d2a39f31eac3b17ce7cfe69b2f69dc2cbed6b SHA512 2749dddb81971af78d4341474a0b45ef96b95fb4ea52400ee5229866b5bb132a16a9163575336d01d0f5441062ae30566ff2a6361d7e5b388ea993a147c2676b
diff --git a/sci-biology/nitime/nitime-0.6.ebuild b/sci-biology/nitime/nitime-0.6.ebuild
index fa11bca00..2fa80fdb8 100644
--- a/sci-biology/nitime/nitime-0.6.ebuild
+++ b/sci-biology/nitime/nitime-0.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
diff --git a/sci-biology/nitime/nitime-0.8.1.ebuild b/sci-biology/nitime/nitime-0.8.1.ebuild
new file mode 100644
index 000000000..a68f9e5f9
--- /dev/null
+++ b/sci-biology/nitime/nitime-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Time-series analysis of neuroscience data"
+HOMEPAGE="http://nipy.org/nitime/index.html"
+SRC_URI="https://github.com/nipy/nitime/archive/rel/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ "
+DEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ dev-python/cython[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-python/networkx[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${PN}-rel-${PV}"
+
+python_test() {
+ virtx pytest -v || die
+}
diff --git a/sci-biology/nitime/nitime-9999.ebuild b/sci-biology/nitime/nitime-9999.ebuild
index fe0d9f1da..192c53138 100644
--- a/sci-biology/nitime/nitime-9999.ebuild
+++ b/sci-biology/nitime/nitime-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1 git-r3