aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-06 11:37:02 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-06 11:37:47 +0100
commitab5fb3e71f8ff3a9d9166077b42e509c7e4c8239 (patch)
tree32235bfbe433f0356c16dd94f100e49ac36c6cd2
parentdev-python/texext: new dep of nibabel (diff)
downloadsci-ab5fb3e7.tar.gz
sci-ab5fb3e7.tar.bz2
sci-ab5fb3e7.zip
sci-libs/nibabel: version bump, fix doc building
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-libs/nibabel/Manifest1
-rw-r--r--sci-libs/nibabel/nibabel-3.2.1.ebuild36
-rw-r--r--sci-libs/nibabel/nibabel-9999.ebuild28
3 files changed, 48 insertions, 17 deletions
diff --git a/sci-libs/nibabel/Manifest b/sci-libs/nibabel/Manifest
index ebcfad955..31eb1f65e 100644
--- a/sci-libs/nibabel/Manifest
+++ b/sci-libs/nibabel/Manifest
@@ -1,2 +1,3 @@
DIST nibabel-2.5.1.tar.gz 4281663 BLAKE2B 361f1118d850a76fb8d2aa3ac6ebf0da711cf8df93aa6e2689201f3e713f35e028442ef00f69ce7a4a96d3c376b4966d0b76a087005123101f743b4d6074d3b2 SHA512 49de1a42113e64a56336e02f3143588b574c7b063b10b892ee125048451be701955e505bd1d51183327e2ee221f8364005fdd9fa7d256343113ab6ca1994820d
DIST nibabel-3.0.2.tar.gz 4336181 BLAKE2B b95ea57f28265eab627caea71f65c8ad1b0f868d40d80efb68f2dbb1e81f7d4f10b2da21d33f803abcd9441f3afe2c861f96828f8701f3981e4b7a4b2f97308e SHA512 51a10a72ade0382e43a006a0b9453b0c00f962a1c0d32c7a9da6ce3b9c95db05cd3bd672389d514107768b688a8315cba2e34d52bc845db3ca3e7912a1a0a8ac
+DIST nibabel-3.2.1.tar.gz 4442534 BLAKE2B 5a76275c0c3746bbe094789350f4f6d9dc17e332915c9f567660138c44ba50672415272d21d7b0834c77f4f9660950bda8c684f7664d58f0e5784b782384cb2f SHA512 5c5d95313f4b22462ba67c23d52dd34ed5d690c72a3137b21ac0bdbc4d20aa4f0c1d87d23c675f8c2f6e4335dc51fb9ab788ac8c63be56eec8ab8657ed95a6d7
diff --git a/sci-libs/nibabel/nibabel-3.2.1.ebuild b/sci-libs/nibabel/nibabel-3.2.1.ebuild
new file mode 100644
index 000000000..03a5f5b48
--- /dev/null
+++ b/sci-libs/nibabel/nibabel-3.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Access a cacophony of neuro-imaging file formats"
+HOMEPAGE="http://nipy.org/nibabel/"
+SRC_URI="https://github.com/nipy/nibabel/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dicom"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dicom? (
+ sci-libs/pydicom
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+BDEPEND="test? (
+ dev-python/pytest-doctestplus[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_sphinx doc/source dev-python/texext dev-python/numpydoc dev-python/matplotlib
+distutils_enable_tests pytest
diff --git a/sci-libs/nibabel/nibabel-9999.ebuild b/sci-libs/nibabel/nibabel-9999.ebuild
index 1fa595d11..611202ad7 100644
--- a/sci-libs/nibabel/nibabel-9999.ebuild
+++ b/sci-libs/nibabel/nibabel-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 git-r3
@@ -15,11 +16,11 @@ EGIT_REPO_URI="https://github.com/nipy/nibabel.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="dicom doc test"
-RESTRICT="!test? ( test )"
+IUSE="dicom"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dicom? (
@@ -27,17 +28,10 @@ RDEPEND="
dev-python/pillow[${PYTHON_USEDEP}]
)
"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-python_test() {
- cd "${BUILD_DIR}" || die
- echo "backend: Agg" > matplotlibrc
- MPLCONFIGDIR=. nosetests || die
-}
+BDEPEND="test? (
+ dev-python/pytest-doctestplus[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_sphinx doc/source dev-python/texext dev-python/numpydoc dev-python/matplotlib
+distutils_enable_tests pytest