aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-11-03 19:25:11 -0400
committerHorea Christian <chr@chymera.eu>2022-11-03 19:25:11 -0400
commitabacdd624ef295533c1e3b484a949c39b719d884 (patch)
tree544319c479b822544ad81a1b966e9c86efcfbd65
parentsci-physics/mcfm: new package, add 10.2.1 (diff)
downloadsci-abacdd62.tar.gz
sci-abacdd62.tar.bz2
sci-abacdd62.zip
dev-python/probeinterface: add 0.2.14
Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/probeinterface/Manifest1
-rw-r--r--dev-python/probeinterface/probeinterface-0.2.14.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/probeinterface/Manifest b/dev-python/probeinterface/Manifest
index dadc7b177..b2c8e3956 100644
--- a/dev-python/probeinterface/Manifest
+++ b/dev-python/probeinterface/Manifest
@@ -1,2 +1,3 @@
DIST probeinterface-0.2.11.gh.tar.gz 194474 BLAKE2B 806d1d83a47fdd3a3196386d08ac5cee7f8561547be819fe814f67265e5b1e31e35107a047ed5c5ae533123b318ab6dca4b37ec8ddb6d30431644402b499b5d2 SHA512 a7e12fba55b952dea3b062dde37178b02259424ec82f788bb210a94cf7fb48d325045f2451c3e764b68563948fe81b60d1d378827a15ae5470931b120b2bc10d
+DIST probeinterface-0.2.14.gh.tar.gz 210232 BLAKE2B 5a2c4fb5bc0f1315777a70b4292a30b135022e3a70608584070088c5ff42b0e1474714472a306196b390e103b45eea70cb89e01cc5dca90b0c31ac4f44810c24 SHA512 e0f5cf5b6560f8c4e578cab708308c36ecf81446c0db684b520e1436e864f2f4e0dce0015461c7cfcba19a0c1c54345b2d55b972de5f4338b02b90731cff52c2
DIST probeinterface-0.2.5.gh.tar.gz 154572 BLAKE2B fdd339fdeec0c71f404fb96665b7d92db29d15f84163924d4508cbe17bf88b4a95e0296c48cf8f878034ed0ce3b249e750363ad32385b2e9d3e83900a760bebe SHA512 fdf170e1e4057445b0c8701105c7e6283258b460b1250e992f9896d6d3a0feacf3eb7dc6f8b35b77f591e1654930bd20d548758ea01b5d4cdb15a57dac24c4f9
diff --git a/dev-python/probeinterface/probeinterface-0.2.14.ebuild b/dev-python/probeinterface/probeinterface-0.2.14.ebuild
new file mode 100644
index 000000000..ac66253b4
--- /dev/null
+++ b/dev-python/probeinterface/probeinterface-0.2.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python package to handle probe layout, geometry and wiring to device"
+HOMEPAGE="https://github.com/SpikeInterface/probeinterface"
+SRC_URI="https://github.com/SpikeInterface/probeinterface/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+# upstream doesn't pus test dir to pypi, https://github.com/SpikeInterface/probeinterface/issues/145
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Requires network access:
+ # https://github.com/SpikeInterface/probeinterface/issues/70
+ tests/test_library.py::test_download_probeinterface_file
+ tests/test_library.py::test_get_from_cache
+ tests/test_library.py::test_get_probe
+ tests/test_wiring.py::test_wire_probe
+)
+distutils_enable_tests pytest