aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-22 09:35:27 -0400
committerAisha Tammy <gentoo@aisha.cc>2020-09-22 09:35:27 -0400
commitac002458a28fad508b966a6e7ce571603fb6b603 (patch)
tree48c40e99a8d35377327973b0bf1219edeea8370e
parentdev-perl/opal-client: fix fatal errors (diff)
downloadsci-ac002458.tar.gz
sci-ac002458.tar.bz2
sci-ac002458.zip
sci-chemistry/coot: drop package
maintainer AWOL Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--sci-chemistry/coot/Manifest1
-rw-r--r--sci-chemistry/coot/coot-9999.ebuild177
-rw-r--r--sci-chemistry/coot/files/coot-9999-desktop.patch21
-rw-r--r--sci-chemistry/coot/files/coot-9999-libguile.patch29
-rw-r--r--sci-chemistry/coot/files/coot-9999-libtool.patch39
-rw-r--r--sci-chemistry/coot/files/coot-9999-sandbox-icons.patch16
-rw-r--r--sci-chemistry/coot/metadata.xml12
7 files changed, 0 insertions, 295 deletions
diff --git a/sci-chemistry/coot/Manifest b/sci-chemistry/coot/Manifest
deleted file mode 100644
index 20ba2aa9c..000000000
--- a/sci-chemistry/coot/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST greg-data.tar.gz 8677037 BLAKE2B bb2eac183598fed429c4977f9512e90335ccb988f154a3a29985668e6d3a90a19cb77ec61e0453e7294243b8dffd9b5ef6bb318bac2280b26eab37e2de25a18a SHA512 28396a5fa64af61e8932b565c6593ed27c4708e6a59158d62c94005bea9fa8c46562b6caba97011209a40705e5ec6711b949138dd8a23bb954df2ab4dfa9bb33
diff --git a/sci-chemistry/coot/coot-9999.ebuild b/sci-chemistry/coot/coot-9999.ebuild
deleted file mode 100644
index f13e9b681..000000000
--- a/sci-chemistry/coot/coot-9999.ebuild
+++ /dev/null
@@ -1,177 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools git-r3 python-single-r1 toolchain-funcs versionator
-
-MY_S2_PV=$(replace_version_separator 2 - ${PV})
-MY_S2_P=${PN}-${MY_S2_PV/pre1/pre-1}
-MY_S_P=${MY_S2_P}-${PR/r/revision-}
-MY_PV=${PV}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Crystallographic Object-Oriented Toolkit"
-HOMEPAGE="https://www2.mrc-lmb.cam.ac.uk/Personal/pemsley/coot/"
-SRC_URI="test? ( https://www2.mrc-lmb.cam.ac.uk/Personal/pemsley/coot/data/greg-data.tar.gz )"
-EGIT_REPO_URI="https://github.com/pemsley/coot.git"
-
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS=""
-IUSE="+openmp static-libs test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-SCIDEPS="
- sci-libs/libccp4
- sci-libs/clipper
- >=sci-libs/coot-data-2
- >=sci-libs/gsl-1.3
- sci-libs/fftw:2.1=
- sci-libs/mmdb:2
- sci-libs/monomer-db
- sci-libs/ssm
- sci-chemistry/reduce
- sci-chemistry/probe"
-
-XDEPS="
- gnome-base/libgnomecanvas
- gnome-base/librsvg:2
- media-libs/libpng:0=
- media-libs/freeglut
- x11-libs/gtk+:2
- x11-libs/goocanvas:0
- x11-libs/gtkglext
- virtual/opengl"
-
-SCHEMEDEPS="
- dev-scheme/net-http
- dev-scheme/guile-gui
- >=dev-scheme/guile-lib-0.1.6
- dev-scheme/guile-www
- >=x11-libs/guile-gtk-2.1"
-
-RDEPEND="
- ${SCIDEPS}
- ${XDEPS}
- ${SCHEMEDEPS}
- ${PYTHON_DEPS}
- dev-db/sqlite:3
- dev-libs/boost:0=[python,${PYTHON_USEDEP}]
- dev-libs/glib:2
- >=dev-libs/gmp-4.2.2-r2:0=
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- >=net-misc/curl-7.19.6
- net-dns/libidn:0
- sys-libs/readline:0=
- "
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=sys-devel/libtool-2.4-r2
- dev-lang/swig
- sys-devel/bc
- test? ( dev-scheme/greg )"
-
-pkg_setup() {
- if use openmp; then
- tc-has-openmp || die "Please use an OPENMP capable compiler"
- fi
- python-single-r1_pkg_setup
-}
-
-PATCHES=(
- "${FILESDIR}"/${P}-desktop.patch
- "${FILESDIR}"/${P}-sandbox-icons.patch
- "${FILESDIR}"/${P}-libtool.patch
- "${FILESDIR}"/${P}-libguile.patch
-)
-
-src_unpack() {
- git-r3_src_unpack
- if use test; then
- cd "${S}" || die
- unpack ${A}
- ln -sf . "${S}"/coot-ccp4 || die
- fi
-}
-
-src_prepare() {
- sed \
- -e '/export LD_LIBRARY/s:^:#:g' \
- -i src/coot.in || die
-
- sed \
- -e "s:AM_COOT_SYS_BUILD_TYPE:COOT_SYS_BUILD_TYPE=Gentoo-Linux-${EPYTHON}-gtk2 ; AC_MSG_RESULT([\$COOT_SYS_BUILD_TYPE]); AC_SUBST(COOT_SYS_BUILD_TYPE):g" \
- -i configure.ac || die
-
- default
- eautoreconf
-}
-
-src_configure() {
- # All the --with's are used to activate various parts.
- # Yes, this is broken behavior.
- local myeconfargs=(
- --with-goocanvas-prefix="${EPREFIX}/usr"
- --with-guile="${EPREFIX}/usr"
- --with-python="${EPREFIX}/usr"
- --with-guile-gtk
- --with-pygtk="${EPREFIX}/usr"
- --with-sqlite3
- --with-boost="${EPREFIX}/usr"
- )
- econf ${myeconfargs[@]}
-}
-
-src_test() {
- source "${EPREFIX}/etc/profile.d/40ccp4.setup.sh"
- mkdir "${T}"/coot_test || die
-
- export COOT_STANDARD_RESIDUES="${S}/standard-residues.pdb"
- export COOT_SCHEME_DIR="${S}/scheme/"
- export COOT_RESOURCES_FILE="${S}/cootrc"
- export COOT_PIXMAPS_DIR="${S}/pixmaps/"
- export COOT_DATA_DIR="${S}/"
- export COOT_PYTHON_DIR="${S}/python/"
- export PYTHONPATH="${COOT_PYTHON_DIR}:${S}/src:${PYTHONPATH}"
- export PYTHONHOME="${EPREFIX}"/usr/
- export CCP4_SCR="${T}"/coot_test/
- export CLIBD_MON="${EPREFIX}/usr/share/data/monomers/"
- export COOT_REF_STRUCTS="${EPREFIX}/usr/share/data/monomers/"
- export SYMINFO="${S}/syminfo.lib"
-
- export COOT_TEST_DATA_DIR="${S}"/greg-data/
-
- cat > command-line-greg.scm <<- EOF
- (use-modules (ice-9 greg))
- (set! greg-tools (list "greg-tests"))
- (set! greg-debug #t)
- (set! greg-verbose 5)
- (let ((r (greg-test-run)))
- (if r
- (coot-real-exit 0)
- (coot-real-exit 1)))
- EOF
-
- einfo "Running test with following paths ..."
- einfo "COOT_STANDARD_RESIDUES $COOT_STANDARD_RESIDUES"
- einfo "COOT_SCHEME_DIR $COOT_SCHEME_DIR"
- einfo "COOT_RESOURCES_FILE $COOT_RESOURCES_FILE"
- einfo "COOT_PIXMAPS_DIR $COOT_PIXMAPS_DIR"
- einfo "COOT_DATA_DIR $COOT_DATA_DIR"
- einfo "COOT_PYTHON_DIR $COOT_PYTHON_DIR"
- einfo "PYTHONPATH $PYTHONPATH"
- einfo "PYTHONHOME $PYTHONHOME"
- einfo "CCP4_SCR ${CCP4_SCR}"
- einfo "CLIBD_MON ${CLIBD_MON}"
- einfo "SYMINFO ${SYMINFO}"
-
- "${S}"/src/coot-bin --no-graphics --script command-line-greg.scm || die
- "${S}"/src/coot-bin --no-graphics --script python-tests/coot_unittest.py || die
-}
diff --git a/sci-chemistry/coot/files/coot-9999-desktop.patch b/sci-chemistry/coot/files/coot-9999-desktop.patch
deleted file mode 100644
index c264dd5a7..000000000
--- a/sci-chemistry/coot/files/coot-9999-desktop.patch
+++ /dev/null
@@ -1,21 +0,0 @@
- coot.desktop | 7 +++----
- 1 file changed, 3 insertions(+), 4 deletions(-)
-
-diff --git a/coot.desktop b/coot.desktop
-index 74aecf3..8668018 100644
---- a/coot.desktop
-+++ b/coot.desktop
-@@ -1,10 +1,9 @@
- [Desktop Entry]
- Type=Application
--Encoding=UTF-8
- Name=Coot
- Comment=Macromolecular model builder
- Exec=coot
--Icon=coot.png
-+Icon=coot
- Terminal=true
--Categories=Science;Graphics
--MimeType=chemical/x-pdb;chemical/x-mmcif;chemical/x-mdl-molfile
-+Categories=Science;Graphics;
-+MimeType=chemical/x-pdb;chemical/x-mmcif;chemical/x-mdl-molfile;
diff --git a/sci-chemistry/coot/files/coot-9999-libguile.patch b/sci-chemistry/coot/files/coot-9999-libguile.patch
deleted file mode 100644
index cbaccefb2..000000000
--- a/sci-chemistry/coot/files/coot-9999-libguile.patch
+++ /dev/null
@@ -1,29 +0,0 @@
- src/graphics-info-modelling.cc | 1 +
- src/graphics-info.cc | 2 ++
- 2 files changed, 3 insertions(+)
-
-diff --git a/src/graphics-info-modelling.cc b/src/graphics-info-modelling.cc
-index 05a63ad..4b7d129 100644
---- a/src/graphics-info-modelling.cc
-+++ b/src/graphics-info-modelling.cc
-@@ -102,6 +102,7 @@
-
- #include "utils/coot-utils.hh"
-
-+#include <libguile.h>
-
- // Idealize the geometry without considering the map.
- //
-diff --git a/src/graphics-info.cc b/src/graphics-info.cc
-index e2f9d52..76b6769 100644
---- a/src/graphics-info.cc
-+++ b/src/graphics-info.cc
-@@ -92,6 +92,8 @@
- #include "cc-interface-scripting.hh"
- #endif
-
-+#include <libguile.h>
-+
- // A few non-class members - should be somewhere else, I guess.
- //
- void initialize_graphics_molecules() {
diff --git a/sci-chemistry/coot/files/coot-9999-libtool.patch b/sci-chemistry/coot/files/coot-9999-libtool.patch
deleted file mode 100644
index 10c43ad55..000000000
--- a/sci-chemistry/coot/files/coot-9999-libtool.patch
+++ /dev/null
@@ -1,39 +0,0 @@
- configure.ac | 2 +-
- lbg/Makefile.am | 11 -----------
- 2 files changed, 1 insertion(+), 12 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 73d6ed7..b04dcd6 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -69,7 +69,7 @@ AC_LIB_PREPARE_MULTILIB
-
- AC_SUBST(COOT_STDTYPES)
-
--EXPORT_DYNAMIC_FLAG_SPEC=$export_dynamic_flag_spec
-+eval EXPORT_DYNAMIC_FLAG_SPEC=\"$export_dynamic_flag_spec\"
- AC_SUBST(EXPORT_DYNAMIC_FLAG_SPEC)
-
-
-diff --git a/lbg/Makefile.am b/lbg/Makefile.am
-index 1277afe..a79ebe0 100644
---- a/lbg/Makefile.am
-+++ b/lbg/Makefile.am
-@@ -43,17 +43,6 @@ pkginclude_HEADERS = lbg.hh wmolecule.hh flev-annotations.hh graphics-c-interfa
- lbg-drag-and-drop.hh qed-interface.hh alerts.hh pi-stacking.hh
- pkgincludedir = $(includedir)/coot/lbg
-
--# 20140521
--# lidia_LDFLAGS = -Wl,--export-dynamic
--#
--# Now we use EXPORT_DYNAMIC_FLAG_SPEC which usually evaluates to ${wl}--export-dynamic
--# (but not for MacOSX, where it Does The Right Thing (hopefully)).
--# We manually set the value of wl here, but maybe the Right Thing To Do for that is
--# run (eval) $($LIBTOOL --config | grep ^wl). How do I do that here though?
--# I don't understand. Maybe the setting of wl should be done in configure? But then
--# I have to force the output of libtool. Bleugh. Hmm...
--# Anyway, thankyou Gary Vaughan.
--wl=-Wl,
- lidia_LDFLAGS = $(EXPORT_DYNAMIC_FLAG_SPEC)
-
- # res spec output operator means we include libcoot-coord-utils
diff --git a/sci-chemistry/coot/files/coot-9999-sandbox-icons.patch b/sci-chemistry/coot/files/coot-9999-sandbox-icons.patch
deleted file mode 100644
index 2a9ff2d71..000000000
--- a/sci-chemistry/coot/files/coot-9999-sandbox-icons.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- pixmaps/icons/Makefile.am | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/pixmaps/icons/Makefile.am b/pixmaps/icons/Makefile.am
-index 0c183ae..dddc11a 100644
---- a/pixmaps/icons/Makefile.am
-+++ b/pixmaps/icons/Makefile.am
-@@ -11,6 +11,6 @@ install-data-local:
- CONTEXT=` echo $$icon | cut -d_ -f2`; \
- SIZE=` echo $$icon | cut -d_ -f3`; \
- ICONFILE=`echo $$icon | cut -d_ -f4`; \
-- mkdir -p $(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT; \
-- $(INSTALL_DATA) $(srcdir)/$$icon $(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
-+ mkdir -p $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT; \
-+ $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
- done;
diff --git a/sci-chemistry/coot/metadata.xml b/sci-chemistry/coot/metadata.xml
deleted file mode 100644
index 79d42af98..000000000
--- a/sci-chemistry/coot/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>jlec@gentoo.org</email>
- <name>Justin Lecher</name>
- </maintainer>
- <maintainer type="project">
- <email>sci-chemistry@gentoo.org</email>
- <name>Gentoo Chemistry Project</name>
- </maintainer>
-</pkgmetadata>