aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-05-31 11:17:22 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-05-31 11:17:22 +0200
commitaf17e687b7022a5f4727d594ef29c24b983d9dc2 (patch)
tree086559c9b363c329ee027c74926bd9a3fefc4555
parentsci-libs/elmer-eio: Update Manifest, fixes Bug #548398 (diff)
downloadsci-af17e687b7022a5f4727d594ef29c24b983d9dc2.tar.gz
sci-af17e687b7022a5f4727d594ef29c24b983d9dc2.tar.bz2
sci-af17e687b7022a5f4727d594ef29c24b983d9dc2.zip
dev-python/meshpy: Version bump; Implement python_test()
Package-Manager: portage-2.2.18
-rw-r--r--dev-python/meshpy/ChangeLog7
-rw-r--r--dev-python/meshpy/Manifest1
-rw-r--r--dev-python/meshpy/meshpy-2014.1.ebuild46
3 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/meshpy/ChangeLog b/dev-python/meshpy/ChangeLog
index 1f223ae38..084d36c0a 100644
--- a/dev-python/meshpy/ChangeLog
+++ b/dev-python/meshpy/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-python/meshpy
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*meshpy-2014.1 (31 May 2015)
+
+ 31 May 2015; Marius Brehler <marbre@linux.sungazer.de> +meshpy-2014.1.ebuild:
+ Version bump; Implement python_test()
+
*meshpy-2013.1.2 (14 Jun 2013)
14 Jun 2013; Justin Lecher <jlec@gentoo.org> -meshpy-0.91.2.ebuild,
diff --git a/dev-python/meshpy/Manifest b/dev-python/meshpy/Manifest
index 62fc27c21..607e920e1 100644
--- a/dev-python/meshpy/Manifest
+++ b/dev-python/meshpy/Manifest
@@ -1 +1,2 @@
DIST MeshPy-2013.1.2.tar.gz 1885753 SHA256 425ffa0f5a7dacfc1301bbb165ff78fbe6beacb0ab6c0a8dd581f565896c6762 SHA512 6004a609fc62ff44e5770a0d041da42eea1e185def5b1efca357d4cac3dcd34a7ccb5b0ca2d2f7fb4ba81bbc0251b8c998eb64bcff828f05cfc1a0a49385b9ae WHIRLPOOL 48266e5838c6a416622fc0cc804112af1331b9d74952030e225500f8f6426c4a9679088e8f3b06dbf26169128e33e2173bae73d198e20b5ffabd02c9e7762660
+DIST MeshPy-2014.1.tar.gz 1851120 SHA256 a090729c9b99360b2741099906361b2e9ba6373b97707817c9b81f66531380b6 SHA512 d8d7823df60250382577f67bb5ffd3b6523c84729c013220eaddccfa4b227839c2e0ffb285f87e752cf0dc5292eb1e5c693d04139d2fb33a05877e0b2b1bcecc WHIRLPOOL b84442d92933c5b5745c8a91ba4f65df80a1c94fd08668d8575c154de61ce0b67605f87b638341adb3f2b43ab8d2f6c82989e9d2bfcab177dabdf0119f07ab9b
diff --git a/dev-python/meshpy/meshpy-2014.1.ebuild b/dev-python/meshpy/meshpy-2014.1.ebuild
new file mode 100644
index 000000000..9727775af
--- /dev/null
+++ b/dev-python/meshpy/meshpy-2014.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="MeshPy"
+
+DESCRIPTION="Quality triangular and tetrahedral mesh generation for Python"
+HOMEPAGE="http://mathema.tician.de/software/meshpy http://pypi.python.org/pypi/MeshPy"
+SRC_URI="mirror://pypi/M/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ sed 's: delay = 10: delay = 1:g' -i aksetup_helper.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ mkdir "${BUILD_DIR}" || die
+ echo "BOOST_PYTHON_LIBNAME = [\'boost_${EPYTHON}-mt\']">> "${BUILD_DIR}"/siteconf.py
+ distutils-r1_python_compile
+}
+
+python_test() {
+ py.test || die
+}