aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-11-30 17:12:25 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2018-11-30 17:12:25 +0100
commitb42d6fd23f783fe21761e20fceb2291a21de61c0 (patch)
treea71572cc5cd4c2b2b28523590d3316f9e2ea2cc2
parentsci-biology/repeatmasker: update dependency on last supported db version (diff)
downloadsci-b42d6fd23f783fe21761e20fceb2291a21de61c0.tar.gz
sci-b42d6fd23f783fe21761e20fceb2291a21de61c0.tar.bz2
sci-b42d6fd23f783fe21761e20fceb2291a21de61c0.zip
sci-biology/repeatmasker: version bump, escape >= to avoid shell redirect
This introduces new repeatmasker-4.0.8 which can use repeatmasker-libraries releasded after 20160829. Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--sci-biology/repeatmasker/Manifest1
-rw-r--r--sci-biology/repeatmasker/files/repeatmasker-4.0.8__configure.patch118
-rw-r--r--sci-biology/repeatmasker/repeatmasker-4.0.6-r3.ebuild2
-rw-r--r--sci-biology/repeatmasker/repeatmasker-4.0.8-r1.ebuild111
4 files changed, 231 insertions, 1 deletions
diff --git a/sci-biology/repeatmasker/Manifest b/sci-biology/repeatmasker/Manifest
index 7d20d7bfb..fce5af28f 100644
--- a/sci-biology/repeatmasker/Manifest
+++ b/sci-biology/repeatmasker/Manifest
@@ -1 +1,2 @@
DIST RepeatMasker-open-4-0-6.tar.gz 266192837 BLAKE2B 1c46cb8dfa48a42093b72b3e61aba2a8c566617ca049064224b4fe8a080a6f75ff2e01d2f53cd9d26e5dfe39aaa8596b051fb1f2ff8dcdc74bab3a574b33f16a SHA512 3ca3593a736ab3741c01cfc79e6bdce0ff069cdd12e7e98864b4feeabf93422247aebaf0305d2121b99fd08166be2f7cc443080a2966331dc7f4c45b800a8a97
+DIST RepeatMasker-open-4-0-8.tar.gz 284258491 BLAKE2B 3a01fa951b4ac285ea5313b2c7dc679b22e265ab6475bc7a0eedbe87eb1c372b02fccd12b3b857ca47ba5d11ed0faa6a6c051ce52abc8f4cd4ab34a2c34a26f9 SHA512 7517bad308c331d2b6b4dbb65d4d425983da2e335fcf19ea4ff1e4618668adf7b5941ecf6f1e65205b307dbd0b67e1feb4b03a27a93abe2346f40d0fc443217a
diff --git a/sci-biology/repeatmasker/files/repeatmasker-4.0.8__configure.patch b/sci-biology/repeatmasker/files/repeatmasker-4.0.8__configure.patch
new file mode 100644
index 000000000..728bb75b1
--- /dev/null
+++ b/sci-biology/repeatmasker/files/repeatmasker-4.0.8__configure.patch
@@ -0,0 +1,118 @@
+--- RepeatMasker/configure.ori 2018-11-30 16:50:39.918872258 +0100
++++ RepeatMasker/configure 2018-11-30 17:00:33.255400144 +0100
+@@ -78,11 +78,10 @@
+ ## unqualified from another installation directory.
+ ##
+ if ( cwd() ne $FindBin::RealBin ) {
+- print "\n The RepeatMasker configure script must be run from\n"
++ die "\n The RepeatMasker configure script must be run from\n"
+ . " inside the RepeatMasker installation directory:\n\n"
+ . " $FindBin::RealBin\n\n"
+ . " Perhaps this is not the \"configure\" you are looking for?\n\n";
+- exit;
+ }
+
+ ##
+@@ -228,12 +227,12 @@
+ print "\n -- Building FASTA database...";
+ system(
+ "$rmLocation/util/buildRMLibFromEMBL.pl $rmLocation/Libraries/RepeatMaskerLib.embl > $rmLocation/Libraries/RepeatMasker.lib 2>/dev/null"
+-);
++) and die "$rmLocation/util/buildRMLibFromEMBL.pl $rmLocation/Libraries/RepeatMaskerLib.embl command filed with: $!";
+
+ ## Uncompress taxonomy.dat
+ if ( -s "$rmLocation/Libraries/taxonomy.dat.gz" ) {
+ print "\n -- Uncompressing taxonomy.dat...";
+- system( "gunzip $rmLocation/Libraries/taxonomy.dat.gz" );
++ system( "gunzip $rmLocation/Libraries/taxonomy.dat.gz" ) and die "gunzip $rmLocation/Libraries/taxonomy.dat.gz failed with: $!";
+ }
+
+ ##
+@@ -278,7 +277,7 @@
+ } while ( $goodParam != 1 );
+
+ # Initialize config from template.
+-system( "cp RepeatMaskerConfig.tmpl RepeatMaskerConfig.pm" );
++system( "cp RepeatMaskerConfig.tmpl RepeatMaskerConfig.pm" ) and die "cp RepeatMaskerConfig.tmpl RepeatMaskerConfig.pm failed with: $!";
+
+ # Make changes to file.
+ my $configFile = "RepeatMaskerConfig.pm";
+@@ -290,7 +289,7 @@
+ }
+ close IN;
+ close OUT;
+-system( "mv $configFile.tmp $configFile" );
++system( "mv $configFile.tmp $configFile" ) and die "mv $configFile.tmp $configFile failed with: $!";
+
+ ##
+ ## Search Engine Configuration
+@@ -452,7 +451,7 @@
+ }
+ close IN;
+ close OUT;
+- system( "mv $configFile.tmp $configFile" );
++ system( "mv $configFile.tmp $configFile" ) and die "mv $configFile.tmp $configFile failed with: $!";
+ }
+
+ }
+@@ -590,9 +589,9 @@
+ my $rmLocation = "$FindBin::Bin";
+ print "Building RMBlast frozen libraries..\n";
+ system( "$pgLocation/makeblastdb -dbtype nucl -in "
+- . "$rmLocation/Libraries/RepeatMasker.lib > /dev/null 2>&1" );
++ . "$rmLocation/Libraries/RepeatMasker.lib > /dev/null 2>&1" ) and die "$pgLocation/makeblastdb -dbtype nucl -in $rmLocation/Libraries/RepeatMasker.lib failed: $!";
+ system( "$pgLocation/makeblastdb -dbtype prot -in "
+- . "$rmLocation/Libraries/RepeatPeps.lib > /dev/null 2>&1" );
++ . "$rmLocation/Libraries/RepeatPeps.lib > /dev/null 2>&1" ) and die "$pgLocation/makeblastdb -dbtype prot -in $rmLocation/Libraries/RepeatPeps.lib failed with: $!";
+
+ my $pgDefault = &promptScreen(
+ "",
+@@ -665,9 +664,9 @@
+ my $rmLocation = "$FindBin::Bin";
+ print "Building WUBlast/ABBlast frozen libraries..\n";
+ system( "$wuLocation/xdformat -n -I "
+- . "$rmLocation/Libraries/RepeatMasker.lib > /dev/null 2>&1" );
++ . "$rmLocation/Libraries/RepeatMasker.lib > /dev/null 2>&1" ) and die "$wuLocation/xdformat -n -I $rmLocation/Libraries/RepeatMasker.lib failed with: $!";
+ system( "$wuLocation/xdformat -p -I "
+- . "$rmLocation/Libraries/RepeatPeps.lib > /dev/null 2>&1" );
++ . "$rmLocation/Libraries/RepeatPeps.lib > /dev/null 2>&1" ) and die "$wuLocation/xdformat -p -I $rmLocation/Libraries/RepeatPeps.lib failed with: $!";
+
+ my $wuDefault = &promptScreen(
+ "",
+@@ -733,7 +732,7 @@
+ }
+ }
+ else {
+- print "ERROR: Could not find nhmmer program in this directory!\n";
++ print "ERROR: Could not find nhmmer program in '$location' directory!\n";
+ }
+ }
+
+@@ -753,7 +752,7 @@
+ }
+ close IN;
+ close OUT;
+- system( "mv $configFile.tmp $configFile" );
++ system( "mv $configFile.tmp $configFile" ) and die "mv $configFile.tmp $configFile failed with: $!";
+
+ my $default = &promptScreen(
+ "",
+@@ -807,7 +806,7 @@
+ }
+ close IN;
+ close OUT;
+- system( "mv $configFile.tmp $configFile" );
++ system( "mv $configFile.tmp $configFile" ) and die "mv $configFile.tmp $configFile failed with: $!";
+
+ my $deDefault = &promptScreen(
+ "",
+@@ -843,9 +842,6 @@
+
+ my $answer = undef;
+
+- # Clear the screen
+- system( "clear" );
+-
+ print "\n\n\n";
+ print $screenText;
+ my $numLines = ( $screenText =~ s/(\n)/$1/g );
diff --git a/sci-biology/repeatmasker/repeatmasker-4.0.6-r3.ebuild b/sci-biology/repeatmasker/repeatmasker-4.0.6-r3.ebuild
index 2ff6c8be6..d41784eb7 100644
--- a/sci-biology/repeatmasker/repeatmasker-4.0.6-r3.ebuild
+++ b/sci-biology/repeatmasker/repeatmasker-4.0.6-r3.ebuild
@@ -104,7 +104,7 @@ pkg_postinst(){
einfo "Supported search engines are:"
optfeature "cross_match" sci-biology/phrap
optfeature "rmblast" sci-biology/rmblast
- optfeature "nhmmer" >=sci-biology/hmmer-3.1
+ optfeature "nhmmer" \>=sci-biology/hmmer-3.1
einfo "abblast/wublast from http://blast.advbiocomp.com/licensing"
einfo "repeatmasker-libraries-20160829 (RepBase 21.12) is the last"
einfo "version compatible with <repeatmasker-4.0.7"
diff --git a/sci-biology/repeatmasker/repeatmasker-4.0.8-r1.ebuild b/sci-biology/repeatmasker/repeatmasker-4.0.8-r1.ebuild
new file mode 100644
index 000000000..9b4af2312
--- /dev/null
+++ b/sci-biology/repeatmasker/repeatmasker-4.0.8-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils perl-module
+
+MY_PV=${PV//\./-}
+
+DESCRIPTION="Screen DNA sequences for interspersed repeats and low complexity DNA"
+HOMEPAGE="http://repeatmasker.org/"
+SRC_URI="http://www.repeatmasker.org/RepeatMasker-open-${MY_PV}.tar.gz"
+
+LICENSE="OSL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.8"
+RDEPEND="
+ dev-perl/Text-Soundex
+ sci-biology/phrap
+ >sci-biology/repeatmasker-libraries-20160829
+ sci-biology/rmblast
+ !sci-biology/trf
+ >=sci-biology/trf-bin-4.0.4
+"
+
+S="${WORKDIR}/RepeatMasker"
+
+PATCHES=( "${FILESDIR}"/"${P}"__configure.patch )
+
+src_configure() {
+ sed \
+ -e "s#/usr/bin/which#which#g" \
+ -e "s#/usr/bin/perl#perl#g" \
+ -i "${S}"/configure || die
+ perl_set_version
+ insinto ${VENDOR_LIB}
+ sed -e "s#/usr/perl5/lib/#${VENDOR_LIB}/#g" -i "${S}"/configure || die
+ # The below is wrong as it causes:
+ # Enter path [ /var/tmp/portage/sci-biology/repeatmasker-4.0.1-r1/work/RepeatMasker ]:
+ # -- Building monolithic RM database...sh: /var/tmp/portage/sci-biology/repeatmasker-4.0.1-r1/image///usr/share/repeatmasker/Libraries/RepeatMasker.lib: No such file or directory
+ # -e 's|> \($rmLocation/Libraries/RepeatMasker.lib\)|> '${D}'/\1|'
+ sed -i -e 's/system( "clear" );//' "${S}/configure" || die
+ mkdir -p "${ED}"/usr/share/repeatmasker/Libraries/ || die
+ #
+ # the below files is actually overwritten by buildRMLibFromEMBL.pl so the 'blah'
+ # item does not get installed
+ echo ">blah\natgc" > "${ED}"/usr/share/repeatmasker/Libraries/RepeatMasker.lib || die
+ # below try to define paths to trf, cross_match, rmblast and nhmmer as search tools
+ echo "
+env
+${S}
+${EPREFIX}/opt/trf/bin
+1
+${EPREFIX}/usr/bin
+Y
+2
+${EPREFIX}/usr/bin
+Y
+4
+${EPREFIX}/usr/bin
+Y
+5" | "${S}"/configure || die "configure failed"
+ sed -i -e "s|use lib $FindBin::RealBin;|use lib ${EPREFIX}/usr/share/${PN}/lib;|" \
+ -e "s|.*\(taxonomy.dat\)|${EPREFIX}/usr/share/${PN}/Libraries/\1|" \
+ -e "/$REPEATMASKER_DIR/ s|$FindBin::RealBin|${EPREFIX}/usr/share/${PN}|" \
+ "${S}"/{DateRepeats,ProcessRepeats,RepeatMasker,DupMasker,RepeatProteinMask,RepeatMaskerConfig.pm,Taxonomy.pm} || die
+}
+# configure failed to 'cp RepeatMaskerConfig.tmpl RepeatMaskerConfig.pm'
+# replace also /u1/local/bin/perl with proper Gentoo PATH
+
+src_install() {
+ exeinto /usr/share/${PN}
+ for i in DateRepeats ProcessRepeats RepeatMasker DupMasker RepeatProteinMask; do
+ doexe $i
+ dosym ../share/${PN}/$i /usr/bin/$i
+ done
+
+ perl_set_version
+ insinto "${VENDOR_LIB}"
+ doins "${S}"/*.pm "${S}"/Libraries/*.pm
+ # zap the supposedly misplaced RepeatAnnotationData.pm file
+ rm -r "${S}"/Libraries/*.pm || die
+
+ # if sci-biology/repeatmasker-libraries is installed prevent file collision
+ # and do NOT install Libraries/RepeatMaskerLib.embl file which contains
+ # a limited version of the file: 20110419-min
+ rm -r Libraries/RepeatMaskerLib.embl || die
+ insinto /usr/share/${PN}
+ doins -r util Matrices Libraries *.help
+ keepdir /usr/share/${PN}/Libraries
+
+ dodoc README.md INSTALL *.help
+}
+
+pkg_postinst(){
+ einfo "RepeatMasker provides bundled human repeats database"
+ einfo "from Dfam-1.0 database www.dfam.org"
+ einfo "You can configure which search search engine is to be used and"
+ einfo "PATHs to the search binaries are defined in"
+ einfo "${EPREFIX}/usr/share/${PN}/lib/RepeatMaskerConfig.pm"
+ einfo "Supported search engines are:"
+ optfeature "cross_match" sci-biology/phrap
+ optfeature "rmblast" sci-biology/rmblast
+ optfeature "nhmmer" \>=sci-biology/hmmer-3.1
+ einfo "abblast/wublast from http://blast.advbiocomp.com/licensing"
+ einfo "repeatmasker-libraries-20160829 (RepBase 21.12) was the last"
+ einfo "version compatible with <repeatmasker-4.0.7"
+}