aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-02 01:13:18 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-10-02 01:38:27 +0000
commitb6a975ddfc6833b2b1af8e560a3c5cc6b9dfe678 (patch)
treed284677f467f6eec88ab094f4d5a7cc80ce8acd4
parentmedia-libs/embree-bin: efficient cpu ray tracer (diff)
downloadsci-b6a975dd.tar.gz
sci-b6a975dd.tar.bz2
sci-b6a975dd.zip
dev-cpp/blitz: cpp tensor library
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--dev-cpp/blitz/Manifest1
-rw-r--r--dev-cpp/blitz/blitz-1.0.2_p20200524.ebuild40
-rw-r--r--dev-cpp/blitz/blitz-9999.ebuild40
-rw-r--r--dev-cpp/blitz/metadata.xml12
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-cpp/blitz/Manifest b/dev-cpp/blitz/Manifest
new file mode 100644
index 000000000..a4e6563b2
--- /dev/null
+++ b/dev-cpp/blitz/Manifest
@@ -0,0 +1 @@
+DIST blitz-1.0.2_p20200524.tar.gz 1297489 BLAKE2B bb2222a63d7763bd9e01b83fd2e895074e2be00bf32617f7ddfbb9e9fc5326daffdb3c5b2a95c257c416238732d53255387df46061a0cca406c33f13747cd060 SHA512 987ee4444b5c2a2d45cb5a66bc7a520e8849461346aab329c14707e53afef7b72325d199b2b619ac7c65c7a1f0995917c6cad2d526166c5ada5e23d0731163aa
diff --git a/dev-cpp/blitz/blitz-1.0.2_p20200524.ebuild b/dev-cpp/blitz/blitz-1.0.2_p20200524.ebuild
new file mode 100644
index 000000000..47a9e5d25
--- /dev/null
+++ b/dev-cpp/blitz/blitz-1.0.2_p20200524.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+CMAKE_MAKEFILE_GENERATOR=emake
+
+DESCRIPTION="multi-dimensional array library for C++"
+HOMEPAGE="https://github.com/blitzpp/blitz"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/blitzpp/blitz"
+else
+ COMMIT=39f885951a9b8b11f931f917935a16066a945056
+ SRC_URI="https://github.com/blitzpp/blitz/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="BSD LGPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ if use test; then
+ cmake_build check-testsuite check-benchmarks check-examples
+ else
+ cmake build
+ fi
+}
diff --git a/dev-cpp/blitz/blitz-9999.ebuild b/dev-cpp/blitz/blitz-9999.ebuild
new file mode 100644
index 000000000..47a9e5d25
--- /dev/null
+++ b/dev-cpp/blitz/blitz-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+CMAKE_MAKEFILE_GENERATOR=emake
+
+DESCRIPTION="multi-dimensional array library for C++"
+HOMEPAGE="https://github.com/blitzpp/blitz"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/blitzpp/blitz"
+else
+ COMMIT=39f885951a9b8b11f931f917935a16066a945056
+ SRC_URI="https://github.com/blitzpp/blitz/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="BSD LGPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ if use test; then
+ cmake_build check-testsuite check-benchmarks check-examples
+ else
+ cmake build
+ fi
+}
diff --git a/dev-cpp/blitz/metadata.xml b/dev-cpp/blitz/metadata.xml
new file mode 100644
index 000000000..e97c4322a
--- /dev/null
+++ b/dev-cpp/blitz/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata>