aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-04-12 03:57:22 -0400
committerHorea Christian <chr@chymera.eu>2020-04-12 03:57:22 -0400
commitbc44451d56ba7f057b2a476d23ebb6b32730c8ca (patch)
treeffbfefa063bb112dc0f64c6566b0a93783508844
parentsci-biology/bruker2nifti: fixed DISTUTILS_USE_SETUPTOOLS (diff)
downloadsci-bc44451d.tar.gz
sci-bc44451d.tar.bz2
sci-bc44451d.zip
sci-libs/nipype: revbump 1.1.1-r2
package supports newer prov Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--sci-libs/nipype/nipype-1.1.1-r2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sci-libs/nipype/nipype-1.1.1-r2.ebuild b/sci-libs/nipype/nipype-1.1.1-r2.ebuild
new file mode 100644
index 000000000..a83371092
--- /dev/null
+++ b/sci-libs/nipype/nipype-1.1.1-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
+HOMEPAGE="http://nipy.sourceforge.net/nipype/"
+SRC_URI="https://github.com/nipy/nipype/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/prov[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ <=dev-python/pytest-4.6.9[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+"
+# Dependency disabled as upstream test configuration which requires it fails
+#dev-python/pytest-xdist[${PYTHON_USEDEP}]
+
+RDEPEND="
+ >=dev-python/click-6.6[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ dev-python/pydotplus[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ sed -i\
+ -e "/'pytest>=%s' % PYTEST_MIN_VERSION,/d"\
+ -e "/'pytest-xdist',$/d"\
+ -e "/'prov==%s' % PROV_VERSION,/d"\
+ nipype/info.py || die
+ sed -i\
+ -e "s/prov==1\.5\.0/prov/g"\
+ requirements.txt rtd_requirements.txt || die
+ default
+}
+
+python_test() {
+ pytest -vv\
+ || die
+ # Upstream test configuration fails
+ #-c nipype/pytest.ini\
+ #--doctest-modules nipype\
+ #--cov nipype\
+ #--cov-config .coveragerc\
+ #--cov-report xml:cov.xml\
+}