aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-09-05 21:02:11 +0200
committerJustin Lecher <jlec@gentoo.org>2016-09-05 20:02:11 +0100
commitbee99748f997e6ea0529e60d91b950174dfab9eb (patch)
treeef39fb292bd889ec3063703e8ba2dfaaacd5e4a2
parentsci-libs/nipype: added threads REQ_USE (#668) (diff)
downloadsci-bee99748.tar.gz
sci-bee99748.tar.bz2
sci-bee99748.zip
Nibabel (#669)
* sci-libs/pydicom: updated EAPI and added python 3.5 compatibility Package-Manager: portage-2.3.0 * sci-libs/nibabel: version bump, updated EAPI, added python 3.5 compat Package-Manager: portage-2.3.0 * sci-libs/nibabel: updated EAPI, copyright, and python compat Package-Manager: portage-2.3.0
-rw-r--r--sci-libs/nibabel/Manifest1
-rw-r--r--sci-libs/nibabel/nibabel-1.3.0.ebuild4
-rw-r--r--sci-libs/nibabel/nibabel-2.0.1.ebuild6
-rw-r--r--sci-libs/nibabel/nibabel-2.1.0.ebuild42
-rw-r--r--sci-libs/nibabel/nibabel-9999.ebuild6
-rw-r--r--sci-libs/pydicom/pydicom-0.9.8.ebuild6
-rw-r--r--sci-libs/pydicom/pydicom-0.9.9.ebuild6
-rw-r--r--sci-libs/pydicom/pydicom-9999.ebuild6
8 files changed, 60 insertions, 17 deletions
diff --git a/sci-libs/nibabel/Manifest b/sci-libs/nibabel/Manifest
index 2abe48b49..8cae39355 100644
--- a/sci-libs/nibabel/Manifest
+++ b/sci-libs/nibabel/Manifest
@@ -1,2 +1,3 @@
DIST nibabel-1.3.0.tar.gz 2184060 SHA256 21488202a655eae76bb0c1170271c894bbf08bfae8246e79c71706233d4964b1 SHA512 6970a1345ce9c4ead484a15696bdcd918a292c354d0d5799359f1260a26e0b49a32507511ad5a9446a50c1d374113863e4d717c9b7bd16feecbe49d4f3da6119 WHIRLPOOL d117160713d9e2557cc957ffecc29a339f6ef14c0e60d962768cd4c8b2bbd4ef6a498b3f96f084256a4638a8264b6c8cd0189979329168d2d47c1ea119581541
DIST nibabel-2.0.1.tar.gz 3390853 SHA256 29c7c371149079586c0cc6152a8dcfd32d1611d683a33306fa551cab93de23db SHA512 ed7bc0d8e8b4f31ed16215fe768b5c1ed27cd6459248b8600b92455e770fc83fc81361eb9533a15ff334352e72bc0400a924df40853c2fad23940f9d3c230b14 WHIRLPOOL 889972d95c50e5b8c6f7698974d9f2f6887d92cc151640adcd1121e10b1052b752f11b804f1d22bc6894795e2d8e1b4ac695e7e284e9333c31ec7d222d767478
+DIST nibabel-2.1.0.tar.gz 3609438 SHA256 cb745509484ff5270a5a0bcf1f0693f32e4db0cd0171cedf82728376b12f4ac9 SHA512 2f0a20e92af9e398557b3f8828b73e46c62ee9887cbba19219d1a218994f4b726d9b873ce67c0f4a8872c992e84a262dab6ce823d427bb01dcd96d542de7bb6b WHIRLPOOL ecb9dbcca86cb979ff9f9cc3c8aa5d8be1a0d2e81618af77aa767ada9920027e9fb676d6afb7791e0a7087c2053226c68e9d671ab1fe35a7396eb66601cb41c1
diff --git a/sci-libs/nibabel/nibabel-1.3.0.ebuild b/sci-libs/nibabel/nibabel-1.3.0.ebuild
index 152663188..151cca9d3 100644
--- a/sci-libs/nibabel/nibabel-1.3.0.ebuild
+++ b/sci-libs/nibabel/nibabel-1.3.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="6"
PYTHON_COMPAT=( python2_7 )
diff --git a/sci-libs/nibabel/nibabel-2.0.1.ebuild b/sci-libs/nibabel/nibabel-2.0.1.ebuild
index af353f214..84e8c98fb 100644
--- a/sci-libs/nibabel/nibabel-2.0.1.ebuild
+++ b/sci-libs/nibabel/nibabel-2.0.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="6"
-PYTHON_COMPAT=( python2_7 python3_4 )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1
diff --git a/sci-libs/nibabel/nibabel-2.1.0.ebuild b/sci-libs/nibabel/nibabel-2.1.0.ebuild
new file mode 100644
index 000000000..84e8c98fb
--- /dev/null
+++ b/sci-libs/nibabel/nibabel-2.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Access a cacophony of neuro-imaging file formats"
+HOMEPAGE="http://nipy.org/nibabel/"
+SRC_URI="https://github.com/nipy/nibabel/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="dicom doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dicom? (
+ sci-libs/pydicom[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+ "
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ distutils-r1_install_for_testing
+ cd "${BUILD_DIR}" || die
+ echo "backend: Agg" > matplotlibrc
+ MPLCONFIGDIR=. nosetests || die
+}
diff --git a/sci-libs/nibabel/nibabel-9999.ebuild b/sci-libs/nibabel/nibabel-9999.ebuild
index d5216992f..7fd8f68de 100644
--- a/sci-libs/nibabel/nibabel-9999.ebuild
+++ b/sci-libs/nibabel/nibabel-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="6"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1 git-r3
diff --git a/sci-libs/pydicom/pydicom-0.9.8.ebuild b/sci-libs/pydicom/pydicom-0.9.8.ebuild
index 44a0bae19..4b84c9969 100644
--- a/sci-libs/pydicom/pydicom-0.9.8.ebuild
+++ b/sci-libs/pydicom/pydicom-0.9.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit distutils-r1
diff --git a/sci-libs/pydicom/pydicom-0.9.9.ebuild b/sci-libs/pydicom/pydicom-0.9.9.ebuild
index ec432d656..de647e06c 100644
--- a/sci-libs/pydicom/pydicom-0.9.9.ebuild
+++ b/sci-libs/pydicom/pydicom-0.9.9.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
-PYTHON_COMPAT=( python2_7 python3_4 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit distutils-r1
diff --git a/sci-libs/pydicom/pydicom-9999.ebuild b/sci-libs/pydicom/pydicom-9999.ebuild
index d992856c5..1d799003b 100644
--- a/sci-libs/pydicom/pydicom-9999.ebuild
+++ b/sci-libs/pydicom/pydicom-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit distutils-r1 git-r3