aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-01-20 02:52:12 +0000
committerAisha Tammy <gentoo@aisha.cc>2021-01-20 02:52:12 +0000
commitc2df401838e2bb3ea4409c9edd054999948890cf (patch)
treeabb44493ededc245dccea972afc574916a4a6e88
parentsci-libs/xblas: update HOMEPAGE (diff)
downloadsci-c2df401838e2bb3ea4409c9edd054999948890cf.tar.gz
sci-c2df401838e2bb3ea4409c9edd054999948890cf.tar.bz2
sci-c2df401838e2bb3ea4409c9edd054999948890cf.zip
x11-misc/envytools: add dated ebuild + EAPI 7
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--x11-misc/envytools/Manifest1
-rw-r--r--x11-misc/envytools/envytools-0_pre20200928.ebuild36
-rw-r--r--x11-misc/envytools/envytools-9999.ebuild30
3 files changed, 56 insertions, 11 deletions
diff --git a/x11-misc/envytools/Manifest b/x11-misc/envytools/Manifest
new file mode 100644
index 000000000..a34198fc4
--- /dev/null
+++ b/x11-misc/envytools/Manifest
@@ -0,0 +1 @@
+DIST envytools-0_pre20200928.tar.gz 1412065 BLAKE2B ce60047f44115f287d23065df63f5a0f5e8967e6daba1b2f4206b247c0e6ad0e525d9dfb057ba411adb0b4329a819746474459889ce0917edf567f6c4e53e586 SHA512 4f9e018834390768e92f398c1617973b0fe46a270e1f7dfa402e900c9c8c0e859dba8c865364339a6060d16d94de3a74abacea182c0c7c17f749ce8c8c1a27d2
diff --git a/x11-misc/envytools/envytools-0_pre20200928.ebuild b/x11-misc/envytools/envytools-0_pre20200928.ebuild
new file mode 100644
index 000000000..d36148e3e
--- /dev/null
+++ b/x11-misc/envytools/envytools-0_pre20200928.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake git-r3
+
+DESCRIPTION="Tools for people envious of nvidia's blob driver"
+HOMEPAGE="https://envytools.readthedocs.io/en/latest/"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/envytools/envytools"
+else
+ COMMIT="2d9931313aa14dfdf26f85be2576b181a14ad387"
+ SRC_URI="https://github.com/envytools/envytools/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/libxml2
+ x11-libs/libpciaccess
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ sys-devel/bison
+ sys-devel/flex
+"
+
+DOCS=( README.rst )
+
+PATCHES=( "${FILESDIR}"/${PN}-bison.patch )
diff --git a/x11-misc/envytools/envytools-9999.ebuild b/x11-misc/envytools/envytools-9999.ebuild
index d01476085..d36148e3e 100644
--- a/x11-misc/envytools/envytools-9999.ebuild
+++ b/x11-misc/envytools/envytools-9999.ebuild
@@ -1,27 +1,35 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3
+inherit cmake git-r3
DESCRIPTION="Tools for people envious of nvidia's blob driver"
-HOMEPAGE="https://github.com/pathscale/envytools"
-EGIT_REPO_URI="
- https://github.com/envytools/envytools.git"
+HOMEPAGE="https://envytools.readthedocs.io/en/latest/"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/envytools/envytools"
+else
+ COMMIT="2d9931313aa14dfdf26f85be2576b181a14ad387"
+ SRC_URI="https://github.com/envytools/envytools/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
-IUSE=""
RDEPEND="
dev-libs/libxml2
- x11-libs/libpciaccess"
-DEPEND="${RDEPEND}
+ x11-libs/libpciaccess
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
sys-devel/bison
- sys-devel/flex"
+ sys-devel/flex
+"
DOCS=( README.rst )