aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-09-28 05:00:42 -0400
committerHorea Christian <chr@chymera.eu>2020-09-28 05:00:42 -0400
commitc45b4080dc3d671fbaa6d6691a1e32ab6f7301fc (patch)
treeb44051d82c157c4a3c226483d3ca4db350e9da41
parentsci-chemistry/xplor-nih: removed unmaintained package (diff)
downloadsci-c45b4080dc3d671fbaa6d6691a1e32ab6f7301fc.tar.gz
sci-c45b4080dc3d671fbaa6d6691a1e32ab6f7301fc.tar.bz2
sci-c45b4080dc3d671fbaa6d6691a1e32ab6f7301fc.zip
sci-libs/plasma: removed unmaintained package
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--sci-libs/plasma/Manifest2
-rw-r--r--sci-libs/plasma/metadata.xml15
-rw-r--r--sci-libs/plasma/plasma-2.5.2.ebuild140
-rw-r--r--sci-libs/plasma/plasma-2.6.0.ebuild141
4 files changed, 0 insertions, 298 deletions
diff --git a/sci-libs/plasma/Manifest b/sci-libs/plasma/Manifest
deleted file mode 100644
index de70a9590..000000000
--- a/sci-libs/plasma/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST plasma_2.5.2.tar.gz 5354770 BLAKE2B 95530ade853e78a6db8372e6aa844b6a1472af40317611cc4e9a93fb0c0bc6f7088f8644e3d91e5991367a1321a0ceef544eb5dbb3a7bacd74a90bc36cba2bb9 SHA512 0ee93bd25fee721a76a28118ef21edcda84830516226ec97806cf52602c4f6df600f14db06d569413ccc83d4ae7f6d9d3ad0853132d0824b3e3efa41b53a8a3f
-DIST plasma_2.6.0.tar.gz 6264802 BLAKE2B 95ac398f3d1fcff38aa7c4dfd7317c43cdf3b6145ca859b43ff0e9c97ba56b07ca3439506d8839c86f9d1c3b1d64971d88b359329815addb22d58241a6861f6f SHA512 887ca2a121e67e9e8279a8da002a3a1e44d10e26e8bdbe7a9f30e6d10cee7ff6b78d95f39412a347c6a89f9fc2ff7fea02f71fdacca3c4fb9353d39381f35f2b
diff --git a/sci-libs/plasma/metadata.xml b/sci-libs/plasma/metadata.xml
deleted file mode 100644
index b21b3df93..000000000
--- a/sci-libs/plasma/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
-The Parallel Linear Algebra for Scalable Multi-core Architectures
-(PLASMA) project aims to address the critical and highly disruptive
-situation that is facing the Linear Algebra and High Performance
-Computing community due to the introduction of multi-core
-architectures.
-</longdescription>
-</pkgmetadata>
diff --git a/sci-libs/plasma/plasma-2.5.2.ebuild b/sci-libs/plasma/plasma-2.5.2.ebuild
deleted file mode 100644
index 1a33d3630..000000000
--- a/sci-libs/plasma/plasma-2.5.2.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils fortran-2 toolchain-funcs versionator multilib flag-o-matic
-
-MYP=${PN}_${PV}
-
-DESCRIPTION="Parallel Linear Algebra for Scalable Multi-core Architecture"
-HOMEPAGE="http://icl.cs.utk.edu/plasma/"
-SRC_URI="http://icl.cs.utk.edu/projectsfiles/plasma/pubs/${MYP}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples fortran static-libs test"
-
-RDEPEND="
- sys-apps/hwloc
- virtual/blas
- virtual/cblas
- virtual/lapack
- virtual/lapacke"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( sci-libs/lapacke-reference[tmg] )"
-
-S="${WORKDIR}/${MYP}"
-
-# TODO: virtual/{blas,cblas,lapack} serial and threaded. plasma works properly
-# with serial blas/lapack (see README). not doable dynamically with atlas
-
-static_to_shared() {
- local libstatic=${1}; shift
- local libname=$(basename ${libstatic%.a})
- local soname=${libname}$(get_libname $(get_version_component_range 1-2))
- local libdir=$(dirname ${libstatic})
-
- einfo "Making ${soname} from ${libstatic}"
- if [[ ${CHOST} == *-darwin* ]] ; then
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -dynamiclib -install_name "${EPREFIX}"/usr/lib/"${soname}" \
- -Wl,-all_load -Wl,${libstatic} \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
- else
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -shared -Wl,-soname=${soname} \
- -Wl,--whole-archive ${libstatic} -Wl,--no-whole-archive \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
- [[ $(get_version_component_count) -gt 1 ]] && \
- ln -s ${soname} ${libdir}/${libname}$(get_libname $(get_major_version))
- ln -s ${soname} ${libdir}/${libname}$(get_libname)
- fi
-}
-
-src_prepare() {
- # rename plasma to avoid collision (https://github.com/gentoo-science/sci/issues/34)
- # lib name conflict with kde plasma, rename
- PLASMA_LIBNAME=plasmca
- sed -i \
- -e "s/-lplasma/-l${PLASMA_LIBNAME}/g" \
- -e "s/libplasma.a/lib${PLASMA_LIBNAME}.a/" \
- Makefile.internal || die
-
- # distributed pc file not so useful, so redo it
- cat <<-EOF > ${PN}.pc
- prefix=${EPREFIX}/usr
- libdir=\${prefix}/$(get_libdir)
- includedir=\${prefix}/include/${PN}
- Name: ${PN}
- Description: ${DESCRIPTION}
- Version: ${PV}
- URL: ${HOMEPAGE}
- Libs: -L\${libdir} -l${PLASMA_LIBNAME} -lcoreblas -lquark
- Libs.private: -lm
- Cflags: -I\${includedir}
- Requires: blas cblas lapack lapacke hwloc
- EOF
-}
-
-src_configure() {
- cat <<-EOF > make.inc
- ARCH = $(tc-getAR)
- ARCHFLAGS = cr
- RANLIB = $(tc-getRANLIB)
- CC = $(tc-getCC)
- FC = $(tc-getFC)
- CFLAGS = ${CFLAGS} -DADD_ -fPIC $(has_version ">=virtual/lapacke-3.5" && echo "-DDOXYGEN_SHOULD_SKIP_THIS=1")
- FFLAGS = ${FFLAGS} -fPIC
- LOADER = $(tc-getFC)
- LIBBLAS = $($(tc-getPKG_CONFIG) --libs blas)
- LIBCBLAS = $($(tc-getPKG_CONFIG) --libs cblas)
- LIBLAPACK = $($(tc-getPKG_CONFIG) --libs lapack) -ltmglib
- LIBCLAPACK = $($(tc-getPKG_CONFIG) --libs lapacke)
- $(use fortran && echo "PLASMA_F90 = 1")
- EOF
-}
-
-src_compile() {
- emake lib
- #mv lib/libplasma.a lib/lib${PLASMA_LIBNAME}.a || die
- static_to_shared quark/libquark.a $($(tc-getPKG_CONFIG --libs hwloc)) -pthread
- static_to_shared lib/libcoreblas.a quark/libquark.so $($(tc-getPKG_CONFIG --libs cblas lapacke))
- static_to_shared lib/lib${PLASMA_LIBNAME}.a quark/libquark.so lib/libcoreblas.so
- if use static-libs; then
- emake cleanall
- sed 's/-fPIC//g' make.inc
- emake lib
- fi
-}
-
-src_test() {
- emake test
- cd testing
- LD_LIBRARY_PATH="../lib:../quark:${LD_LIBRARY_PATH}" ./plasma_testing.py || die
-}
-
-src_install() {
- dolib.so lib/lib*$(get_libname)* quark/libquark$(get_libname)*
- use static-libs && dolib.a lib/lib*.a quark/libquark.a
- insinto /usr/include/${PN}
- doins quark/quark{,_unpack_args}.h quark/icl_{hash,list}.h include/*.h
- use fortran && doins include/*.mod
- insinto /usr/$(get_libdir)/pkgconfig
- doins ${PN}.pc
- dodoc README ToDo ReleaseNotes
- use doc && dodoc docs/pdf/*.pdf && dohtml docs/doxygen/out/html/*
- if use examples; then
- emake -C examples cleanall
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-pkg_postinst() {
- elog "The plasma linear algebra library file has been renamed ${PLASMA_LIBNAME}"
- elog "to avoid collision with KDE plasma."
- elog "Compile and link your programs using the following command:"
- elog " pkg-config --cflags --libs plasma"
-}
diff --git a/sci-libs/plasma/plasma-2.6.0.ebuild b/sci-libs/plasma/plasma-2.6.0.ebuild
deleted file mode 100644
index 851a4d00e..000000000
--- a/sci-libs/plasma/plasma-2.6.0.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils fortran-2 toolchain-funcs versionator multilib flag-o-matic
-
-MYP=${PN}_${PV}
-SOVER=$(get_version_component_range 1)
-
-DESCRIPTION="Parallel Linear Algebra for Scalable Multi-core Architecture"
-HOMEPAGE="http://icl.cs.utk.edu/plasma/"
-SRC_URI="http://icl.cs.utk.edu/projectsfiles/plasma/pubs/${MYP}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${SOVER}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples fortran static-libs test"
-
-RDEPEND="
- sys-apps/hwloc
- virtual/blas
- virtual/cblas
- virtual/lapack
- virtual/lapacke"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( sci-libs/lapacke-reference[tmg] )"
-
-S="${WORKDIR}/${MYP}"
-
-# TODO: virtual/{blas,cblas,lapack} serial and threaded. plasma works properly
-# with serial blas/lapack (see README). not doable dynamically with atlas
-
-static_to_shared() {
- local libstatic=${1}; shift
- local libname=$(basename ${libstatic%.a})
- local soname=${libname}$(get_libname ${SOVER})
- local libdir=$(dirname ${libstatic})
-
- einfo "Making ${soname} from ${libstatic}"
- if [[ ${CHOST} == *-darwin* ]] ; then
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -dynamiclib -install_name "${EPREFIX}"/usr/lib/"${soname}" \
- -Wl,-all_load -Wl,${libstatic} \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
- else
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -shared -Wl,-soname=${soname} \
- -Wl,--whole-archive ${libstatic} -Wl,--no-whole-archive \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
- [[ $(get_version_component_count) -gt 1 ]] && \
- ln -s ${soname} ${libdir}/${libname}$(get_libname $(get_major_version))
- ln -s ${soname} ${libdir}/${libname}$(get_libname)
- fi
-}
-
-src_prepare() {
- # rename plasma to avoid collision (https://github.com/gentoo-science/sci/issues/34)
- # lib name conflict with kde plasma, rename
- PLASMA_LIBNAME=plasmca
- sed -i \
- -e "s/-lplasma/-l${PLASMA_LIBNAME}/g" \
- -e "s/libplasma.a/lib${PLASMA_LIBNAME}.a/" \
- Makefile.internal || die
-
- # distributed pc file not so useful, so redo it
- cat <<-EOF > ${PN}.pc
- prefix=${EPREFIX}/usr
- libdir=\${prefix}/$(get_libdir)
- includedir=\${prefix}/include/${PN}
- Name: ${PN}
- Description: ${DESCRIPTION}
- Version: ${PV}
- URL: ${HOMEPAGE}
- Libs: -L\${libdir} -l${PLASMA_LIBNAME} -lcoreblas -lquark
- Libs.private: -lm
- Cflags: -I\${includedir}
- Requires: blas cblas lapack lapacke hwloc
- EOF
-}
-
-src_configure() {
- cat <<-EOF > make.inc
- ARCH = $(tc-getAR)
- ARCHFLAGS = cr
- RANLIB = $(tc-getRANLIB)
- CC = $(tc-getCC)
- FC = $(tc-getFC)
- CFLAGS = ${CFLAGS} -DADD_ -fPIC $(has_version ">=virtual/lapacke-3.5" && echo "-DDOXYGEN_SHOULD_SKIP_THIS=1")
- FFLAGS = ${FFLAGS} -fPIC
- LOADER = $(tc-getFC)
- LIBBLAS = $($(tc-getPKG_CONFIG) --libs blas)
- LIBCBLAS = $($(tc-getPKG_CONFIG) --libs cblas)
- LIBLAPACK = $($(tc-getPKG_CONFIG) --libs lapack) -ltmglib
- LIBCLAPACK = $($(tc-getPKG_CONFIG) --libs lapacke)
- $(use fortran && echo "PLASMA_F90 = 1")
- EOF
-}
-
-src_compile() {
- emake lib
- #mv lib/libplasma.a lib/lib${PLASMA_LIBNAME}.a || die
- static_to_shared quark/libquark.a $($(tc-getPKG_CONFIG --libs hwloc)) -pthread
- static_to_shared lib/libcoreblas.a quark/libquark.so $($(tc-getPKG_CONFIG --libs cblas lapacke))
- static_to_shared lib/lib${PLASMA_LIBNAME}.a quark/libquark.so lib/libcoreblas.so
- if use static-libs; then
- emake cleanall
- sed 's/-fPIC//g' make.inc
- emake lib
- fi
-}
-
-src_test() {
- emake test
- cd testing
- LD_LIBRARY_PATH="../lib:../quark:${LD_LIBRARY_PATH}" ./plasma_testing.py || die
-}
-
-src_install() {
- dolib.so lib/lib*$(get_libname)* quark/libquark$(get_libname)*
- use static-libs && dolib.a lib/lib*.a quark/libquark.a
- insinto /usr/include/${PN}
- doins quark/quark{,_unpack_args}.h quark/icl_{hash,list}.h include/*.h
- use fortran && doins include/*.mod
- insinto /usr/$(get_libdir)/pkgconfig
- doins ${PN}.pc
- dodoc README ToDo ReleaseNotes
- use doc && dodoc docs/pdf/*.pdf && dohtml docs/doxygen/out/html/*
- if use examples; then
- emake -C examples cleanall
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-pkg_postinst() {
- elog "The plasma linear algebra library file has been renamed ${PLASMA_LIBNAME}"
- elog "to avoid collision with KDE plasma."
- elog "Compile and link your programs using the following command:"
- elog " pkg-config --cflags --libs plasma"
-}