aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-03 20:04:48 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-03 20:04:48 +0100
commitc8d5d7864ee4751077a339bc643515fcdc549021 (patch)
treec479bd8513dc31fe3f3c5667b528a884f79d7034
parentdev-python/pytorch-lightning: bump to 1.8.6 (diff)
downloadsci-c8d5d7864ee4751077a339bc643515fcdc549021.tar.gz
sci-c8d5d7864ee4751077a339bc643515fcdc549021.tar.bz2
sci-c8d5d7864ee4751077a339bc643515fcdc549021.zip
sci-libs/torchvision: add 0.14.1, drop 0.11.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-libs/torchvision/Manifest2
-rw-r--r--sci-libs/torchvision/torchvision-0.14.1.ebuild (renamed from sci-libs/torchvision/torchvision-0.11.2.ebuild)21
2 files changed, 12 insertions, 11 deletions
diff --git a/sci-libs/torchvision/Manifest b/sci-libs/torchvision/Manifest
index 8e703b008..2167de395 100644
--- a/sci-libs/torchvision/Manifest
+++ b/sci-libs/torchvision/Manifest
@@ -1 +1 @@
-DIST torchvision-0.11.2.tar.gz 9361872 BLAKE2B a3086b1ac8a05ab1f8dac13c5ee15f75274a96cebb72b48b525ac9721c961c67d742878efa7ef4c245a885904ea88d2c2dde311df8ef710563c3656c2629b644 SHA512 11891d19c1a17d27fbcc95b576a7bba7d2d2b96673661bc8488505aded9c70e7ee09229732d42eac4a590e11fb8f0066fb5a2d9f5b7fa95265f54d533ffc1359
+DIST torchvision-0.14.1.tar.gz 9265179 BLAKE2B 0708635b00ac7c2cf4e54799f1190f01f3240f53233695819f691313b8a369b8922520e2f3cf96184bab671877b5826b84e0936d9ca5b58004d6e2a098c6cbbf SHA512 08fb1e35da1c3f1d0446ef879d9b6a7ae839a5137c3b5b46ef8111c2ae890299e2b555d1bd3b3d61f96b8778b831d8f895487cf8a4e36e371fcd4b8acda67d1f
diff --git a/sci-libs/torchvision/torchvision-0.11.2.ebuild b/sci-libs/torchvision/torchvision-0.14.1.ebuild
index 765fd05b7..8ad8d7147 100644
--- a/sci-libs/torchvision/torchvision-0.11.2.ebuild
+++ b/sci-libs/torchvision/torchvision-0.14.1.ebuild
@@ -4,25 +4,28 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Datasets, transforms and models to specific to computer vision"
HOMEPAGE="https://github.com/pytorch/vision"
SRC_URI="https://github.com/pytorch/vision/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/vision-${PV}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
RDEPEND="
- dev-python/av[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- sci-libs/pytorch[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ ')
+ sci-libs/pytorch[${PYTHON_SINGLE_USEDEP}]
media-video/ffmpeg
dev-qt/qtcore:5
"
@@ -34,6 +37,4 @@ BDEPEND="
')
)"
-S="${WORKDIR}/vision-${PV}"
-
distutils_enable_tests pytest