aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-02-10 21:14:54 +0000
committerAisha Tammy <gentoo@aisha.cc>2021-02-10 21:14:54 +0000
commitc96c450a590f337fff700ab23109f81c6b1d0d1d (patch)
treeadb9bca807fccdc07861a4b1ea6137b877b15ffd
parentdev-util/boost-build: add missing patches and files. (diff)
downloadsci-c96c450a.tar.gz
sci-c96c450a.tar.bz2
sci-c96c450a.zip
dev-python/pynndescent: version bump to 0.5.2
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--dev-python/pynndescent/Manifest1
-rw-r--r--dev-python/pynndescent/pynndescent-0.5.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pynndescent/Manifest b/dev-python/pynndescent/Manifest
index 2a5f6dfae..e7ea7da50 100644
--- a/dev-python/pynndescent/Manifest
+++ b/dev-python/pynndescent/Manifest
@@ -1,2 +1,3 @@
DIST pynndescent-0.4.8.tar.gz 1134120 BLAKE2B bb82bf27edee6bb5f92e7ba9c762ffadffd16854450d28c2eda416b98ff0e67127860347748c663a094ddad44027db312b935a49fa60604146a9df1620edffe1 SHA512 e85feed2cc78e9a4364a61ce3c03b029dd0db643b4d9e7efa14dfda90e6e2512ba7a4dc083b440696b070262e2111f50b6dcb41915e26fe8d8332b47837ad9fc
DIST pynndescent-0.5.1.tar.gz 1138551 BLAKE2B 175fcc284f61f1aa4704587b8dc5fbdf356d75be79b878a7f64ec807e32f241f0c0c94bb689de64f8117e7b593f439564731cba3d2247093a98a4273a05a9e4f SHA512 15694cbed64b86d48aa70a5ccda57b21fe040fca147e367d81bf527a7c329c80b7bd0f46f09612236c470fee0d35c7f48cb42e6476f6fc022ab8612321a7cd95
+DIST pynndescent-0.5.2.tar.gz 1148182 BLAKE2B 64cff5fe0d92b2d735564b7e3a1dc62c64bcaec33d8d5bfaffbcf61423ff1cef388dd2335479dff5af7f50848dbe8d9640a22add54b2b90a979cb13d0894b371 SHA512 b38bbf8aab91d4278572a6446e4750022e2b2bc82e7a8f7754b8ec74c0ae1f7795364ef4e22cd6bd39071056ebacaedeb79981620e3143d3c9060a1520c85aae
diff --git a/dev-python/pynndescent/pynndescent-0.5.2.ebuild b/dev-python/pynndescent/pynndescent-0.5.2.ebuild
new file mode 100644
index 000000000..894f3114f
--- /dev/null
+++ b/dev-python/pynndescent/pynndescent-0.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="nearest neighbor descent for approximate nearest neighbors"
+HOMEPAGE="https://github.com/lmcinnes/pynndescent"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/joblib[${PYTHON_USEDEP}]
+ >=dev-python/numba-0.51.2[${PYTHON_USEDEP}]
+ >=dev-python/llvmlite-0.34[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ <=sci-libs/scikit-learn-0.24.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests nose