aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-25 23:19:49 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-09-25 23:19:49 +0000
commitce46f296a73cb17ab4581fccec3a44f31f0087c8 (patch)
treebc8643c42a8ec256560667092852091692409407
parentdev-libs/asmjit: version bump to dated (diff)
downloadsci-ce46f296.tar.gz
sci-ce46f296.tar.bz2
sci-ce46f296.zip
dev-libs/asmjit: add live ebuild
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--dev-libs/asmjit/asmjit-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/asmjit/asmjit-9999.ebuild b/dev-libs/asmjit/asmjit-9999.ebuild
new file mode 100644
index 000000000..4aa72707c
--- /dev/null
+++ b/dev-libs/asmjit/asmjit-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="complete x86/x64 JIT-Assembler for C++ language"
+HOMEPAGE="http://asmjit.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/asmjit/asmjit"
+else
+ COMMIT=b49d685cd9e2e4488f55ce6004306a79bdea056b
+ SRC_URI="https://github.com/asmjit/asmjit/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64"
+fi
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="natvis static-libs test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DASMJIT_EMBED=$(usex static-libs)
+ -DASMJIT_BUILD_X86=ON
+ -DASMJIT_NO_NATVIS=$(usex natvis)
+ -DASMJIT_TEST=$(usex test)
+ )
+ cmake_src_configure
+}