aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-07-28 21:23:07 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-07-28 22:05:19 +0200
commitcef6f206bd05567e80c11b9f9b1e850f74e06731 (patch)
tree1df8a2ac47c1dc9e820801e9302fd0fb8dee1737
parentsci-biology/vcftools: the 0.1.15_pre release was just renamed to 0.1.15 by up... (diff)
downloadsci-cef6f206.tar.gz
sci-cef6f206.tar.bz2
sci-cef6f206.zip
sci-biology/nanopolish: new package
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--sci-biology/nanopolish/metadata.xml12
-rw-r--r--sci-biology/nanopolish/nanopolish-9999.ebuild48
2 files changed, 60 insertions, 0 deletions
diff --git a/sci-biology/nanopolish/metadata.xml b/sci-biology/nanopolish/metadata.xml
new file mode 100644
index 000000000..f68a1b6fa
--- /dev/null
+++ b/sci-biology/nanopolish/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/nanopolish/nanopolish-9999.ebuild b/sci-biology/nanopolish/nanopolish-9999.ebuild
new file mode 100644
index 000000000..92c5f41d3
--- /dev/null
+++ b/sci-biology/nanopolish/nanopolish-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Signal-level analysis of Oxford Nanopore sequencing data"
+HOMEPAGE="https://github.com/jts/nanopolish"
+EGIT_REPO_URI="https://github.com/jts/nanopolish.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+# HDF5 is not thread safe by default and nanopolish currently requires a threadsafe HDF5.
+# This is one reason we download the compile it ourself (the main reason is to make it
+# easier for most users). The other options cxx, fortran, mpi are not needed by nanopolish
+# (we use the C bindings in nanopolish only).
+# The bundled version of htslib in is 1.2.1 as of now although 1.5.1 already exists
+DEPEND=">=sci-libs/hdf5-1.8.14[threads]
+ >=dev-cpp/eigen-3.2.5
+ sci-libs/htslib:0
+ sci-libs/fast5"
+RDEPEND="${DEPEND}
+ sci-biology/biopython"
+
+src_prepare(){
+ default
+ rm -rf hdf5* eigen htslib || die # TODO; zap also fast5
+}
+
+src_compile(){
+ # >=gcc-4.8 but <gcc-7 is needed
+ # https://github.com/jts/nanopolish/issues/145
+ emake HDF5="noinstall" EIGEN="nofetch" HTS_LIB=-lhts HTS_INCLUDE=-I/usr/include/htslib EIGEN_INCLUDE=-I/usr/include/eigen3 # TODO: FAST5_INCLUDE=-I/usr/include/fast5
+}
+
+src_install(){
+ rm -rf lib || die # zap libs eventually compiled from the bundled copies
+ dobin nanopolish
+ # add scripts/ subdirectory to PATH
+}
+
+src_test(){
+ nanopolish_test || die
+}