aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-02-10 13:43:29 +0100
committerTomas Chvatal <scarabeus@gentoo.org>2009-02-10 13:43:29 +0100
commitcfff81fe99aa4761241bee8eb14b92b7474e4633 (patch)
tree3c2ae5de9188418f565673236c5b9af78e92f003
parentsci-chemistry/procheck moved from Donnies overlay to sci overlay (diff)
downloadsci-cfff81fe99aa4761241bee8eb14b92b7474e4633.tar.gz
sci-cfff81fe99aa4761241bee8eb14b92b7474e4633.tar.bz2
sci-cfff81fe99aa4761241bee8eb14b92b7474e4633.zip
Update boinc generator script. now server should build.
-rw-r--r--Documentation/generate_tarball.sh9
1 files changed, 7 insertions, 2 deletions
diff --git a/Documentation/generate_tarball.sh b/Documentation/generate_tarball.sh
index 11d910c04..be50bdf08 100644
--- a/Documentation/generate_tarball.sh
+++ b/Documentation/generate_tarball.sh
@@ -88,8 +88,13 @@ sed -i \
-e "s:doc/Makefile::g" \
-e "sXclient/win/boinc_path_config.py:py/Boinc/boinc_path_config.py.inXXg" \
"$PACKAGE"/configure.ac
-# reconfigure
-# somebody who likes autotools will have to do this :D i have no clue there
+# fix the server build
+sed -i \
+ -e "s:samples/example_app::g" \
+ "$PACKAGE"/Makefile.am
+sed -i \
+ -e "s:sched apps tools samples/example_app:sched apps tools:g" \
+ "$PACKAGE"/Makefile.in
pushd "$PACKAGE"/
./_autosetup
popd