aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-03-28 22:46:20 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-03-28 22:46:20 +0100
commitd174cca6d660563e4d1ac95875628d8b4ec94867 (patch)
treee0769cb1ad658f8f265bcb0862009622d472a4db
parentsci-biology/NGSTools: renamed into NGSEPcore and NGSEPplugin (diff)
downloadsci-d174cca6.tar.gz
sci-d174cca6.tar.bz2
sci-d174cca6.zip
sci-biology/maker: some progress with the ebuild, empty KEYWORDS
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
-rw-r--r--sci-biology/maker/Manifest3
-rw-r--r--sci-biology/maker/maker-2.31.10.ebuild154
-rw-r--r--sci-biology/maker/maker-3.01.02_beta.ebuild (renamed from sci-biology/maker/maker-2.31.8.ebuild)16
3 files changed, 167 insertions, 6 deletions
diff --git a/sci-biology/maker/Manifest b/sci-biology/maker/Manifest
index 8b2a8d085..e11ced65a 100644
--- a/sci-biology/maker/Manifest
+++ b/sci-biology/maker/Manifest
@@ -1 +1,2 @@
-DIST maker-2.31.8.tgz 13607357 SHA256 a99c7e433638979808ea3f4bcd2b6b69f4474bd898807aba4520debd58717420 SHA512 1533888c4960a74395f4bfdd26a4f86ba33d93764b1e40094fcd2d8e7e355495464619820b0c805061f467c20d979ddf17bdb2979a7f17117c1a721032ee538d WHIRLPOOL 2df90ae76891160ed08fc3a703d3d8a982e737fa23c3f65d197bd900816588a2e8d8ec364e1122af4be289f01b5c704414487eb19ece8a8fedd9c9aac11e40e2
+DIST maker-2.31.10.tgz 13607534 BLAKE2B 600790dac23c20f888b56e922d30eaba912b6e2d63927568b01a1be124e5de735755b4dfaa60b537f85dfc0b8cfbab5ec126656c244f5c4935148053661db833 SHA512 3708d761221aa3be056dde86bc80bba6e6da57ba49df61892d05b45a90d9c493248661903537e47bdb549e908ea9eb5819088a84777d3a21e6af0e0b89aa5ede
+DIST maker-3.01.02_beta.tgz 13646218 BLAKE2B d2767ddd160e98ed843652c4a4259ad8997ec5ee58dcda277dcebc531e3195ff823f6b00eeb0114099f70d412a17fcf7bd784c67eab445a2e6989c3a3c0d23e8 SHA512 69d9b8e03a3094ca0ad1db40d02391a100a360c0917ea6f850dae7bc8c345a12cdb9935473fd388b508e9c5b2fc7f9fbfb5c3f64df9821c1df652803fb469e0e
diff --git a/sci-biology/maker/maker-2.31.10.ebuild b/sci-biology/maker/maker-2.31.10.ebuild
new file mode 100644
index 000000000..b7dc780a9
--- /dev/null
+++ b/sci-biology/maker/maker-2.31.10.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit eutils perl-module
+
+DESCRIPTION="A genome annotation viewer and pipeline for small eukaryota and prokaryota"
+HOMEPAGE="http://www.yandell-lab.org/software/maker.html"
+SRC_URI="maker-"${PV}".tgz"
+
+RESTRICT="fetch"
+
+# for academia: GPL-v2 or Artistic-2
+# for commercial: ask
+LICENSE="|| ( GPL-2 Artistic-2 )"
+SLOT="0"
+KEYWORDS=""
+IUSE="mpi"
+
+# http://search.cpan.org/~rybskej/forks-0.36/lib/forks.pm # bug #566360
+# http://search.cpan.org/~rybskej/forks-0.36/lib/forks/shared.pm
+#
+# MAKER does not work with MVAPICH2.
+# It can work with Intel MPI and OpenMPI with some command line modification.
+# It always works with MPICH, but MPICH may not be able to scale to more than ~100 CPUs.
+DEPEND="
+ mpi? ( sys-cluster/mpich2 || ( sys-cluster/openmpi ) )
+ dev-perl/DBI
+ dev-perl/DBD-SQLite
+ dev-perl/File-Which
+ dev-perl/Bit-Vector
+ dev-perl/Inline-C
+ dev-perl/IO-All
+ dev-perl/libwww-perl
+ dev-perl/DBD-Pg
+ dev-perl/Module-Build
+ dev-perl/Want
+ dev-perl/IO-Prompt
+ dev-perl/Perl-Unsafe-Signals
+ dev-perl/forks
+ >=sci-biology/GAL-0.2.1
+ >=sci-biology/bioperl-1.6
+ sci-biology/ncbi-tools || ( sci-biology/ncbi-tools++ )
+ sci-biology/snap
+ sci-biology/exonerate
+ >=sci-biology/augustus-2.0
+ sci-biology/repeatmasker"
+ #sci-biology/GeneMark_ES-bin
+ #sci-biology/GeneMark_S-bin
+ #>=sci-biology/FGENESH-bin-2.4 (not in gentoo yet)
+RDEPEND="${DEPEND}"
+# dev-perl/forks-shared ?
+
+# ==============================================================================
+# STATUS MAKER v2.31.8
+# ==============================================================================
+# PERL Dependencies: MISSING
+# ! Perl::Unsafe::Signals
+# ! Want
+# ! forks
+# ! forks::shared
+#
+# External Programs: MISSING
+# ! RepeatMasker
+#
+# External C Libraries: VERIFIED
+# MPI SUPPORT: DISABLED
+# MWAS Web Interface: DISABLED
+# MAKER PACKAGE: MISSING PREREQUISITES
+#
+#
+# Important Commands:
+# ./Build installdeps #installs missing PERL dependencies
+# ./Build installexes #installs all missing external programs
+# ./Build install #installs MAKER
+# ./Build status #Shows this status menu
+#
+# Other Commands:
+# ./Build repeatmasker #installs RepeatMasker (asks for RepBase)
+# ./Build blast #installs BLAST (NCBI BLAST+)
+# ./Build exonerate #installs Exonerate (v2 on UNIX / v1 on Mac OSX)
+# ./Build snap #installs SNAP
+# ./Build augustus #installs Augustus
+# ./Build apollo #installs Apollo
+# ./Build gbrowse #installs GBrowse (must be root)
+# ./Build jbrowse #installs JBrowse (MAKER copy, not web accecible)
+# ./Build webapollo #installs WebApollo (use maker2wap to create DBs)
+# ./Build mpich2 #installs MPICH2 (but manual install recommended)
+# Building MAKER
+#
+# * MISSING MAKER PREREQUISITES - CANNOT CONTINUE!!
+
+S="${WORKDIR}"/maker/src
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE} and obtain the file"
+ einfo "maker-"${PV}".tgz and place it into ${DISTDIR}"
+ einfo "You must also install sci-biology/repeatmasker otherwise"
+ einfo "MAKER install process will stop."
+ einfo "That in turn requires you to register at http://www.girinst.org/server/RepBase"
+ einfo "to obtain sci-biology/repeatmasker-libraries data file"
+ einfo "For execution through openmpi or mpich please read INSTALL file"
+ einfo "Customization typically go into maker_opts.ctl file"
+}
+
+src_compile(){
+ perl Build.PL || die
+ ./Build install || die
+ ./Build installdeps || die
+}
+
+# If you move it, then the executables won't able to locate dependencies
+# in the /maker/data, /maker/lib, /maker/perl directories. You should
+# really either add the location of /maker/bin to you PATH environmental
+# variable or at most soft link the executables somewhere
+# else using the 'ln -s' command.
+src_install(){
+ cd "${WORKDIR}"/maker || die
+ rm -f bin/fasta_tool # is part of sci-biology/GAL
+ # drop development related accessory script requiring Parallel/MPIcar.pm
+ find . -name mpi_evaluator | xargs rm || die
+ mv bin/compare bin/compare_gff3_to_chado # rename as agreed by upstream, will be in maker-3 as well
+ dobin bin/*
+ perl_set_version
+ insinto "${VENDOR_LIB}"/MAKER # uppercase, not "${PN}"
+ doins perl/lib/MAKER/*.pm
+ doman perl/man/*.3pm
+ #
+ # FIXME: find equivalent perl packages for lib/* contents, for example lib/GI.pm
+ # You do not have write access to install missing Modules.
+ # I can try and install these locally (i.e. only for MAKER)
+ # in the .../maker/perl/lib directory, or you can run
+ # './Build installdeps' as root or using sudo and try again.
+ # Do want MAKER to try and build a local installation? [N ]N
+ #
+ #
+ # WARNING: You do not appear to have write access to install missing
+ # Modules. Please run './Build installdeps' as root or using sudo.
+ #
+ # Do you want to continue anyway? [N ]N
+ #
+ doins -r lib/*
+ insinto "${VENDOR_LIB}"/Parallel/Application
+ doins perl/lib/Parallel/Application/*.pm
+ insinto /usr/share/"${PN}"/data
+ doins data/*
+ dodoc README INSTALL
+ insinto /usr/share/"${PN}"/GMOD/Apollo
+ doins GMOD/Apollo/gff3.tiers
+ insinto /usr/share/"${PN}"/GMOD/JBrowse
+ doins GMOD/JBrowse/maker.css
+}
diff --git a/sci-biology/maker/maker-2.31.8.ebuild b/sci-biology/maker/maker-3.01.02_beta.ebuild
index e5c791ab2..d6ad845d1 100644
--- a/sci-biology/maker/maker-2.31.8.ebuild
+++ b/sci-biology/maker/maker-3.01.02_beta.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -21,6 +21,10 @@ IUSE="mpi"
# http://search.cpan.org/~rybskej/forks-0.36/lib/forks.pm # bug #566360
# http://search.cpan.org/~rybskej/forks-0.36/lib/forks/shared.pm
+#
+# MAKER does not work with MVAPICH2.
+# It can work with Intel MPI and OpenMPI with some command line modification.
+# It always works with MPICH, but MPICH may not be able to scale to more than ~100 CPUs.
DEPEND="
mpi? ( sys-cluster/mpich2 || ( sys-cluster/openmpi ) )
dev-perl/DBI
@@ -93,6 +97,7 @@ S="${WORKDIR}"/maker/src
pkg_nofetch() {
einfo "Please visit ${HOMEPAGE} and obtain the file"
einfo "maker-"${PV}".tgz and place it into ${DISTDIR}"
+ einfo "If it is '-beta' rename it to '_beta'"
einfo "You must also install sci-biology/repeatmasker otherwise"
einfo "MAKER install process will stop."
einfo "That in turn requires you to register at http://www.girinst.org/server/RepBase"
@@ -106,10 +111,11 @@ src_compile(){
./Build install || die
}
-# If you move it, then the executables won’t be able to locate dependencies in the …/maker/data,
-# …/maker/lib, and …/maker/perl directories. You should really either add the location of
-# …/maker/bin to you PATH environmental variable or at most soft link the executables somewhere
-# else using the ‘ln -s’ command.
+# If you move it, then the executables won't able to locate dependencies
+# in the /maker/data, /maker/lib, /maker/perl directories. You should
+# really either add the location of /maker/bin to you PATH environmental
+# variable or at most soft link the executables somewhere
+# else using the 'ln -s' command.
src_install(){
cd "${WORKDIR}"/maker || die
rm -f bin/fasta_tool # is part of sci-biology/GAL