aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-01 11:32:54 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-01 11:32:54 +0100
commitd71c56239475f71bc640d54a4e70f71335c9d637 (patch)
tree0403001c2a9e31eea23fe27df43481e7f46beb3d
parentsci-biology/biobambam2: add keyword (diff)
downloadsci-d71c5623.tar.gz
sci-d71c5623.tar.bz2
sci-d71c5623.zip
sci-biology/cortex_var: fix sed calls
but still does not compile, needs a patch Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-biology/cortex_var/cortex_var-1.0.5.21.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sci-biology/cortex_var/cortex_var-1.0.5.21.ebuild b/sci-biology/cortex_var/cortex_var-1.0.5.21.ebuild
index 0e611a6c6..f5b86e25c 100644
--- a/sci-biology/cortex_var/cortex_var-1.0.5.21.ebuild
+++ b/sci-biology/cortex_var/cortex_var-1.0.5.21.ebuild
@@ -28,13 +28,15 @@ S="${WORKDIR}/CORTEX_release_v${PV}"
src_prepare(){
default
- sed -e "s/ -O3 / ${CFLAGS} /" Makefile || die
- sed -e "s#libs/gsl-1.15#${EPREFIX}/usr/include/gsl#" Makefile || die
+ sed -i -e "s/ -O3 / ${CFLAGS} /" Makefile || die
+ sed -i -e "s#libs/gsl-1.15#${EPREFIX}/usr/include/gsl#" Makefile || die
}
src_compile(){
rm -rf libs/htslib libs/gsl-1.15 || die
- emake NUM_COLS=1 MAXK=31 cortex_var || die
+ emake -C libs/string_buffer
+ emake STRING_BUF_PATH="${S}/libs/string_buffer" HTS_PATH="/usr/include/" -C libs/seq_file
+ emake NUM_COLS=1 MAXK=31 cortex_var
}
src_install(){