aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-04-01 03:48:43 -0400
committerHorea Christian <chr@chymera.eu>2022-04-01 03:48:43 -0400
commitda45c12e15c1bfde33d4c8e0919eccec25b426b8 (patch)
treea5e30a51f75cc85ab1787834e21d5eac3cc9dcf1
parentdev-python/pycryptodomex: dropped in favour of pycryptodome::gentoo (diff)
downloadsci-da45c12e.tar.gz
sci-da45c12e.tar.bz2
sci-da45c12e.zip
sci-biology/afni: reinstated working versions
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--sci-biology/afni/Manifest2
-rw-r--r--sci-biology/afni/afni-20.1.16.ebuild73
-rw-r--r--sci-biology/afni/afni-20.3.03.ebuild77
-rw-r--r--sci-biology/afni/afni-22.0.03.ebuild3
-rw-r--r--sci-biology/afni/files/afni-20.1.16-python.patch11
-rw-r--r--sci-biology/afni/files/afni-20.3.03-python.patch11
6 files changed, 176 insertions, 1 deletions
diff --git a/sci-biology/afni/Manifest b/sci-biology/afni/Manifest
index 42bf141a9..bbb2dea50 100644
--- a/sci-biology/afni/Manifest
+++ b/sci-biology/afni/Manifest
@@ -1 +1,3 @@
+DIST afni-20.1.16.tar.gz 43355499 BLAKE2B ad7750e64dd9f4c2ca7e5c67bd99faeb8595a41d8a16192e77202f3d307e912083affc11dcbb5da3530079b9e3cf3c2b6b470050f57d5d7af2bb35cc2322772f SHA512 e6fdb8baea6165865bae5bb186375bd65e862564c48470523a8fe026a12f00715fd21bd852bd77c4077ea444a97642c4c3d2ca8060640ba5ddd57bd7883901a6
+DIST afni-20.3.03.tar.gz 43263734 BLAKE2B 7fdaf3de874edff9b32950a2724ba8b4cbcdda538b09effb12658a042326d5c8badf48f1a4dfb4555eb069347099cf3cdb08c4fe1a12999e6eca3ca6f8dca639 SHA512 3c5007f59d6c46093d38f9419c72aa36fb5701314690811f757d9568561b386cf3cd602ddf910ae08fd071ea7ae1e51f5762081217f7a29b23e32f1490f5db65
DIST afni-22.0.03.tar.gz 43893862 BLAKE2B f49000b8f72c487537a0f8e79c10aa49fba42c61027f09da6fb97e2125924c843e6c2f560116724e303eebb90a4f6d83a2627b6ac790a7122a143ca12a718d7d SHA512 d6e2350b79236b92003000038007b7c22ab1f6305a18ddf3153ab0e785ec846bbd8612b841011621272f404bb15da8d905d3e912144847d6be21f1cd762bf5e5
diff --git a/sci-biology/afni/afni-20.1.16.ebuild b/sci-biology/afni/afni-20.1.16.ebuild
new file mode 100644
index 000000000..98fdb2397
--- /dev/null
+++ b/sci-biology/afni/afni-20.1.16.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An open-source environment for processing and displaying functional MRI data"
+HOMEPAGE="http://afni.nimh.nih.gov/"
+SRC_URI="https://github.com/afni/afni/archive/AFNI_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/expat
+ media-libs/glu
+ media-libs/netpbm
+ media-libs/qhull
+ media-video/mpeg-tools
+ sci-libs/gsl
+ sys-devel/llvm:*
+ virtual/jpeg:0
+ x11-libs/libGLw
+ x11-libs/libXft
+ x11-libs/libXi
+ x11-libs/libXpm
+ x11-libs/motif[-static-libs]"
+
+# x11-libs/motif[static-libs] breaks the build.
+# See upstream discussion
+# http://afni.nimh.nih.gov/afni/community/board/read.php?1,85348,85348#msg-85348
+
+DEPEND="${RDEPEND}
+ app-shells/tcsh"
+
+S="${WORKDIR}/${PN}-AFNI_${PV}/src"
+BUILD="linux_fedora_19_64"
+BIN_CONFLICTS=(qdelaunay whirlgif djpeg cjpeg qhull rbox count mpeg_encode)
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-python.patch" || die
+ find -type f -exec sed -i -e "s/-lXp //g" {} +
+ cp other_builds/Makefile.${BUILD} Makefile || die "Could not copy Makefile"
+ # Unbundle imcat
+ sed -e "s/ imcat / /g" \
+ -i Makefile.INCLUDE || die "Could not edit includes files."
+ sed -e "s~CC = /usr/bin/gcc -O2 -m64~CC = $(tc-getCC) \$(CFLAGS)~" \
+ -e "s~CCMIN = /usr/bin/gcc -m64~CCMIN = $(tc-getCC) \$(CFLAGS)~" \
+ -e "s~LD = /usr/bin/gcc~LD = $(tc-getCC)~" \
+ -e "s~AR = /usr/bin/ar~AR = $(tc-getAR)~" \
+ -e "s~RANLIB = /usr/bin/ranlib~RANLIB = $(tc-getRANLIB)~" \
+ -i Makefile || die "Could not edit Makefile"
+ # they provide somewhat problematic makefiles :(
+ sed -e "s~ifeq ($(CC),gcc)~ifeq (1,1)~"\
+ -i SUMA/SUMA_Makefile || die "Could not edit SUMA/SUMA_Makefile"
+ # upstream checks if $CC is EXACTLY gcc, else sets variables for Mac
+ find "${S}" -iname "*Makefile*" | xargs sed -e "s~/usr/~${EROOT}/usr/~g;" -i
+ default
+}
+
+src_compile() {
+ emake -j1 all plugins suma_exec
+}
+
+src_install() {
+ emake INSTALLDIR="${ED}/usr/bin" -j1 install install_plugins
+ emake INSTALLDIR="${ED}/usr/$(get_libdir)" install_lib
+ for CONFLICT in ${BIN_CONFLICTS[@]}; do
+ rm "${ED}/usr/bin/${CONFLICT}"
+ done
+}
diff --git a/sci-biology/afni/afni-20.3.03.ebuild b/sci-biology/afni/afni-20.3.03.ebuild
new file mode 100644
index 000000000..fab7446bf
--- /dev/null
+++ b/sci-biology/afni/afni-20.3.03.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An open-source environment for processing and displaying functional MRI data"
+HOMEPAGE="http://afni.nimh.nih.gov/"
+SRC_URI="https://github.com/afni/afni/archive/AFNI_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/expat
+ media-libs/glu
+ media-libs/netpbm
+ media-libs/qhull
+ media-video/mpeg-tools
+ sci-libs/gsl
+ sys-devel/llvm:*
+ virtual/jpeg:0
+ x11-libs/libGLw
+ x11-libs/libXft
+ x11-libs/libXi
+ x11-libs/libXpm
+ x11-libs/motif[-static-libs]"
+
+# x11-libs/motif[static-libs] breaks the build.
+# See upstream discussion
+# http://afni.nimh.nih.gov/afni/community/board/read.php?1,85348,85348#msg-85348
+
+DEPEND="${RDEPEND}
+ app-shells/tcsh"
+
+S="${WORKDIR}/${PN}-AFNI_${PV}/src"
+BUILD="linux_fedora_19_64"
+BIN_CONFLICTS=(qdelaunay whirlgif djpeg cjpeg qhull rbox count mpeg_encode)
+
+#PATCHES=(
+# "${FILESDIR}/${P}-python.patch"
+#)
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-python.patch" || die
+ find -type f -exec sed -i -e "s/-lXp //g" {} +
+ cp other_builds/Makefile.${BUILD} Makefile || die "Could not copy Makefile"
+ # Unbundle imcat
+ sed -e "s/ imcat / /g" \
+ -i Makefile.INCLUDE || die "Could not edit includes files."
+ sed -e "s~CC = /usr/bin/gcc -O2 -m64~CC = $(tc-getCC) \$(CFLAGS)~" \
+ -e "s~CCMIN = /usr/bin/gcc -m64~CCMIN = $(tc-getCC) \$(CFLAGS)~" \
+ -e "s~LD = /usr/bin/gcc~LD = $(tc-getCC)~" \
+ -e "s~AR = /usr/bin/ar~AR = $(tc-getAR)~" \
+ -e "s~RANLIB = /usr/bin/ranlib~RANLIB = $(tc-getRANLIB)~" \
+ -i Makefile || die "Could not edit Makefile"
+ # they provide somewhat problematic makefiles :(
+ sed -e "s~ifeq ($(CC),gcc)~ifeq (1,1)~"\
+ -i SUMA/SUMA_Makefile || die "Could not edit SUMA/SUMA_Makefile"
+ # upstream checks if $CC is EXACTLY gcc, else sets variables for Mac
+ find "${S}" -iname "*Makefile*" | xargs sed -e "s~/usr/~${EROOT}/usr/~g;" -i
+ default
+}
+
+src_compile() {
+ emake -j1 all plugins suma_exec
+}
+
+src_install() {
+ emake INSTALLDIR="${ED}/usr/bin" -j1 install install_plugins
+ emake INSTALLDIR="${ED}/usr/$(get_libdir)" install_lib
+ for CONFLICT in ${BIN_CONFLICTS[@]}; do
+ rm "${ED}/usr/bin/${CONFLICT}"
+ done
+}
diff --git a/sci-biology/afni/afni-22.0.03.ebuild b/sci-biology/afni/afni-22.0.03.ebuild
index 920bf7189..9e831b018 100644
--- a/sci-biology/afni/afni-22.0.03.ebuild
+++ b/sci-biology/afni/afni-22.0.03.ebuild
@@ -11,7 +11,8 @@ SRC_URI="https://github.com/afni/afni/archive/AFNI_${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+# fully broken due to upstream cmake migration
+KEYWORDS=""
IUSE=""
RDEPEND="dev-libs/expat
diff --git a/sci-biology/afni/files/afni-20.1.16-python.patch b/sci-biology/afni/files/afni-20.1.16-python.patch
new file mode 100644
index 000000000..8c3e859f5
--- /dev/null
+++ b/sci-biology/afni/files/afni-20.1.16-python.patch
@@ -0,0 +1,11 @@
+--- a/other_builds/Makefile.linux_fedora_19_64 2020-10-09 07:07:58.348874414 -0400
++++ b/other_builds/Makefile.linux_fedora_19_64 2020-10-10 01:15:22.337755934 -0400
+@@ -11,8 +11,6 @@
+
+ # ------------------------------
+ # python from C
+-IPYTHON = -DSELENIUM_READY -I/usr/include/python2.7
+-LDPYTHON = -lpython2.7
+
+ # ----------------------------------------------------------------------
+ # X configuration
diff --git a/sci-biology/afni/files/afni-20.3.03-python.patch b/sci-biology/afni/files/afni-20.3.03-python.patch
new file mode 100644
index 000000000..8c3e859f5
--- /dev/null
+++ b/sci-biology/afni/files/afni-20.3.03-python.patch
@@ -0,0 +1,11 @@
+--- a/other_builds/Makefile.linux_fedora_19_64 2020-10-09 07:07:58.348874414 -0400
++++ b/other_builds/Makefile.linux_fedora_19_64 2020-10-10 01:15:22.337755934 -0400
+@@ -11,8 +11,6 @@
+
+ # ------------------------------
+ # python from C
+-IPYTHON = -DSELENIUM_READY -I/usr/include/python2.7
+-LDPYTHON = -lpython2.7
+
+ # ----------------------------------------------------------------------
+ # X configuration