aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-07 05:03:37 +0100
committerSam James <sam@gentoo.org>2022-07-07 05:54:09 +0100
commite3383c8190097c6975adf18209345121ffbaa8e1 (patch)
tree09e6467663455791a134eb645e559229ba775ca6
parentdev-python/visvis: enable py3.10 (diff)
downloadsci-e3383c81.tar.gz
sci-e3383c81.tar.bz2
sci-e3383c81.zip
sci-libs/nibabel: enable py3.10 and disable py3.7
See https://projects.gentoo.org/python/guide/distutils.html#running-tests-with-virtualx re virtx. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/nibabel/nibabel-3.2.1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sci-libs/nibabel/nibabel-3.2.1.ebuild b/sci-libs/nibabel/nibabel-3.2.1.ebuild
index d469867f9..43720d35f 100644
--- a/sci-libs/nibabel/nibabel-3.2.1.ebuild
+++ b/sci-libs/nibabel/nibabel-3.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -23,14 +23,19 @@ RDEPEND="
dev-python/scipy[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dicom? (
- sci-libs/pydicom
dev-python/pillow[${PYTHON_USEDEP}]
- )
+ sci-libs/pydicom
+ )
"
BDEPEND="test? (
dev-python/pytest-doctestplus[${PYTHON_USEDEP}]
)"
+EPYTEST_DESELECT=(
+ # Re-evaluate after 3.2.1
+ nibabel/gifti/tests/test_parse_gifti_fast.py::test_parse_dataarrays
+)
+
distutils_enable_sphinx doc/source dev-python/texext dev-python/numpydoc dev-python/matplotlib
distutils_enable_tests pytest