aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-25 22:56:51 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-09-25 22:56:51 +0000
commite535df72eeecfcae9a0f18dd392d2659e25e1a81 (patch)
tree6a30ea8ef41972235a00a0373642dfd22a60273d
parentdev-libs/utf8proc: drop old versions (diff)
downloadsci-e535df72eeecfcae9a0f18dd392d2659e25e1a81.tar.gz
sci-e535df72eeecfcae9a0f18dd392d2659e25e1a81.tar.bz2
sci-e535df72eeecfcae9a0f18dd392d2659e25e1a81.zip
dev-libs/simclist: various fixes and options
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--dev-libs/simclist/Manifest2
-rw-r--r--dev-libs/simclist/metadata.xml14
-rw-r--r--dev-libs/simclist/simclist-1.6.ebuild42
-rw-r--r--dev-libs/simclist/simclist-1.6_p1.ebuild52
4 files changed, 62 insertions, 48 deletions
diff --git a/dev-libs/simclist/Manifest b/dev-libs/simclist/Manifest
index 2ff328fc9..2f6a2d69e 100644
--- a/dev-libs/simclist/Manifest
+++ b/dev-libs/simclist/Manifest
@@ -1 +1 @@
-DIST simclist-1.6.tar.bz2 44280 SHA256 63b47211215466ddfba1643582cb3aaa7b5e9ca1cc5f247290e3199c4e29f147 SHA512 b221b583993470c35d42dbc145af8bce2992c0e717e15f201ed1fe0a1aa3f0d676bb3258930987d85e3080eb27d9c89c4b08f27bd4e56031fd02fbab32e52615 WHIRLPOOL 9b31847ef2cba06f6364dd2ecc486f1dd02727ee7128d88cf3b7a3fe25f10df9a5c31ea2a386e2fa967a2b0c484ea55909c4d73bae390fcc972abce78d46ecdb
+DIST simclist-1.6_p1.tar.gz 47710 BLAKE2B 01153e8de1a2ebe4bc08ba5e995dd8d531151e4125a8f154fc8df1a7f6d64bfa4f0ed2703fbc8f259dbca0a94637dba35006f51f0a7b1bb315b7da88719ef93f SHA512 639ced247de276d95dae6bf2990a0ef8bc4548f45b220593baa2dfcb87e90c14bf4ae16f0898132744fe4ac5377dfa3f97d5ed8e239c6d032f221b3cda17cbb4
diff --git a/dev-libs/simclist/metadata.xml b/dev-libs/simclist/metadata.xml
index 27a2343d7..8426fdb21 100644
--- a/dev-libs/simclist/metadata.xml
+++ b/dev-libs/simclist/metadata.xml
@@ -6,9 +6,13 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription>
-SimCList is a high quality C (C++ embeddable) library for handling
-lists. It exploits several advanced techniques for improving
-performance, including freelists, sentinels, automatic sort algorithm
-selection, sort randomization, mid pointer and optional multithreading.
-</longdescription>
+ SimCList is a high quality C (C++ embeddable) library for handling
+ lists. It exploits several advanced techniques for improving
+ performance, including freelists, sentinels, automatic sort algorithm
+ selection, sort randomization, mid pointer and optional multithreading.
+ </longdescription>
+ <use>
+ <flag name="dump">Disable building of dump and restore functionalities</flag>
+ <flag name="hash">Allow list_hash() to work exclusively on memory locations</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-libs/simclist/simclist-1.6.ebuild b/dev-libs/simclist/simclist-1.6.ebuild
deleted file mode 100644
index 179cabbcb..000000000
--- a/dev-libs/simclist/simclist-1.6.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="SimCList is a high quality C (C++ embeddable) library for handling lists"
-HOMEPAGE="http://mij.oltrelinux.com/devel/simclist"
-SRC_URI="${HOMEPAGE}/${P/_/}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-S="${WORKDIR}/${P/_/}"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-src_compile(){
- cmake-utils_src_compile
- if use doc; then
- doxygen || die "doxygen failed"
- fi
-}
-
-src_install() {
- mkdir -p "${D}"/usr/include
- cp simclist.h "${D}"/usr/include/
- cd "${BUILD_DIR}"
- dolib libsimclist.so
- cd "${S}"
- if use doc; then
- dohtml -r doc/html/*
- fi
- if use examples; then
- docinto examples
- dodoc examples/*
- fi
-}
diff --git a/dev-libs/simclist/simclist-1.6_p1.ebuild b/dev-libs/simclist/simclist-1.6_p1.ebuild
new file mode 100644
index 000000000..2b7eb84f1
--- /dev/null
+++ b/dev-libs/simclist/simclist-1.6_p1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="SimCList is a high quality C (C++ embeddable) library for handling lists"
+HOMEPAGE="https://mij.oltrelinux.com/devel/simclist"
+COMMIT=6aef848d1743af66045a6f413cd3b8b1f1578c15
+SRC_URI="https://github.com/mij/simclist/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc dump hash threads"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ sed -i -e "/-O2/d" CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSIMCLIST_DEBUG=$(usex debug)
+ -DSIMCLIST_THREADING=$(usex threads)
+ -DSIMCLIST_NO_DUMPRESTORE=$(usex dump)
+ -DSIMCLIST_ALLOW_LOCATIONBASED_HASHES=$(usex hash)
+ )
+ cmake_src_configure
+}
+
+src_compile(){
+ cmake_src_compile
+ if use doc; then
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ doheader simclist.h
+ dolib.so libsimclist.so
+
+ if use doc ; then
+ dodoc -r doc/html/*
+ fi
+}