aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-01-19 18:23:15 +0100
committerHorea Christian <chr@chymera.eu>2020-01-19 18:23:15 +0100
commitea94e8974906d55e593321e488e2a0437aa5a718 (patch)
treeba7d0714d81cff50e835a1b05382fbdf2c9f90fc
parentsci-visualization/fsleyes-widgets: new package, required for FSLeyes (diff)
downloadsci-ea94e897.tar.gz
sci-ea94e897.tar.bz2
sci-ea94e897.zip
sci-visualization/fsleyes-props: new package required by FSLeyes
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--sci-visualization/fsleyes-props/ChangeLog9
-rw-r--r--sci-visualization/fsleyes-props/Manifest1
-rw-r--r--sci-visualization/fsleyes-props/files/fsleyes-props-1.6.7-coverage.patch10
-rw-r--r--sci-visualization/fsleyes-props/files/fsleyes-props-1.6.7-tests.patch45
-rw-r--r--sci-visualization/fsleyes-props/fsleyes-props-1.6.7.ebuild46
-rw-r--r--sci-visualization/fsleyes-props/metadata.xml19
6 files changed, 130 insertions, 0 deletions
diff --git a/sci-visualization/fsleyes-props/ChangeLog b/sci-visualization/fsleyes-props/ChangeLog
new file mode 100644
index 000000000..58b6e28dd
--- /dev/null
+++ b/sci-visualization/fsleyes-props/ChangeLog
@@ -0,0 +1,9 @@
+ 08 Oct 2018; Horea Christian <h.chr@mail.ru> fsleyes-props-1.6.3.ebuild:
+ sci-visualization/fsleyes-props: python3 compatibility
+
+*fsleyes-props-1.6.3 (08 Oct 2018)
+
+ 08 Oct 2018; Horea Christian <h.chr@mail.ru> +fsleyes-props-1.6.3.ebuild,
+ +metadata.xml:
+ sci-visualization/fsleyes-props: new ebuild Ahead of inclusion in science
+ overlay (unsubmitted)
diff --git a/sci-visualization/fsleyes-props/Manifest b/sci-visualization/fsleyes-props/Manifest
new file mode 100644
index 000000000..2afeed68b
--- /dev/null
+++ b/sci-visualization/fsleyes-props/Manifest
@@ -0,0 +1 @@
+DIST props-1.6.7.tar.gz 122329 BLAKE2B 7b32b2520c254065a0de423e6f3b14de4aa572739d0b0d8985af3ae628a80546299b0fd2acb675bd130e62acc37f729bab9ae198cb365bfa652b2f034a63d506 SHA512 fed8d9df0bb010da2449b9c6327e9b346402d789da16c73bfc8c61017808eadd4301d145b5da96f923dd005662d0ad593fff3a6ea129127aeb9e0760e72b2c12
diff --git a/sci-visualization/fsleyes-props/files/fsleyes-props-1.6.7-coverage.patch b/sci-visualization/fsleyes-props/files/fsleyes-props-1.6.7-coverage.patch
new file mode 100644
index 000000000..e256af331
--- /dev/null
+++ b/sci-visualization/fsleyes-props/files/fsleyes-props-1.6.7-coverage.patch
@@ -0,0 +1,10 @@
+diff --git a/setup.cfg b/setup.cfg
+index 2b66974..9929adf 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -10,4 +10,4 @@ ignore = E127,E201,E203,E221,E222,E241,E271,E272,E301,E302,E303,E701
+
+ [tool:pytest]
+ testpaths = tests
+-addopts = -v --cov=fsleyes_props
++addopts = -v
diff --git a/sci-visualization/fsleyes-props/files/fsleyes-props-1.6.7-tests.patch b/sci-visualization/fsleyes-props/files/fsleyes-props-1.6.7-tests.patch
new file mode 100644
index 000000000..124eb28cb
--- /dev/null
+++ b/sci-visualization/fsleyes-props/files/fsleyes-props-1.6.7-tests.patch
@@ -0,0 +1,45 @@
+diff --git a/tests/test_widget_number.py b/tests/test_widget_number.py
+index 1c5cadc..9d8067a 100644
+--- a/tests/test_widget_number.py
++++ b/tests/test_widget_number.py
+@@ -14,6 +14,7 @@ import fsleyes_props as props
+ import fsleyes_widgets.floatspin as floatspin
+ import fsleyes_widgets.floatslider as floatslider
+
++import pytest
+
+ def setup_module():
+ props.initGUI()
+@@ -28,6 +29,9 @@ class MyObj(props.HasProperties):
+ myrealc = props.Real(minval=0.0, maxval=1.0, clamped=True)
+
+
++@pytest.mark.skip(reason="Known to fail on Gentoo:"
++ "https://github.com/pauldmccarthy/fsleyes-props/issues/1"
++ )
+ def test_widget_number(): run_with_wx(_test_widget_number)
+ def _test_widget_number(parent):
+
+diff --git a/tests/test_widget_point.py b/tests/test_widget_point.py
+index cc21226..d83aa48 100644
+--- a/tests/test_widget_point.py
++++ b/tests/test_widget_point.py
+@@ -11,6 +11,7 @@ import numpy as np
+ import fsleyes_props as props
+ import fsleyes_widgets.floatslider as floatslider
+
++import pytest
+
+ from . import (run_with_wx, simtext, simclick, addall, realYield)
+
+@@ -24,7 +25,9 @@ class MyObj(props.HasProperties):
+ mypointi = props.Point(ndims=2, real=False)
+ mypointf = props.Point(ndims=2)
+
+-
++@pytest.mark.skip(reason="Known to fail on Gentoo:"
++ "https://github.com/pauldmccarthy/fsleyes-props/issues/1"
++ )
+ def test_widget_point(): run_with_wx(_test_widget_point)
+ def _test_widget_point(parent):
+
diff --git a/sci-visualization/fsleyes-props/fsleyes-props-1.6.7.ebuild b/sci-visualization/fsleyes-props/fsleyes-props-1.6.7.ebuild
new file mode 100644
index 000000000..ed283ca43
--- /dev/null
+++ b/sci-visualization/fsleyes-props/fsleyes-props-1.6.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1 virtualx
+
+MY_PN="props"
+
+DESCRIPTION="The new FSL image viewer, released with FSL 5.0.10"
+HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
+SRC_URI="https://git.fmrib.ox.ac.uk/fsl/fsleyes/${MY_PN}/-/archive/${PV}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/deprecation[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ sci-visualization/fsleyes-widgets[${PYTHON_USEDEP}]
+ dev-python/fslpy[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/fsleyes-props-1.6.7-coverage.patch"
+ "${FILESDIR}/fsleyes-props-1.6.7-tests.patch"
+)
+
+python_test() {
+ virtx pytest --verbose || die
+}
diff --git a/sci-visualization/fsleyes-props/metadata.xml b/sci-visualization/fsleyes-props/metadata.xml
new file mode 100644
index 000000000..cc3ce2d75
--- /dev/null
+++ b/sci-visualization/fsleyes-props/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chr@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ FSLeyes-props is a library which is used by FSLeyes, and which allows you to
+ listen for change to attributes on a python object, automatically generate
+ wxpython widgets which are bound to attributes of a python object, and
+ automatically generate a command line interface to set values of the attributes
+ of a Python object.
+ </longdescription>
+</pkgmetadata>