aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-08-25 15:22:54 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-08-25 15:22:54 +0200
commitf188fc8820c0dd0fab65638998455637e55f98c9 (patch)
tree498b24b8094c7b931fb2f39d2d80d353276b6bfc
parentdev-python/jupyter_client: Add missing dep: ipykernel (required for testing) (diff)
downloadsci-f188fc88.tar.gz
sci-f188fc88.tar.bz2
sci-f188fc88.zip
dev-python/notebook: Enable doc useflag
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/notebook/ChangeLog3
-rw-r--r--dev-python/notebook/notebook-9999.ebuild6
2 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/notebook/ChangeLog b/dev-python/notebook/ChangeLog
index 2daf6ed3d..ba65bee5f 100644
--- a/dev-python/notebook/ChangeLog
+++ b/dev-python/notebook/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 25 Aug 2015; Marius Brehler <marbre@linux.sungazer.de> notebook-9999.ebuild:
+ dev-python/notebook: Enable doc useflag
+
*notebook-4.0.1 (13 Aug 2015)
*notebook-9999 (13 Aug 2015)
diff --git a/dev-python/notebook/notebook-9999.ebuild b/dev-python/notebook/notebook-9999.ebuild
index ba9ce57fc..242663aef 100644
--- a/dev-python/notebook/notebook-9999.ebuild
+++ b/dev-python/notebook/notebook-9999.ebuild
@@ -20,11 +20,12 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="test"
+IUSE="doc test"
CDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${CDEPEND}
dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.3.3[${PYTHON_USEDEP}]
>=www-servers/tornado-4.0[${PYTHON_USEDEP}]
dev-python/ipython_genutils[${PYTHON_USEDEP}]
dev-python/traitlets[${PYTHON_USEDEP}]
@@ -39,6 +40,9 @@ DEPEND="${RDEPEND}
>=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
)
+ doc? (
+ >=dev-python/sphinx-1.1[${PYTHON_USEDEP}]
+ )
"
python_test() {