aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-09-26 05:18:08 -0400
committerHorea Christian <chr@chymera.eu>2020-09-26 05:18:08 -0400
commitf5b04b681df6b6acb9a840eea614905639b6e1a1 (patch)
treedcd43fb0cbca7d0ed41ff9129f45aad80bbc97ba
parentdev-python/nbviewer: removed package with no stable releases (diff)
downloadsci-f5b04b68.tar.gz
sci-f5b04b68.tar.bz2
sci-f5b04b68.zip
sci-biology/mne-python: removed package with unavailable dep
mne-python needs mayavi. Unless we can distribute that we can't distribute this. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--sci-biology/mne-python/Manifest1
-rw-r--r--sci-biology/mne-python/metadata.xml11
-rw-r--r--sci-biology/mne-python/mne-python-0.7.ebuild56
-rw-r--r--sci-biology/mne-python/mne-python-9999.ebuild54
4 files changed, 0 insertions, 122 deletions
diff --git a/sci-biology/mne-python/Manifest b/sci-biology/mne-python/Manifest
deleted file mode 100644
index 38d6e3b27..000000000
--- a/sci-biology/mne-python/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST v0.7.zip 58120981 SHA256 26711803c8068adc7f3c06997b6bd1e076fea170e9f87af3b488c51eb6e3caa9 SHA512 1221038daa9687e358c7b51aed969c0174e5ea979e35c2e2663a5d2795b751f837bb8e1f45fd12251f713b6b69a5c5086e8f07d417e23abfa4302562f271f774 WHIRLPOOL a44c067c02270285103ad978d2d1afbf46972ad39eeec77548d78bb1515bd4a22fca713c2e814d5b462b09ce3caad2696deda1b09f67ed9f3c8f0a74de3fdaee
diff --git a/sci-biology/mne-python/metadata.xml b/sci-biology/mne-python/metadata.xml
deleted file mode 100644
index d9ac16118..000000000
--- a/sci-biology/mne-python/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">mne-tools/mne-python</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-biology/mne-python/mne-python-0.7.ebuild b/sci-biology/mne-python/mne-python-0.7.ebuild
deleted file mode 100644
index 2b67a1330..000000000
--- a/sci-biology/mne-python/mne-python-0.7.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Python package for MEG and EEG data analysis"
-HOMEPAGE="http://martinos.org/mne/mne-python.html"
-SRC_URI="https://github.com/mne-tools/mne-python/archive/v${PV}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-#IUSE="cuda test"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- sci-libs/scikits_learn[${PYTHON_USEDEP}]
- dev-python/joblib[${PYTHON_USEDEP}]
- sci-libs/nibabel[${PYTHON_USEDEP}]
- sci-biology/pysurfer[${PYTHON_USEDEP}]
- sci-visualization/mayavi
- dev-python/matplotlib[${PYTHON_USEDEP}]"
-
-# cuda? (
-# dev-python/pycuda[${PYTHON_USEDEP}]
-# dev-python/scikits-cuda[${PYTHON_USEDEP}]
-# )
-#"
-
-DEPEND="
- test? ( dev-python/nose ${RDEPEND} )
-"
-
-S="${WORKDIR}/mne-python-${PV}"
-
-run_test() {
- PYTHONPATH=. MNE_SKIP_SAMPLE_DATASET_TESTS=1 nosetests -v mne
-}
-
-python_test() {
- distutils_install_for_testing
- esetup.py install --root="${T}/test-${EPYTHON}" --no-compile
- # Link to test data that won't be included in the final installation
- local TEST_DIR="${T}/test-${EPYTHON}/$(python_get_sitedir)"
- cd "${S}" || die
- find . -type d -name data -exec ln -s "${S}"/{} ${TEST_DIR}/{} \; || die
- cd ${TEST_DIR} || die
- VIRTUALX_COMMAND="run_test"
- virtualmake
-}
diff --git a/sci-biology/mne-python/mne-python-9999.ebuild b/sci-biology/mne-python/mne-python-9999.ebuild
deleted file mode 100644
index 2c90c0d32..000000000
--- a/sci-biology/mne-python/mne-python-9999.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 git-r3 virtualx
-
-DESCRIPTION="Python package for MEG and EEG data analysis"
-HOMEPAGE="http://martinos.org/mne/mne-python.html"
-EGIT_REPO_URI="https://github.com/mne-tools/mne-python.git"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-#IUSE="cuda test"
-KEYWORDS=""
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- sci-libs/scikits_learn[${PYTHON_USEDEP}]
- dev-python/joblib[${PYTHON_USEDEP}]
- sci-libs/nibabel[${PYTHON_USEDEP}]
- sci-biology/pysurfer[${PYTHON_USEDEP}]
- sci-visualization/mayavi
- dev-python/matplotlib[${PYTHON_USEDEP}]"
-
-# cuda? (
-# dev-python/pycuda[${PYTHON_USEDEP}]
-# dev-python/scikits-cuda[${PYTHON_USEDEP}]
-# )
-#"
-
-DEPEND="
- test? ( dev-python/nose ${RDEPEND} )
-"
-
-run_test() {
- PYTHONPATH=. MNE_SKIP_SAMPLE_DATASET_TESTS=1 nosetests -v mne
-}
-
-python_test() {
- distutils_install_for_testing
- esetup.py install --root="${T}/test-${EPYTHON}" --no-compile
- # Link to test data that won't be included in the final installation
- local TEST_DIR="${T}/test-${EPYTHON}/$(python_get_sitedir)"
- cd "${S}" || die
- find . -type d -name data -exec ln -s "${S}"/{} ${TEST_DIR}/{} \; || die
- cd ${TEST_DIR} || die
- VIRTUALX_COMMAND="run_test"
- virtualmake
-}