aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-12-20 21:01:27 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-12-20 21:01:35 +0800
commitf66ac0c6904b9f69ec44eb9b368c9e754b1b26e1 (patch)
treec1ce925efe858c1c9013091de9734c17f709f03c
parentsci-physics/uproot: remove with its dependencies. (diff)
downloadsci-f66ac0c6904b9f69ec44eb9b368c9e754b1b26e1.tar.gz
sci-f66ac0c6904b9f69ec44eb9b368c9e754b1b26e1.tar.bz2
sci-f66ac0c6904b9f69ec44eb9b368c9e754b1b26e1.zip
sci-libs/pytorch: migrate from cmake-utils to cmake.
Suggested-by: kenshin33, Hendrik Klug <hendrik.klug@gmail.com> Closes: https://github.com/gentoo/sci/issues/992 Closes: https://bugs.gentoo.org/755101 Closes: https://bugs.gentoo.org/754342 Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--sci-libs/pytorch/pytorch-1.6.0-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sci-libs/pytorch/pytorch-1.6.0-r1.ebuild b/sci-libs/pytorch/pytorch-1.6.0-r1.ebuild
index 0708ef6d3..807308c4e 100644
--- a/sci-libs/pytorch/pytorch-1.6.0-r1.ebuild
+++ b/sci-libs/pytorch/pytorch-1.6.0-r1.ebuild
@@ -125,7 +125,8 @@ src_unpack() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
+ eapply_user
mv -v third_party/miniz-* ../ || die
rm -r third_party || die
@@ -216,7 +217,7 @@ src_configure() {
-DBLAS=${blas}
)
- cmake-utils_src_configure
+ cmake_src_configure
if use python; then
CMAKE_BUILD_DIR="${BUILD_DIR}" distutils-r1_src_configure
@@ -227,7 +228,7 @@ src_configure() {
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use python; then
CMAKE_BUILD_DIR=${BUILD_DIR} distutils-r1_src_compile
@@ -235,7 +236,7 @@ src_compile() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
local LIB=$(get_libdir)
if [[ ${LIB} != lib ]]; then