aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-09-01 16:05:06 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-09-01 16:07:58 -0500
commitf6af5d93e2ecbed116c5a9aa35c86261d5ab67b1 (patch)
treea63feae9706c7ce32ad8507e0b6d694ac0e295b7
parentsci-libs/libsc: add openmp and threads use flags (diff)
downloadsci-f6af5d93.tar.gz
sci-f6af5d93.tar.bz2
sci-f6af5d93.zip
sci-libs/p4est: add openmp and threads use flags
Package-Manager: portage-2.2.28
-rw-r--r--sci-libs/p4est/p4est-9999.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/sci-libs/p4est/p4est-9999.ebuild b/sci-libs/p4est/p4est-9999.ebuild
index 05f4f1b52..33c371d71 100644
--- a/sci-libs/p4est/p4est-9999.ebuild
+++ b/sci-libs/p4est/p4est-9999.ebuild
@@ -26,16 +26,17 @@ fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="debug doc examples mpi romio static-libs +vtk-binary"
+# TODO petsc
+IUSE="debug doc examples mpi openmp romio static-libs threads +vtk-binary"
REQUIRED_USE="romio? ( mpi )"
RDEPEND="
- >=sci-libs/libsc-1.0[mpi,romio]
+ >=sci-libs/libsc-1.0[mpi=,openmp=,romio=,threads=]
dev-lang/lua:*
sys-apps/util-linux
virtual/blas
virtual/lapack
- mpi? ( virtual/mpi[romio?] )"
+ mpi? ( virtual/mpi[romio=] )"
DEPEND="
${RDEPEND}
@@ -47,6 +48,13 @@ DOCS=( AUTHORS NEWS README )
AT_M4DIR="${WORKDIR}/${P}/config ${WORKDIR}/${P}/sc/config"
AUTOTOOLS_AUTORECONF=true
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && use openmp; then
+ tc-has-openmp || \
+ die "Please select an openmp capable compiler like gcc[openmp]"
+ fi
+}
+
src_prepare() {
# Inject libsc to get all parts of the build system...
if ! [[ ${PV} = *9999* ]]; then
@@ -76,10 +84,13 @@ src_configure() {
local myeconfargs=(
$(use_enable debug)
$(use_enable mpi)
+ $(use_enable openmp)
$(use_enable romio mpiio)
$(use_enable vtk-binary)
+ $(use_enable threads pthread)
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ $(use_with petsc)
--with-sc="${EPREFIX}/usr"
)
autotools-utils_src_configure