aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-10 13:45:23 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-10-10 13:45:23 +0000
commitfc5c07038aa37eb1444eeac10b2c546944013e1f (patch)
treee73a6844519bcf701987e2b07a677289a8af689c
parentdev-perl/Config-Std: version bump to 0.903 (diff)
downloadsci-fc5c0703.tar.gz
sci-fc5c0703.tar.bz2
sci-fc5c0703.zip
sci-biology/weblogo: version bump to 3.7.5
really cool package, can't do bio without this Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--sci-biology/weblogo/Manifest1
-rw-r--r--sci-biology/weblogo/weblogo-3.7.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sci-biology/weblogo/Manifest b/sci-biology/weblogo/Manifest
index eb9181eff..46ab61a85 100644
--- a/sci-biology/weblogo/Manifest
+++ b/sci-biology/weblogo/Manifest
@@ -1 +1,2 @@
+DIST weblogo-3.7.5.tar.gz 817128 BLAKE2B f7619b6ea0c944fb21b8acdfc9593d6223e7d48ac9495c872c3bcadc0187249883b013e44bec70ce126d820abb6281b2e5ef5f04126e7a288c3f5a1026612ab0 SHA512 7fbf71854eee0bcebebe926f2c93653b0b8475462ed5b3dc951947cec67a37bee801d468f893932257f5bdca8c754264c3279695cdb3da747bd82e9353392c0b
DIST weblogo.2.8.2.tar.gz 303971 BLAKE2B fd3dd23e94a534d8a0e62331053913ca9558270a3d55484c9e9ff49bc88f3f9cd6b44a6c4dfdfdd6163327be7579b43c02722830892576ef309542fb42cd59fc SHA512 05fe94db1c82d78913141dde650d2f6c7e851e88c5b4a7707253103e562d44f9cac318a8037f14dbe605c0f5ec3a89bb806a0c199d4c43eb018ed66a980e535d
diff --git a/sci-biology/weblogo/weblogo-3.7.5.ebuild b/sci-biology/weblogo/weblogo-3.7.5.ebuild
new file mode 100644
index 000000000..ea07941ff
--- /dev/null
+++ b/sci-biology/weblogo/weblogo-3.7.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="generate consensus sequence logo figures"
+HOMEPAGE="http://weblogo.threeplusone.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/scipy
+"
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/mypy
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}