aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-30 10:31:03 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-30 10:31:03 +0100
commitfd57fb2706919f70446dc9e90e93ba9ba96179b3 (patch)
tree93193281cdfc4cfa4ea68a8cebc2ef901ba9312f
parentsci-libs/cgnstools: remove pack, replace by cgnslib[tools] (diff)
downloadsci-fd57fb2706919f70446dc9e90e93ba9ba96179b3.tar.gz
sci-fd57fb2706919f70446dc9e90e93ba9ba96179b3.tar.bz2
sci-fd57fb2706919f70446dc9e90e93ba9ba96179b3.zip
sci-libs/ciftilib: version bump, EAPI bump, cmake-utils-->cmake
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-libs/ciftilib/Manifest2
-rw-r--r--sci-libs/ciftilib/ciftilib-1.6.0.ebuild (renamed from sci-libs/ciftilib/ciftilib-1.5.3-r1.ebuild)16
-rw-r--r--sci-libs/ciftilib/files/ciftilib-1.5.3-openmp_in_pc.patch12
3 files changed, 7 insertions, 23 deletions
diff --git a/sci-libs/ciftilib/Manifest b/sci-libs/ciftilib/Manifest
index 7eecc1b4d..ddc2bbc19 100644
--- a/sci-libs/ciftilib/Manifest
+++ b/sci-libs/ciftilib/Manifest
@@ -1 +1 @@
-DIST ciftilib-1.5.3.tar.gz 1727910 BLAKE2B 21433e6bfdfa51b741bf90d1dfa18fc812fb3e2017a5d2b77c73d01d4ed59389f47b50423cf67d98cf92f6c662c2803c7af2978278f509ae933e70ca85fcf40b SHA512 bb264b532edd50a47ddf48f5e7a48843a70632c2a3d8770c3b2ce4937c5559111047e553d7d48a06bc32acafd2fe251ae61859f80b17e63df7a02a2e4e669fc0
+DIST ciftilib-1.6.0.tar.gz 1728524 BLAKE2B 37144e477709fbab4afa63fb3947216de5a4b21bc36057f119625eea0beaa79ccb0ddc1ce77f4b28f2bee8eb8a5b6e0360df0ccbcc8d80d3033dd64ec7961f12 SHA512 414cb598800abb3dc9c52d9fcc1db1ec4ee019497e5dc950f7cfc3110ea2d83f7da3a5f16bc337058be74afbabe1bba8b1376dc984bb8ec27ba48f80ee89f85a
diff --git a/sci-libs/ciftilib/ciftilib-1.5.3-r1.ebuild b/sci-libs/ciftilib/ciftilib-1.6.0.ebuild
index ad4894dd1..062fa44ef 100644
--- a/sci-libs/ciftilib/ciftilib-1.5.3-r1.ebuild
+++ b/sci-libs/ciftilib/ciftilib-1.6.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="C++ Library for reading and writing CIFTI-2 and CIFTI-1 files"
HOMEPAGE="https://github.com/Washington-University/CiftiLib"
@@ -22,10 +22,6 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.3-openmp_in_pc.patch
- )
-
S="${WORKDIR}/CiftiLib-${PV}"
#TODO: Enable doc building and installation
@@ -42,14 +38,14 @@ src_prepare(){
-e "s:DT_:CIFTI_DT_:g" \
-i `grep -rl DT_ *`
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(-DBUILD_SHARED_LIBS=ON)
use qt5 || mycmakeargs+=(-DIGNORE_QT=TRUE)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test(){
@@ -57,5 +53,5 @@ src_test(){
local myctestargs=(
-j1
)
- cmake-utils_src_test
+ cmake_src_test
}
diff --git a/sci-libs/ciftilib/files/ciftilib-1.5.3-openmp_in_pc.patch b/sci-libs/ciftilib/files/ciftilib-1.5.3-openmp_in_pc.patch
deleted file mode 100644
index 6fd35159a..000000000
--- a/sci-libs/ciftilib/files/ciftilib-1.5.3-openmp_in_pc.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/CiftiLib.pc.in b/CiftiLib.pc.in
-index 13cd78c..8db6c46 100644
---- a/CiftiLib.pc.in
-+++ b/CiftiLib.pc.in
-@@ -5,6 +5,6 @@ Name: CiftiLib
- Description: C++ Library for reading and writing CIFTI-2 and CIFTI-1 files
- Version: @CIFTILIB_VERSION@
- URL: https://github.com/Washington-University/CiftiLib
--Cflags: -I${includedir}/CiftiLib @CIFTILIB_PKGCONFIG_DEFINE@
-+Cflags: -I${includedir}/CiftiLib @CIFTILIB_PKGCONFIG_DEFINE@ @OpenMP_CXX_FLAGS@
- Libs: -L${libdir} -lCifti
- @CIFTILIB_PKGCONFIG_REQUIRES_LINE@