aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schäfer <gentryx@gmx.de>2013-08-12 16:54:49 +0200
committerAndreas Schäfer <gentryx@gmx.de>2013-08-12 16:54:49 +0200
commitfe993e8dcd55e7a8955004a677ff783468d0767d (patch)
tree1d3eb057178b4ae2d8186174aba931c8a97a20ef
parentadded missing manifest (diff)
downloadsci-fe993e8dcd55e7a8955004a677ff783468d0767d.tar.gz
sci-fe993e8dcd55e7a8955004a677ff783468d0767d.tar.bz2
sci-fe993e8dcd55e7a8955004a677ff783468d0767d.zip
added updated HPX ebuild
-rw-r--r--sys-cluster/hpx/Manifest1
-rw-r--r--sys-cluster/hpx/hpx-0.9.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-cluster/hpx/Manifest b/sys-cluster/hpx/Manifest
index 8e6e9d14b..30bd49207 100644
--- a/sys-cluster/hpx/Manifest
+++ b/sys-cluster/hpx/Manifest
@@ -1 +1,2 @@
DIST hpx_0.9.5.tar.gz 3801863 SHA256 4e9f71b70d005104142157969f5ab3a980e2594279a2fb5f79a48bf77a8bc6aa SHA512 b156935061130bd87ababc4693b936687a4098eae305b55fce3c1fa7e0aef13b24f396045b8b392131c9eb973e67a1c1e665ae192a4b6350b5d3802dae9231a7 WHIRLPOOL 41a3e28be66578f0f665470847b38e2c6e5c573cb2ada7fbb49fe07c51b9bb15b761e811299560b2f4ed2e386bff5d42c6748c1c58fe430f4d8bed1376588c2a
+DIST hpx_0.9.6.tar.gz 4506305 SHA256 937f753d5e6287bfa121d45ffe282b5f72c1c7a9bdc7cd6ca90e92169e13dba9 SHA512 37253aca00df825528dc79700cbb68de5cc9c652fdc7ebb4986f9f8fc603c789290f033d46b35b766a2a2a87c0dc9a2120d12ed300ef4fa3d4e267462906f01c WHIRLPOOL 317e9f229e10dec59e0c95ee008b33689b0728612954205eb6edc2b0014e40510fb5f026579d4f4becf9b39f4e419da0d1f7c95c1f8bc137c7da4edb8e5fe2fd
diff --git a/sys-cluster/hpx/hpx-0.9.6.ebuild b/sys-cluster/hpx/hpx-0.9.6.ebuild
new file mode 100644
index 000000000..49bfea45b
--- /dev/null
+++ b/sys-cluster/hpx/hpx-0.9.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2013-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="A general C++ runtime system for parallel and distributed applications of any scale"
+HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
+SRC_URI="http://stellar.cct.lsu.edu/files/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.48"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}/hpx-0.9.5-install-path.patch" )
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release
+ cmake-utils_src_configure
+}