aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-13 12:06:16 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-13 13:18:57 +0200
commitdebb928bf74076729f974f799716c6714421046b (patch)
tree6e06af242cffb9a8567eda32719d6b08facbc535 /app-benchmarks
parentdev-python/astropysics: Bump to EAPI=5 and distutils-r1.eclass (diff)
downloadsci-debb928bf74076729f974f799716c6714421046b.tar.gz
sci-debb928bf74076729f974f799716c6714421046b.tar.bz2
sci-debb928bf74076729f974f799716c6714421046b.zip
app-benchmarks/numbench: Bump to EAPI=5 and distutils-r1.eclass
Package-Manager: portage-2.2.0_alpha179
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/numbench/ChangeLog8
-rw-r--r--app-benchmarks/numbench/metadata.xml14
-rw-r--r--app-benchmarks/numbench/numbench-0.2.ebuild28
-rw-r--r--app-benchmarks/numbench/numbench-9999.ebuild28
4 files changed, 42 insertions, 36 deletions
diff --git a/app-benchmarks/numbench/ChangeLog b/app-benchmarks/numbench/ChangeLog
index f1101806f..e92e96c82 100644
--- a/app-benchmarks/numbench/ChangeLog
+++ b/app-benchmarks/numbench/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for app-benchmarks/numbench
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
-
+
+ 13 Jun 2013; Justin Lecher <jlec@gentoo.org> numbench-0.2.ebuild,
+ numbench-9999.ebuild, metadata.xml:
+ Bump to EAPI=5 and distutils-r1.eclass
+
29 Sep 2012; SĂ©bastien Fabbro <bicatali@gentoo.org>
-numbench-0.2_beta4-r1.ebuild, -numbench-0.2_beta4.ebuild,
numbench-0.2.ebuild, numbench-9999.ebuild:
diff --git a/app-benchmarks/numbench/metadata.xml b/app-benchmarks/numbench/metadata.xml
index 5868b425e..03b2c774e 100644
--- a/app-benchmarks/numbench/metadata.xml
+++ b/app-benchmarks/numbench/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <maintainer>
- <email>andyspiros@gmail.com</email>
- <name>Andrea Arteaga</name>
- <description>Google Summer of Code 2011 student</description>
- </maintainer>
- <longdescription>This package contains a set of scripts developed during the Google Summer of Code 2011 project. It aims to benchmark numerical libraries, and more precisely implementations of the standard BLAS, CBLAS, LAPACK, PBLAS, ScaLAPACK and the library FFTW.</longdescription>
+ <herd>sci</herd>
+ <maintainer>
+ <email>andyspiros@gmail.com</email>
+ <name>Andrea Arteaga</name>
+ <description>Google Summer of Code 2011 student</description>
+ </maintainer>
+ <longdescription>This package contains a set of scripts developed during the Google Summer of Code 2011 project. It aims to benchmark numerical libraries, and more precisely implementations of the standard BLAS, CBLAS, LAPACK, PBLAS, ScaLAPACK and the library FFTW.</longdescription>
</pkgmetadata>
diff --git a/app-benchmarks/numbench/numbench-0.2.ebuild b/app-benchmarks/numbench/numbench-0.2.ebuild
index fb279c427..74ca01834 100644
--- a/app-benchmarks/numbench/numbench-0.2.ebuild
+++ b/app-benchmarks/numbench/numbench-0.2.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=5
-inherit eutils distutils
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 vcs-snapshot
DESCRIPTION="Automated benchmarks suite"
HOMEPAGE="http://soc.dev.gentoo.org/~spiros"
@@ -17,19 +19,17 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="!app-admin/eselect-blas
- !app-admin/eselect-cblas
- !app-admin/eselect-lapack
- >=dev-python/matplotlib-1.0.0
- >=app-admin/eselect-1.3.2-r100"
-
-S="${WORKDIR}/andyspiros-numbench-${CID}"
+RDEPEND="
+ !app-admin/eselect-blas
+ !app-admin/eselect-cblas
+ !app-admin/eselect-lapack
+ >=dev-python/matplotlib-1.0.0
+ >=app-admin/eselect-1.3.2-r100"
-src_install() {
- distutils_src_install
+python_install_all() {
+ distutils-r1_python_install_all
- chmod +x exec.py
- newbin exec.py numbench
+ python_parallel_foreach_impl python_newscript exec.py numbench
insinto /usr/share/numbench/samples
doins samples/*.xml
diff --git a/app-benchmarks/numbench/numbench-9999.ebuild b/app-benchmarks/numbench/numbench-9999.ebuild
index 98d4d6d5f..fa358ef53 100644
--- a/app-benchmarks/numbench/numbench-9999.ebuild
+++ b/app-benchmarks/numbench/numbench-9999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=5
-inherit eutils git-2 distutils
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit git-2 distutils-r1
DESCRIPTION="Automated benchmarks suite"
HOMEPAGE="http://soc.dev.gentoo.org/~spiros"
@@ -17,20 +19,20 @@ KEYWORDS=""
IUSE=""
-RDEPEND="!app-admin/eselect-blas
- !app-admin/eselect-cblas
- !app-admin/eselect-lapack
- >=dev-python/matplotlib-1.0.0
- >=app-admin/eselect-1.3.2-r100"
+RDEPEND="
+ !app-admin/eselect-blas
+ !app-admin/eselect-cblas
+ !app-admin/eselect-lapack
+ >=dev-python/matplotlib-1.0.0
+ >=app-admin/eselect-1.3.2-r100"
-src_install() {
- distutils_src_install
+python_install_all() {
+ distutils-r1_python_install_all
- chmod +x exec.py
- newbin exec.py numbench
+ python_parallel_foreach_impl python_newscript exec.py numbench
insinto /usr/share/numbench/samples
- doins samples/*xml
+ doins samples/*.xml
doman doc/numbench.1
}