aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-05-21 14:26:00 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-05-21 14:26:00 +0200
commit3d80e4ae6a859f3a51dc77b1470622572177a312 (patch)
treea02c9d3cb710ee9a557ae33ef81f085531fe2b4e /dev-libs
parentdev-util/f90cache: Version bump (diff)
downloadsci-3d80e4ae6a859f3a51dc77b1470622572177a312.tar.gz
sci-3d80e4ae6a859f3a51dc77b1470622572177a312.tar.bz2
sci-3d80e4ae6a859f3a51dc77b1470622572177a312.zip
dev-libs/utf8proc: Version bump
Package-Manager: portage-2.2.18
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/utf8proc/ChangeLog8
-rw-r--r--dev-libs/utf8proc/Manifest1
-rw-r--r--dev-libs/utf8proc/files/utf8proc-1.2-buildflags.patch14
-rw-r--r--dev-libs/utf8proc/utf8proc-1.2.ebuild31
4 files changed, 53 insertions, 1 deletions
diff --git a/dev-libs/utf8proc/ChangeLog b/dev-libs/utf8proc/ChangeLog
index f5afbed53..f822d346b 100644
--- a/dev-libs/utf8proc/ChangeLog
+++ b/dev-libs/utf8proc/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for dev-libs/utf8proc
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*utf8proc-1.2 (21 May 2015)
+
+ 21 May 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +files/utf8proc-1.2-buildflags.patch, +utf8proc-1.2.ebuild:
+ Version bump
+
02 Apr 2014; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
utf8proc-1.1.6.ebuild:
dev-libs/utf8proc: Keyworded for amd64-linux x86-linux
diff --git a/dev-libs/utf8proc/Manifest b/dev-libs/utf8proc/Manifest
index 4459cdb6a..7d19b7696 100644
--- a/dev-libs/utf8proc/Manifest
+++ b/dev-libs/utf8proc/Manifest
@@ -1 +1,2 @@
+DIST utf8proc-1.2.tar.gz 137294 SHA256 9b07ffe12e049974d120f1558459f6ba9b44681c182ac738ca96fb70aa842fd9 SHA512 066b77d599320e0f6d90e52f6ae482c3caf54276920ad4afacaf4d0c4969d94aa33401e63edee14b2887cdf60fdffd07f913d246212aac1a26b480f20cbc24d4 WHIRLPOOL 597f30c1f1b6d413d9ab7b81c203d01386a949bf33a99eb0bf90ffb7b2c560b78b55ad02d074bff57ecaccda46db991d0bbb9dcf113756c87914a488a2e44762
DIST utf8proc-v1.1.6.tar.gz 105825 SHA256 fedc8fa78022eb8f0584fbc85c9f9571bcd7fd510de0ce16955289c42f4199e7 SHA512 3bec2388298c201d9d6992cdd36330f1109d26a37b3411ba633f006f40da9e494ba0565051b763a7d3014e6113cd1e7754e6b95d5cbb2d7b50cee55193f0fdc1 WHIRLPOOL c211419407e80893b66fa7586a8148e9b2e45c89d2d31878658a4ae7f0b1ca72e269cef234ca8b30e27e4bac5a48715520dd546f6605af773d6e165ef76f81b0
diff --git a/dev-libs/utf8proc/files/utf8proc-1.2-buildflags.patch b/dev-libs/utf8proc/files/utf8proc-1.2-buildflags.patch
new file mode 100644
index 000000000..4d583e417
--- /dev/null
+++ b/dev-libs/utf8proc/files/utf8proc-1.2-buildflags.patch
@@ -0,0 +1,14 @@
+Adjust build flags. Proted from 1.1.6.
+
+Patch by Marius Brehler.
+--- Makefile
++++ Makefile
+@@ -6,7 +6,7 @@ AR=ar
+ INSTALL=install
+
+ # compiler settings
+-cflags = -O2 -std=c99 -pedantic -Wall -fpic -DUTF8PROC_EXPORTS $(CFLAGS)
++cflags = -std=c99 -pedantic -fpic -DUTF8PROC_EXPORTS $(CFLAGS)
+ cc = $(CC) $(cflags)
+
+ # shared-library version MAJOR.MINOR.PATCH ... this may be *different*
diff --git a/dev-libs/utf8proc/utf8proc-1.2.ebuild b/dev-libs/utf8proc/utf8proc-1.2.ebuild
new file mode 100644
index 000000000..349806f39
--- /dev/null
+++ b/dev-libs/utf8proc/utf8proc-1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="library for processing UTF-8 encoded Unicode strings"
+HOMEPAGE="http://www.public-software-group.org/utf8proc"
+SRC_URI="https://github.com/JuliaLang/${PN}/archive/v1.2.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${P}"-buildflags.patch
+}
+
+src_compile() {
+ emake libutf8proc.so
+ use static-libs & emake libutf8proc.a
+}
+
+src_install() {
+ doheader utf8proc.h
+ dolib.so libutf8proc.so
+ use static-libs && dolib.a libutf8proc.a
+}