aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-11-28 14:48:03 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2016-11-28 14:48:03 +0100
commit941b616a9cfdae9f11d7a658b00d45ae72484ba9 (patch)
tree133944ac32a0c619783a39ea7fc560f7f05f4499 /dev-libs
parentsci-libs/clfft: Version bump to 2.12.2 (diff)
downloadsci-941b616a9cfdae9f11d7a658b00d45ae72484ba9.tar.gz
sci-941b616a9cfdae9f11d7a658b00d45ae72484ba9.tar.bz2
sci-941b616a9cfdae9f11d7a658b00d45ae72484ba9.zip
dev-libs/opencl-clhpp: New ebuild providing C++ headers for OpenCL development
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/opencl-clhpp/Manifest1
-rw-r--r--dev-libs/opencl-clhpp/metadata.xml12
-rw-r--r--dev-libs/opencl-clhpp/opencl-clhpp-2.0.10.ebuild29
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/opencl-clhpp/Manifest b/dev-libs/opencl-clhpp/Manifest
new file mode 100644
index 000000000..2e17caf8c
--- /dev/null
+++ b/dev-libs/opencl-clhpp/Manifest
@@ -0,0 +1 @@
+DIST opencl-clhpp-2.0.10.tar.gz 129954 SHA256 fa27456295c3fa534ce824eb0314190a8b3ebd3ba4d93a0b1270fc65bf378f2b SHA512 4a4898540c55422ca0cc6ba7f0c5495b915fc34df50f8add90e7f06dd5ef1d01a767234ecdee3757292980aa2f938e773177bcc73f28ac9c1b42d386863dea58 WHIRLPOOL 7f9fd0407e1aa6cd35bd8583fb8dfce45ea6841b507102a24bcb375752629374679bda3a77fdc228e18b56debc0e0c2ebbfde71a81b0281a896e34d044bc466a
diff --git a/dev-libs/opencl-clhpp/metadata.xml b/dev-libs/opencl-clhpp/metadata.xml
new file mode 100644
index 000000000..222c1e307
--- /dev/null
+++ b/dev-libs/opencl-clhpp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata> \ No newline at end of file
diff --git a/dev-libs/opencl-clhpp/opencl-clhpp-2.0.10.ebuild b/dev-libs/opencl-clhpp/opencl-clhpp-2.0.10.ebuild
new file mode 100644
index 000000000..9d7132510
--- /dev/null
+++ b/dev-libs/opencl-clhpp/opencl-clhpp-2.0.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_PN="OpenCL-CLHPP"
+
+DESCRIPTION="OpenCL Host API C++ bindings (cl.hpp and cl2.hpp)"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-CLHPP"
+SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT-KhronosGroup"
+SLOT="0"
+IUSE="examples"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCS=OFF
+ -DBUILD_EXAMPLES=OFF
+ -DBUILD_TESTS=OFF
+ )
+ cmake-utils_src_configure
+} \ No newline at end of file