aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-14 22:19:31 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-14 22:19:31 +0100
commitaf310e85ff9cff3853902d61fe8afd2446c507a4 (patch)
treecc05faa0585922f6aab268dba905d32a4262ecde /dev-python/specutils/specutils-1.1.1.ebuild
parentdev-python/gwcs: new dep of specutils (diff)
downloadsci-af310e85ff9cff3853902d61fe8afd2446c507a4.tar.gz
sci-af310e85ff9cff3853902d61fe8afd2446c507a4.tar.bz2
sci-af310e85ff9cff3853902d61fe8afd2446c507a4.zip
dev-python/specutils: bump python targets, add new deps
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/specutils/specutils-1.1.1.ebuild')
-rw-r--r--dev-python/specutils/specutils-1.1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/specutils/specutils-1.1.1.ebuild b/dev-python/specutils/specutils-1.1.1.ebuild
new file mode 100644
index 000000000..24f1d3118
--- /dev/null
+++ b/dev-python/specutils/specutils-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Package for spectroscopic astronomical data"
+HOMEPAGE="https://github.com/astropy/specutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Requires access to the internet
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/asdf[${PYTHON_USEDEP}]
+ >=dev-python/astropy-4.0[${PYTHON_USEDEP}]
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/gwcs[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
+
+# Bug: https://bugs.gentoo.org/703778
+#distutils_enable_sphinx docs dev-python/sphinx-astropy
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # do not depend on pytest-datafiles
+ sed -i -e '/addopts =/d' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}