aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Gonçalves <camaradadennis@gmail.com>2023-09-02 11:23:32 -0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-05 13:05:28 +0200
commit73dbd35fdd9ad310ed136ad1bb5257ca0fad3e7a (patch)
treee2b13f28d9483a2f5bda5d78fe32d0ed493b39c6 /dev-python
parentsci-biology/BEP032tools: new package, add 0.0.1_alpha (diff)
downloadsci-73dbd35fdd9ad310ed136ad1bb5257ca0fad3e7a.tar.gz
sci-73dbd35fdd9ad310ed136ad1bb5257ca0fad3e7a.tar.bz2
sci-73dbd35fdd9ad310ed136ad1bb5257ca0fad3e7a.zip
dev-python/geopandas: add 0.13.2, drop 0.12.2
Closes: https://github.com/gentoo/sci/pull/1217 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/geopandas/Manifest2
-rw-r--r--dev-python/geopandas/geopandas-0.13.2.ebuild (renamed from dev-python/geopandas/geopandas-0.12.2.ebuild)8
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/geopandas/Manifest b/dev-python/geopandas/Manifest
index 23cd9b3d5..037a125d3 100644
--- a/dev-python/geopandas/Manifest
+++ b/dev-python/geopandas/Manifest
@@ -1 +1 @@
-DIST geopandas-0.12.2.gh.tar.gz 6360014 BLAKE2B ded0b7fdff88f91ad02f690013b92b4fd7378742fbe01473a0351164df526fe4ca7cbfb1097b79311d2f6c3fa4301199cf7862befe970e4b6fa6a0d8c1317c38 SHA512 6470bf45360bb6486607870ee643f295a8823ce3109b777ec9d1eb576bc11c717d3dc40777481748ffe8d17a6d9869245efff5298bea274ec108ca9d0b1502ba
+DIST geopandas-0.13.2.gh.tar.gz 6388249 BLAKE2B 910f32ea7d798bbdeee77be190c57daf7bdc719901a2183b5328ec13619ff9b4145d1717afed8fc71da154d84f388ce2bc30c541478f95ed121c7d8681c691ae SHA512 4dff4bfeca2490081c02c41edf92037fa8a8f4b030b6f6a0cdc231b3119f829604af39277125db9535c66aac0698d2d4dcfac2bb58b92d31bea83f0ee296e21a
diff --git a/dev-python/geopandas/geopandas-0.12.2.ebuild b/dev-python/geopandas/geopandas-0.13.2.ebuild
index 10edebed5..921c13417 100644
--- a/dev-python/geopandas/geopandas-0.12.2.ebuild
+++ b/dev-python/geopandas/geopandas-0.13.2.ebuild
@@ -25,9 +25,10 @@ distutils_enable_tests pytest
python_test() {
local deselect=(
- # disable tests due to networking being blocked
- geopandas/io/tests/test_file.py::test_read_file_remote_zipfile_url
- geopandas/io/tests/test_file.py::test_read_file_remote_geojson_url
+ # needs network access
+ geopandas/io/tests/test_file.py::test_read_file_url
+ # fails with RuntimeError thrown by matplotlib
+ geopandas/tests/test_plotting.py::TestGeoplotAccessor::test_pandas_kind
)
epytest ${deselect[@]/#/--deselect }
@@ -37,4 +38,5 @@ pkg_postinst() {
optfeature "plotting" dev-python/matplotlib
optfeature "spatial indexes and spatial joins" sci-libs/rtree
optfeature "geocoding" sci-geosciences/geopy
+ optfeature "geodatabase access" dev-python/psycopg dev-python/sqlalchemy
}