aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-09-14 17:15:45 +0200
committerJustin Lecher <jlec@gentoo.org>2016-09-14 16:15:45 +0100
commitc5ee7b85cafe4e073c5cb4681df7a518dd67e3c4 (patch)
tree8752608cfc8f95880de9380989afce139fdda326 /dev-python
parentsci-libs/asl: version bump to 0.1.6 (#670) (diff)
downloadsci-c5ee7b85cafe4e073c5cb4681df7a518dd67e3c4.tar.gz
sci-c5ee7b85cafe4e073c5cb4681df7a518dd67e3c4.tar.bz2
sci-c5ee7b85cafe4e073c5cb4681df7a518dd67e3c4.zip
dev-python/prov: updated python compatibility and fixed test phase (#672)
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/prov/prov-1.4.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/prov/prov-1.4.0.ebuild b/dev-python/prov/prov-1.4.0.ebuild
index cbb13de65..2fe1cd468 100644
--- a/dev-python/prov/prov-1.4.0.ebuild
+++ b/dev-python/prov/prov-1.4.0.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="6"
+EAPI=6
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1
@@ -27,6 +27,6 @@ RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/six-1.10[${PYTHON_USEDEP}]
"
-src_test() {
- ${PYTHON} -m unittest discover || die
+python_test() {
+ ${EPYTHON} -m unittest discover || die
}