aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <h.chr@mail.ru>2013-10-06 03:50:26 +0200
committerHorea Christian <h.chr@mail.ru>2013-10-06 03:50:26 +0200
commitb64c77747095de7d279d3a2fc5f9d40407666edb (patch)
treee22811fa18f3b3cf90a75708d73da95678a8c61c /dev-tex
parentInstallying python scripts now (diff)
downloadsci-b64c77747095de7d279d3a2fc5f9d40407666edb.tar.gz
sci-b64c77747095de7d279d3a2fc5f9d40407666edb.tar.bz2
sci-b64c77747095de7d279d3a2fc5f9d40407666edb.zip
Trying to debug the shebang thing
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/pythontex/pythontex-0.12.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-tex/pythontex/pythontex-0.12.ebuild b/dev-tex/pythontex/pythontex-0.12.ebuild
index 614eee74a..a45887267 100644
--- a/dev-tex/pythontex/pythontex-0.12.ebuild
+++ b/dev-tex/pythontex/pythontex-0.12.ebuild
@@ -36,20 +36,19 @@ src_compile() {
}
src_install() {
- python_optimize .
- python_fix_shebang .
-
if python_is_python3; then
python_newscript pythontex3.py pythontex.py
python_newscript depythontex3.py depythontex.py
fi
-
+
if ! python_is_python3; then
python_newscript pythontex2.py pythontex.py
- python_newscript depythontex2.py depythontex.py
python_doscript pythontex_2to3.py
+ python_newscript depythontex2.py depythontex.py
fi
-
+ python_fix_shebang
+ python_optimize .
+
latex-package_src_install
#insinto ${TEXMF}/tex/latex/${PN}